• RSS
  • Twitter
  • FaceBook

Exchange Server Forums

Forums | Register | Login | My Profile | Inbox | RSS RSS icon | My Subscription | My Forums | Address Book | Member List | Search | FAQ | Ticket List | Log Out

404 - File or directory not found

Users viewing this topic: none

Logged in as: Guest
  Printable Version
All Forums >> [Microsoft Exchange 2007] >> Outlook Web Access >> 404 - File or directory not found Page: [1]
Login
Message << Older Topic   Newer Topic >>
404 - File or directory not found - 12.Apr.2009 3:06:28 PM   
dverkissen

 

Posts: 16
Joined: 13.Aug.2007
Status: offline
Good evening people, or at least, here it is evening again :(

What turned out to be a nice day ended sitting behind my pc for about 9 hours troubleshooting my fresh installation of exchange 2007 with Server 2008.

Let me start from the beginning describing my problem and then telling you guys ( and girls ) what i have found out so far.


I have installed Server 2008 with the latest updates and so on. Then i installed AD and DNS. Again updates.
Then i installed IIS, but i did not install ASP in the beginning, forgot it.

Then i installed exchange 2007 and after installing the last features it needed i was ready and finished with the installation.

But then it started. As i though i just go to my https://localhost/owa i got a popup where i needed to fill in my credentials for logging in. But to bad, i just got an error.
As i must add, the error is different logging in locally then logging in remotely ( connecting to the web access page owa ).

Locally i get the popup telling me this when i try logging in:

HTTP Error 404.17 - Not Found
The requested content appears to be script and will not be served by the static file handler.
Detailed Error Information




Module
StaticFileModule

Notification
ExecuteRequestHandler

Handler
StaticFile

Error Code
0x80070032






Requested URL
https://localhost:443/owa/auth/logon.aspx?url=https://localhost/owa/&reason=0

Physical Path
E:\Exchange Server\ClientAccess\owa\auth\logon.aspx

Logon Method
Anonymous

Logon User

Anonymous





 
Ok, so then i tried it remotely, after my own pc cause i was working remotely trying to solve this ( not so easy found ) problem.

Error as following:



Server Error





404 - File or directory not found.
The resource you are looking for might have been removed, had its name changed, or is temporarily unavailable.


 


Ok things i have tried:

I looked at form based authentication at first cause i thought it would be that problem. But no, form based auth was allready active and changing it didn't solve anything.

Then i digged in to the certificates and also trying to connect without ssl. No solution :( Coming back to the cert. I have a godaddy turbo ssl cert and i installed that. No solution ( as i thought but i want to have tested it all ).

Finally i digged in to IIS for some time and googled myself crazy but no solution. I found out that altough handlers are marked as inherited. They don't inheret to my owa folder.
Looking in the server of a friend of mine, he has way way more handlers then me. I dont' have any aspx handler in the owa dir although i have it on the default web site saying inheret.

Thingking back on my asp missclick, by now i have it allready installed but it didn't do anything. No aspx for me in the owa dir. Anyway, i added 1 handler myself but no success still the same errors.

I once had to recreate the whole iis dirs including vdirs with a nice tut from microsoft, but i hope i don't have to do it here or reinstalling some things.

Any help would be greatly appreciated.



Update @ 22:05 ( Dutch Time )
- It has come to a major progress concerning the login to webbased e-mail owa.

What i have done:
- Remove-OwaVirtualDirectory -identity "owa (Default Web Site)"
- New-OWAVirtualDirectory -OWAVersion "Exchange2007" -Name "owa (Default Web Site)"
 
But, i still get a popup instead of a nice forum based login page. There i still need help.

- And also now all files inhereted, so aspx and so on are also in the owa dir available :)


Very small update @ 00:34
- I think i need to recreate the /exchange dir for the form based auth, people can confirm that? And also, maybe help how to recreate it. Since it is very hard to find out. 

< Message edited by dverkissen -- 13.Apr.2009 6:04:02 AM >
Post #: 1
RE: 404 - File or directory not found - 13.Apr.2009 6:06:12 AM   
dverkissen

 

Posts: 16
Joined: 13.Aug.2007
Status: offline
Problem solved, solution below:
 
Ok i solved the problem.

What you do when you have this problem is as followed:

Symthons:

1. You cannot use form based authentication and you see or not see
that when looking in IIS manager that in the /owa vdir the inhereted
aspx are not available.

2. Locally ( on the server IE ) or remotely with IE you cannot use FBA
( Form Based Authentication ) and you keep getting a popup.
3. Maybee in the beginng you experienced the problem that logging in
would generate error 404.*

That error 404 can be solved by recreating the vdir /owa in iis as
following:

- Remove-OwaVirtualDirectory -identity "owa (Default Web Site)"
- New-OWAVirtualDirectory -OWAVersion "Exchange2007" -Name "owa
(Default Web Site)"


Above stept ( without the "-" ) can be executed within the Exchange
2007 shell.


Ok, but then, you still get the formbased auth right?
But now looking in the /owa dir within iis you have enheritence right? Ok good, and bad.

What worked for me is removing the Client Access Role, CA or C as
Microsoft mentioned it.


Note, a partial role cannot be removed within the change / uninstall
option within your programs thingy in control panel.

Ok good, here we go.


To use the Setup.com command to remove an Exchange 2007 server role
Log on to the server on which you want to remove one or more Exchange
2007 server roles.

Open a Command Prompt window and navigate to the directory where you
installed the Exchange Server 2007 files. By default, this directory
is %programfiles%\Microsoft\Exchange Server.

Navigate to the \bin directory.

Note:
%programfiles%\Microsoft\Exchange Server\bin is in your path, so you
can run this command from anywhere, without navigating to this
directory.


Use the following syntax for Setup.com:

Setup.com /mode:uninstall /role:<server roles to remove>


Where <server roles to remove> must be one or more of the following,
in a comma-separated list:

HubTransport (or HT, or H)

ClientAccess (or CA, or C)

EdgeTransport (or ET, or E)

Mailbox (or MB, or M)

UnifiedMessaging (or UM, or U)

ManagementTools (or MT, or T)


As we see above i have mentioned all the roles but in my case, and
maybe yours, you only need the CA role so i die   :CA

Then i rebooted ( just to be safe offcourse ), then i went to programs
in control panel, selected exchange and clicked "change". Then i got
the setup from exchange and i put a mark at the "Client Access" role
to be installed again.

Ok, setup went on checking and gave me a error, what else.

If you get an error saying:  The Distributed Transaction Coordinator
Service Must be Started Before Setup can Continue


Go to your services and look for the "Distributed Transaction
Coordinator" service. Start or restart it and click retry within the
setup. Voila, installed. Then reboot ( Just to be safe ) and done.

Have a very nice day, you just solved your problem :)

(in reply to dverkissen)
Post #: 2

Page:   [1] << Older Topic    Newer Topic >>
All Forums >> [Microsoft Exchange 2007] >> Outlook Web Access >> 404 - File or directory not found Page: [1]
Jump to:

New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Follow TechGenix on Twitter