• RSS
  • Twitter
  • FaceBook

Exchange Server Forums

Forums | Register | Login | My Profile | Inbox | RSS RSS icon | My Subscription | My Forums | Address Book | Member List | Search | FAQ | Ticket List | Log Out

ActiveSync Server Issue

Users viewing this topic: none

Logged in as: Guest
  Printable Version
All Forums >> [Microsoft Exchange 2007] >> Mobility >> ActiveSync Server Issue Page: [1]
Login
Message << Older Topic   Newer Topic >>
ActiveSync Server Issue - 8.Dec.2008 11:38:16 AM   
chazsheen

 

Posts: 3
Joined: 8.Dec.2008
Status: offline
Hi everybody,

I know where our problem lies, but I'm not sure how to fix it. We're in our test phase of pushing out e-mail to Windows Mobile devices with Exchange 2007 SP1 living on a Windows 2008 Server. AD is Windows 2008 with domain and foreset levels running at a Windows 2003.

Everytime we try to sync a mobile device the phone returns the error code of 0x85010017 "Server is unavailable..." If I take a peek into our event logs on the CAS server I get two messages back to back:


"Removal of privileges from process "c:\windows\system32\inetsrv\w3wp.exe" (PID=7416, LABEL=MSExchangeServicesSyncPool) failed with error code 0x80070005."


The account "domain\username" does not have the correct permissions to modify the Exchange ActiveSync service privileges. Check the assigned permissions for the account that is running the Exchange ActiveSync ASP.NET process. Error code: "5".

The weird thing is that the account shown in the error message is not the same account that is being used to sync the phone. Does anybody have any ideas? The account displayed in the error message is the same domain administrator account (mine actually) every time. I went into IIS manager and edited the permissions so that domain admins have full control, but no luck on that fixing the problem.

Any and all help is greatly appreciated. Thanks!
Post #: 1
RE: ActiveSync Server Issue - 8.Dec.2008 1:05:32 PM   
Elan Shudnow

 

Posts: 897
Joined: 4.Jan.2007
From: Chicago, IL
Status: offline
Someone else was having this issue on Exchange-Experts.  They resolved it by:

There was a permission mistake in the Microsoft-ServerActiveSync virtual directory in default web site. In the Advanced settings of the virtual directory the "Physical Path Credentials" option the permission should be Application user (pass-through  authentication).

_____________________________

Elan Shudnow
Exchange MVP
http://www.shudnow.net

(in reply to chazsheen)
Post #: 2
RE: ActiveSync Server Issue - 8.Dec.2008 1:38:46 PM   
chazsheen

 

Posts: 3
Joined: 8.Dec.2008
Status: offline
Thanks Elan! Worked perfectly. Event logs cleared right up and synchronization with the handhelds is working like it's supposed to now. Thanks for your help.

(in reply to Elan Shudnow)
Post #: 3

Page:   [1] << Older Topic    Newer Topic >>
All Forums >> [Microsoft Exchange 2007] >> Mobility >> ActiveSync Server Issue Page: [1]
Jump to:

New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Follow TechGenix on Twitter