• RSS
  • Twitter
  • FaceBook

Exchange Server Forums

Forums | Register | Login | My Profile | Inbox | RSS RSS icon | My Subscription | My Forums | Address Book | Member List | Search | FAQ | Ticket List | Log Out

Added Second exchange server and need help!

Users viewing this topic: none

Logged in as: Guest
  Printable Version
All Forums >> [Microsoft Exchange 2007] >> Message Routing >> Added Second exchange server and need help! Page: [1]
Login
Message << Older Topic   Newer Topic >>
Added Second exchange server and need help! - 25.Jul.2011 7:05:46 PM   
scottjb29

 

Posts: 6
Joined: 11.Jul.2008
Status: offline
Hello Everyone!  I have built a new Exchange 2007 Server with all new hardware and a fresh install of Windows Server Standard R2 2003 Server.  I've ran all the service packs, windows updates, and all the pre-requisites needed to install Exchange 2007.  The environment already has Exchange 2007 running on another server which is working fine etc.  During the install I added this new server to the existing Exchange Organization so that both are activated and show up in the Exchange Console.

The end result will be that we'll move the mailboxes over to the new server and eventually remove the old server from running Exchange.  This will give us a new Information Store to work fresh with, and a dedicated Exchange Server.

I have moved over my mailbox as a test and everything seems to work fine receiving mail and sending / receiving internally.  Whenever I try to send mail to the outside world I get email messages that get stuck in the queue and eventually come back to me undeliverable.  I ran the mailflow troubleshooter and got the below error message:

'Remote delivery' queue (inrexchange\4) is in retry : 
The 'Remote delivery' queue (inrexchange\4) on server inrexchange is in retry status. Number of message(s) in the queue: 1. Last error information: 451 4.4.0 Primary target IP address responded with: "451 5.7.3 Cannot achieve Exchange Server authentication." Attempted failover to alternate host, but that did not succeed. Either there are no alternate hosts, or delivery failed to all alternate hosts.

Any help on where to start would be appreciated!  I've worked with Exchange for many years and this is my second migration to new hardware.  First migration with Exchange 2007.  I know it must be a firewall / smtp connector related issue.  Or am I missing something?
Post #: 1
RE: Added Second exchange server and need help! - 26.Jul.2011 8:22:55 AM   
jveldh

 

Posts: 2335
Joined: 12.Apr.2008
From: The Netherlands
Status: offline
Scott,

Ensure that no firewall is active between the servers that performs smtp inspection.
Second verify that there isn't a receive connector which only allows anonymous users and a restriction is applied per remote IP-address. If a complete subnet is configured ensure you exclude the IP from the second Exchange server.

Regards,
Johan

_____________________________

Best regards,

Johan Veldhuis

Visit my Exchange blog

(in reply to scottjb29)
Post #: 2
RE: Added Second exchange server and need help! - 26.Jul.2011 7:23:52 PM   
scottjb29

 

Posts: 6
Joined: 11.Jul.2008
Status: offline
Johan,

Thanks for the reply!  The firewall is setup to forward all SMTP traffic to the first exchange server we have setup.  That uses an address like 172.31.100.5 and the second exchange server is 172.31.100.7.  So the connections between them are both behind the same firewall and on the same subnet. 

I've made sure the subnet, default gateway, DNS entries are all correct.  This second server recieves mail just fine which tells me that the SMTP traffic forwards through the firewall to our first exchange server.  Because there in the same Exchange organization it knows the mailbox is located on the other exchange server and forwards it over.  When I respond to that same message to send a reply back it will just sit in the queue and then error out.  If that message was sent to someone internally it would be sent just fine though.

I've looked at our SMTP connecter and it seems to be configured right.  My question would be this.

1)  When an email is sent to the outside world does it route back to the other exchange server first and then send out?  Our firewall is setup to only allow SMTP outgoing traffic from the first exchange server.
2)  Another setup item I wanted to know about is under "Organization Configuration" and "Send Connectors".  Under there there is a tab for "Source Server".  My new server is not added in there.  Would that make a difference?  I know this is a simple setting someplace.

Thanks again!

(in reply to jveldh)
Post #: 3
RE: Added Second exchange server and need help! - 28.Jul.2011 8:21:52 AM   
jveldh

 

Posts: 2335
Joined: 12.Apr.2008
From: The Netherlands
Status: offline
Scott,

1) it depends if the server is listed as "source" server on the send connector it will
   try to deliver the mail.
2) if adding it here the server will also used to send mail to the internet.

Regards,
Johan

_____________________________

Best regards,

Johan Veldhuis

Visit my Exchange blog

(in reply to scottjb29)
Post #: 4
RE: Added Second exchange server and need help! - 28.Jul.2011 9:16:34 PM   
scottjb29

 

Posts: 6
Joined: 11.Jul.2008
Status: offline
Johan,

Thanks for the help!

(in reply to jveldh)
Post #: 5

Page:   [1] << Older Topic    Newer Topic >>
All Forums >> [Microsoft Exchange 2007] >> Message Routing >> Added Second exchange server and need help! Page: [1]
Jump to:

New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Follow TechGenix on Twitter