• RSS
  • Twitter
  • FaceBook

Exchange Server Forums

Forums | Register | Login | My Profile | Inbox | RSS RSS icon | My Subscription | My Forums | Address Book | Member List | Search | FAQ | Ticket List | Log Out

Autodiscover for smartphones

Users viewing this topic: none

Logged in as: Guest
  Printable Version
All Forums >> [Microsoft Exchange 2007] >> Mobility >> Autodiscover for smartphones Page: [1]
Login
Message << Older Topic   Newer Topic >>
Autodiscover for smartphones - 26.Aug.2011 3:50:58 AM   
willhackforbeer

 

Posts: 3
Joined: 26.Aug.2011
Status: offline
Hello,

We are gonna roll out a  lot of smartphones and a want to use autodiscover so users only have to enter there amailadres and password and not the url.
I already created Autodisover srv records but it won't work yet, im guessing i have to setup the WebServicesVirtualDirectory external url but i dont't now where to point it to.
Our url is https://mail.compay.com
Can someone tell me what i have to configure on our exchange 2007 server?
Post #: 1
RE: Autodiscover for smartphones - 27.Aug.2011 3:03:26 AM   
stevieg

 

Posts: 1
Joined: 19.Nov.2010
From: United Kingdom
Status: offline
If you haven't already you may wish to ensure you've set the correct ExternalURL values for your different components, in particular the ActiveSync Virtual Directory. You can check and change this using the Exchange Management Console, or using Exchange Management Shell cmdlets Get-ActiveSyncVirtualDirectory  and Set-ActiveSyncVirtualDirectory.

If you want to check what you've done so far is correct, visit www.testexchangeconnectivity.com where you can perform ActiveSync tests including the AutoDiscover component.


Not all smartphones support the SRV record technique, so you may wish to consider setting up a DNS record for autodiscover.company.com along with an appropriate SAN/UCC certificate (or a re-issue of your existing one) cert for your server incorporating that name in addition to mail.company.com


Steve

(in reply to willhackforbeer)
Post #: 2
RE: Autodiscover for smartphones - 29.Aug.2011 3:13:48 AM   
willhackforbeer

 

Posts: 3
Joined: 26.Aug.2011
Status: offline
I added the external url as https://mail.company.com and tried https://mail.company.com/Microsoft-Server-ActiveSync but it still won't work

At www.testexchangeconnectivity.com it stays on
Your test is being performed. Please wait. (Status is checked every 5 seconds) Attempting the Autodiscover and Exchange ActiveSync test (if requested).

(in reply to stevieg)
Post #: 3
RE: Autodiscover for smartphones - 31.Aug.2011 7:28:49 AM   
willhackforbeer

 

Posts: 3
Joined: 26.Aug.2011
Status: offline
I configured as described bij microsoft
http://technet.microsoft.com/en-us/library/aa998277.aspx
Set-ActiveSyncVirtualDirectory -Identity "servername\Microsoft-Server-ActiveSync (Default Web Site)" -ExternalURL "https://mail.company.com"

Set-ActiveSyncVirtualDirectory -Identity "servername\Microsoft-Server-ActiveSync (Default Web Site)" -ActiveSyncServer "https://mail.company.com"

But it still won't work, am i missing something?

(in reply to willhackforbeer)
Post #: 4

Page:   [1] << Older Topic    Newer Topic >>
All Forums >> [Microsoft Exchange 2007] >> Mobility >> Autodiscover for smartphones Page: [1]
Jump to:

New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Follow TechGenix on Twitter