• RSS
  • Twitter
  • FaceBook

Exchange Server Forums

Forums | Register | Login | My Profile | Inbox | RSS RSS icon | My Subscription | My Forums | Address Book | Member List | Search | FAQ | Ticket List | Log Out

Bad delay in receiving mail

Users viewing this topic: none

Logged in as: Guest
  Printable Version
All Forums >> [Microsoft Exchange 2003] >> General >> Bad delay in receiving mail Page: [1] 2   next >   >>
Login
Message << Older Topic   Newer Topic >>
Bad delay in receiving mail - 3.Oct.2006 2:17:54 PM   
jaxisland

 

Posts: 63
Joined: 17.Aug.2006
Status: offline
I have about 60 users running XP SP2 with Outlook 2002 SP3 and a Exchange 2003 server running on 2003 std edition.

I am noticing huge delays in receiving messages. Two local users on the same LAN can take up to 20 hours to deliver a message. This delay will sometimes also happen to mail coming in from the outside.

Is there any help for this?

Thanks
Post #: 1
RE: Bad delay in receiving mail - 3.Oct.2006 3:14:55 PM   
uemurad

 

Posts: 8232
Joined: 7.Jan.2004
From: California, USA
Status: offline
Start by running both the Best Practices Analyzer and the Exchange Troubleshooting Assistant.  Both are downloadable from Microsoft:
http://www.microsoft.com/technet/prodtechnol/exchange/downloads/2003/tools.mspx

_____________________________

Regards,

Dean T. Uemura
Microsoft MVP - Exchange (2007-2011)
exchangeguy.blogspot.com
uemurad@yahoo.com

(in reply to jaxisland)
Post #: 2
RE: Bad delay in receiving mail - 3.Oct.2006 8:20:19 PM   
jaxisland

 

Posts: 63
Joined: 17.Aug.2006
Status: offline
Nothing has cropped up with the troubleshooter or the best practices. Everything looks to be configured as it should.

Any other ideas?

Thanks for the help.

(in reply to jaxisland)
Post #: 3
RE: Bad delay in receiving mail - 3.Oct.2006 9:22:56 PM   
uemurad

 

Posts: 8232
Joined: 7.Jan.2004
From: California, USA
Status: offline
Next, I'd look at the message header for one of the delayed messages.  Note the time stamps and see if you can determine where the message is being held up.  Then I'd look at the Application and System logs for that time to see if anything can be determined.

_____________________________

Regards,

Dean T. Uemura
Microsoft MVP - Exchange (2007-2011)
exchangeguy.blogspot.com
uemurad@yahoo.com

(in reply to jaxisland)
Post #: 4
RE: Bad delay in receiving mail - 4.Oct.2006 12:57:49 PM   
jaxisland

 

Posts: 63
Joined: 17.Aug.2006
Status: offline
I am not sure what the header will tell me. That just says who it is from. I have not been able to locate any corrosponding errors in the logs...yet....I will keep looking but let me know if there is anything else I can do.

Thanks

(in reply to uemurad)
Post #: 5
RE: Bad delay in receiving mail - 4.Oct.2006 4:33:18 PM   
uemurad

 

Posts: 8232
Joined: 7.Jan.2004
From: California, USA
Status: offline
The header should be date/time stamped at every hop the message passes through.  Look for a big time gap to determine where the message is being delayed. 

If this is a purely internal message, check Message Tracking to gain some insight as to the timing.

_____________________________

Regards,

Dean T. Uemura
Microsoft MVP - Exchange (2007-2011)
exchangeguy.blogspot.com
uemurad@yahoo.com

(in reply to jaxisland)
Post #: 6
RE: Bad delay in receiving mail - 4.Oct.2006 4:55:55 PM   
primate

 

Posts: 75
Joined: 27.Oct.2005
From: Manchester, UK
Status: offline
Are the clients working offline or online?

(in reply to uemurad)
Post #: 7
RE: Bad delay in receiving mail - 4.Oct.2006 8:30:31 PM   
jaxisland

 

Posts: 63
Joined: 17.Aug.2006
Status: offline
They are all working online with Outlook 2002 SP3

(in reply to primate)
Post #: 8
RE: Bad delay in receiving mail - 5.Oct.2006 10:29:45 AM   
primate

 

Posts: 75
Joined: 27.Oct.2005
From: Manchester, UK
Status: offline
OK, just checking, I've had some misbehaving clients (users?) who were mysteriously working offline every now and then and the users would complain that they weren't receiving email for long periods.

(in reply to jaxisland)
Post #: 9
RE: Bad delay in receiving mail - 5.Oct.2006 3:32:23 PM   
acerimmer

 

Posts: 223
Joined: 2.May2001
From: Chicago,IL,USA
Status: offline
is it affecting all mail or just certain messages or just mail between these two users.


when it happens to an email from the outside, you can look at the header information (if they still have a 'from outside' email, go look at it now, post the header if you can)

for the internal folks, can you reproduce the problem? you might want to increase the logging on your mta, or watch the queues to help diagnose. any errors in the event log during email delay periods?

(in reply to primate)
Post #: 10
RE: Bad delay in receiving mail - 5.Oct.2006 4:11:45 PM   
uemurad

 

Posts: 8232
Joined: 7.Jan.2004
From: California, USA
Status: offline
Jaxisland,

In your original inquiry, you said that message delivery was taking a long time.  My questions were geared towards figuring out where the delay is happening so that you have a starting point for troubleshooting.

The BPA and ETA often point out things that aren't obvious.  You reported that those came back clean.

Next, I asked you to investigate the time stamps on messages that you have already identified as delayed.  The message header is an easy source of information when messages come in from the outside.  The Message Tracking tool in the ESM is an easy check of your logs for internal messages.  It will illustrate the processing of the message (with time stamps).  You hadn't said in your posts whether you checked Message Tracking.

What I was hoping to hear was an obvious time gap somewhere in the processing, or evidence that the message reached the recipient's mailbox in short order and that perhaps the issue is at the client-side.

_____________________________

Regards,

Dean T. Uemura
Microsoft MVP - Exchange (2007-2011)
exchangeguy.blogspot.com
uemurad@yahoo.com

(in reply to jaxisland)
Post #: 11
RE: Bad delay in receiving mail - 5.Oct.2006 8:11:21 PM   
jaxisland

 

Posts: 63
Joined: 17.Aug.2006
Status: offline
They troubleshooter came back with nothing. I cleaned up a few small things with the BPA, but since then I have not heard of an email being delayed yet. So I am still waiting to see what happens with the header info, maybe its fixed?

There is no way to reproduce the problem internal or external, it is random across all users. I have not been able to track down a single similarity in the cases where they were delayed.

I did increase the logging on the server, and I am waiting to hear if someone gets a delay.

As soon as that happens I will post back some more.

Thanks for the help.

(in reply to uemurad)
Post #: 12
RE: Bad delay in receiving mail - 5.Oct.2006 8:29:44 PM   
uemurad

 

Posts: 8232
Joined: 7.Jan.2004
From: California, USA
Status: offline
Any of the messages that were reported as delayed will still have their header information, and should still be in Message Tracking (provided it was turned on when the problem occurred).  If any of your users can identify one of the problem messages, you can still go back and analyze it.

_____________________________

Regards,

Dean T. Uemura
Microsoft MVP - Exchange (2007-2011)
exchangeguy.blogspot.com
uemurad@yahoo.com

(in reply to jaxisland)
Post #: 13
RE: Bad delay in receiving mail - 5.Oct.2006 9:12:51 PM   
theiceman

 

Posts: 5
Joined: 5.Oct.2006
Status: offline
Get an external SMTP server. 

(in reply to uemurad)
Post #: 14
RE: Bad delay in receiving mail - 5.Oct.2006 10:07:57 PM   
jaxisland

 

Posts: 63
Joined: 17.Aug.2006
Status: offline
Message tracking was enabled and those messages, according the the system manager say that all were submitted and sent in less than a minute, which doesnt explain the 12 hour delay.

Maybe something between outlook and server?

Thanks

(in reply to theiceman)
Post #: 15
RE: Bad delay in receiving mail - 5.Oct.2006 10:18:45 PM   
uemurad

 

Posts: 8232
Joined: 7.Jan.2004
From: California, USA
Status: offline
Just to clarify, your Message Tracking indicated the message was "Delivered locally to store" mentioning the mailbox name all in a timely manner, correct?

If so, there isn't an issue with your Exchange side.  Next, let's take a look at your client side.

First, when the message finally showed up, was the time/date stamp the delayed time, or the sending time?

Is the message recipient running Outlook in cache mode?  It could indicate a corruption the OST file.  You can test by checking OWA instead, or by disabling cache mode (temporarily). 

_____________________________

Regards,

Dean T. Uemura
Microsoft MVP - Exchange (2007-2011)
exchangeguy.blogspot.com
uemurad@yahoo.com

(in reply to jaxisland)
Post #: 16
RE: Bad delay in receiving mail - 9.Oct.2006 4:07:18 PM   
jaxisland

 

Posts: 63
Joined: 17.Aug.2006
Status: offline
Ok, I just got another email that was delayed. Here is the information that I have on it.

The email was sent from UserA and sent to 2 users, UserB and UserC at  5:51pm on Friday Oct 6th
I used the message tracking in the system manager and looked up the details of the email with both User B and User C as the recepient. this is what I have:
SMTP: 5:51 pm     SMTP Store Driver: Message Submitted from Store
SMTP: 5:51 pm     SMTP: Message Submited to Advanced Queing
SMTP: 5:51 pm     SMTP: Started Message Submission to Advanced Queue
SMTP: 5:51 pm     SMTP: Message Submitted to Categorizer
SMTP: 5:51 pm     SMTP: Message Categorized and Queued for Routing
SMTP: 5:51 pm     SMTP: Message Queued for Local Delivery
SMTP: 5:51 pm     SMTP: Message Delivered Locally to multiple reciepients
SMTP: 5:51 pm     SMTP: Message Delivered Locally to Store to UserB@domain.com
SMTP: 5:51 pm     SMTP: Message Delivered Locally to Store to UserC@domain.com

Thats if from the message tracking. Now In Outlook UserB recieved this email at 5:51pm on Friday October 6th.

UserC recieved the same email at 11:30am on Monday October 9th.

Most of these problems that I have seen since the BPA changes always include UserC, could this be a local problem to him or something else?

I hope the details help.

Thanks


(in reply to uemurad)
Post #: 17
RE: Bad delay in receiving mail - 9.Oct.2006 4:20:16 PM   
uemurad

 

Posts: 8232
Joined: 7.Jan.2004
From: California, USA
Status: offline
Okay - let's concentrate on UserC.  From what you've said to this point, that seems to be a common thread.

According to your Message Tracking, the message was delivered to UserC's mailbox immediately, and that all three users appear to be on the same mailbox server.  That would rule out a message transport issue.

While it's possible there is some odd problem with that user's mailbox, try to rule out the Client-side stuff first.  Is the message time stamped 11:30am 10/09/06?  Make sure there aren't any oddball rules in that mailbox.  If the time stamp is today, does it stay the same if you check that mailbox using OWA, or non-cache mode, or on a different workstation?  You might also rename the OST file and let cache mode rebuild it.

_____________________________

Regards,

Dean T. Uemura
Microsoft MVP - Exchange (2007-2011)
exchangeguy.blogspot.com
uemurad@yahoo.com

(in reply to jaxisland)
Post #: 18
RE: Bad delay in receiving mail - 10.Oct.2006 8:11:01 AM   
jaxisland

 

Posts: 63
Joined: 17.Aug.2006
Status: offline
Here is what I found:

The time stamp on the email in Outlook and OWA is 5:51pm on Friday Oct 6th. The email did not show up in his mailbox until 11:30 on the 9th.

There are no rules configured for his mailbox.

The time stamp stays the same for all.

If I rename the OST file will he lose any mail, and if you want me to do that, could you please give me a little more detail to make sure Im on the same page with you.

Thanks for the help.

(in reply to uemurad)
Post #: 19
RE: Bad delay in receiving mail - 10.Oct.2006 10:34:44 AM   
uemurad

 

Posts: 8232
Joined: 7.Jan.2004
From: California, USA
Status: offline
The OST is the offline storage used by cache mode.  It is only a copy of what is on the server.

A PST is a personal folder file.  These contain messages that have been removed from the server and stored outside the Exchange environment.  I'm not asking you to do anything with any PST files the user may have.

Renaming an OST file will not cause any loss of mail.  OST files can become corrupt and cause all sorts of issues.  When you run Outlook in cache mode, you are actually viewing the OST file.  If one doesn't exist, Outlook will rebuild it, pulling all the messages from the server. 

The fact that the timestamp is correct, but the message didn't appear points to some synchronization issue.  Whether Outlook isn't checking the server appropriately, or the message can't be stored in the OST in a timely manner suggests that there might be a problem with the OST file.

Since you also say that OWA sees the message, that means the message isn't being automatically written to a PST file (which can also become corrupt, but that doesn't appear to be the case here).  If it were, you wouldn't be able to see it using OWA.

_____________________________

Regards,

Dean T. Uemura
Microsoft MVP - Exchange (2007-2011)
exchangeguy.blogspot.com
uemurad@yahoo.com

(in reply to jaxisland)
Post #: 20

Page:   [1] 2   next >   >> << Older Topic    Newer Topic >>
All Forums >> [Microsoft Exchange 2003] >> General >> Bad delay in receiving mail Page: [1] 2   next >   >>
Jump to:

New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Follow TechGenix on Twitter