• RSS
  • Twitter
  • FaceBook

Exchange Server Forums

Forums | Register | Login | My Profile | Inbox | RSS RSS icon | My Subscription | My Forums | Address Book | Member List | Search | FAQ | Ticket List | Log Out

Can't mount store after recovery

Users viewing this topic: none

Logged in as: Guest
  Printable Version
All Forums >> [Microsoft Exchange 2003] >> Installation >> Can't mount store after recovery Page: [1] 2   next >   >>
Login
Message << Older Topic   Newer Topic >>
Can't mount store after recovery - 31.Jan.2008 8:38:01 AM   
pab_gm

 

Posts: 13
Joined: 31.Jan.2008
Status: offline
Hello,

My exchange server just crashed due to a faulty HDD, i was luck to have done a backup very recently. I used msbackup to back up the data and im now using msbackup to recover the data. I have put in a new hdd to my machine and had to re-install windows 2003 server standard.


i get the error c1041724 when i try to mount my store.

Any help wouuld be greatly appreciated.


Regards

Pablo.
Post #: 1
RE: Can't mount store after recovery - 31.Jan.2008 9:08:00 AM   
Wan2Fly

 

Posts: 15
Joined: 26.Apr.2006
Status: offline
I have been there not long ago.  have you done a defrag and use isutil.  I suggest you do checks on your DB

if that does not work then u might want to set up a parallel db export users, create ne db and import.

F

< Message edited by Wan2Fly -- 31.Jan.2008 9:09:32 AM >

(in reply to pab_gm)
Post #: 2
RE: Can't mount store after recovery - 1.Feb.2008 4:05:38 AM   
paresh_md

 

Posts: 129
Joined: 12.Dec.2007
From: United Kingdom
Status: offline
Hi,

Did you use /disasterrecovery switch to install Exchange?

Please paste the error events here logged while mounting the stores.

PD

_____________________________

Microsoft PSS - X Team Leader - Messaging
Systems

Have you ever run ExBPA on your Exchange server ? (Exchange Best Practises Analyzer)
Download from ExBPA.com

(in reply to Wan2Fly)
Post #: 3
RE: Can't mount store after recovery - 1.Feb.2008 7:07:12 AM   
pab_gm

 

Posts: 13
Joined: 31.Jan.2008
Status: offline
Hello,

Im a novice exchange user so im not sure if i have done things correctly

. I have put in a new hard drive and re-installed windows 2003 server and exxchange and then restored the backup of exchange, but i cant get into OWA or configure for pop3.

i have got a load of errors in event viewer. Any help would be greatly appreciated.


The MAPI call 'OpenMsgStore' failed with the following error:

The Microsoft Exchange Server computer is not available. Either there are network problems or the Microsoft Exchange Server computer is down for maintenance.

The MAPI provider failed.

Microsoft Exchange Server Information Store

ID no: 8004011d-0526-00000000



The MAPI call 'OpenMsgStore' failed with the following error:

The Microsoft Exchange Server computer is not available. Either there are network problems or the Microsoft Exchange Server computer is down for maintenance.

The MAPI provider failed.

Microsoft Exchange Server Information Store

ID no: 8004011d-0526-00000000



Error initializing session for virtual machine MAIL. The error number is 0x8004011d. Make sure Microsoft Exchange Store is running.





Error initializing session for virtual machine MAIL. The error number is 0x8004011d. Make sure Microsoft Exchange Store is running.



The Win32 API call 'DsGetDCNameW' returned error code [0x862] The specified component could not be found in the configuration information. The service could not be initialized. Make sure that the operating system was installed properly.





Unexpected error <<0xc1050000 - Unknown Error. The logon to the Microsoft Exchange Server computer failed. Microsoft Exchange Server Information Store ID no: 80040111-03ee-80040111>> occurred.





Process MAD.EXE (PID=4664). All Domain Controller Servers in use are not responding:

mail.fsnsolutions.com.au



Information Store (4876) First Storage Group: Attempted to attach database 'C:\Program Files\Exchsrvr\mdbdata\priv1.edb' but it is a database restored from a backup set on which hard recovery was not started or did not complete successfully.





Error initializing session for virtual machine MAIL. The error number is 0x8004011d. Make sure Microsoft Exchange Store is running.

(in reply to paresh_md)
Post #: 4
RE: Can't mount store after recovery - 1.Feb.2008 7:09:43 AM   
pab_gm

 

Posts: 13
Joined: 31.Jan.2008
Status: offline
Oh and when i try to login to Outlook web access it gives me the error "HTTP/1.1 503 Service Unavailable"

(in reply to pab_gm)
Post #: 5
RE: Can't mount store after recovery - 4.Feb.2008 6:34:20 AM   
pab_gm

 

Posts: 13
Joined: 31.Jan.2008
Status: offline
Hi,

I have read up on using the /disasterrecovery switch  and i think that it applies to servers that were in a network that had a separate DNS server. My exchange server was also my active directory server so using the /disasterrecovery switch probably wont help.

Any thoughts?

(in reply to pab_gm)
Post #: 6
RE: Can't mount store after recovery - 4.Feb.2008 10:09:57 AM   
de.blackman

 

Posts: 3542
Joined: 4.Apr.2005
From: Toronto, Canada
Status: offline
Hi,

You mentioned that the exchange server was also a domain controller. Was it the only domain controller on the network? If so, then you will basically have to install and configure exchange from scratch. In order for the databases to be able to come online, the exchange organization and administrative group name must be the same as they were in the previous configuration. It is also recommended that the exchange server name be the same (to avoid reconfiguring the outlook clients), the storage group/mailbox database name should be the same too.

the DisasterRecovery switch only works when you still have another domain controller in the network after the crash since exchange information is stored in active directory

< Message edited by de.blackman -- 4.Feb.2008 10:11:54 AM >


_____________________________

Ibrahim Benna - Microsoft Exchange MVP
Forum Moderator
Navantis
@IbrahimBenna

(in reply to pab_gm)
Post #: 7
RE: Can't mount store after recovery - 4.Feb.2008 8:16:43 PM   
pab_gm

 

Posts: 13
Joined: 31.Jan.2008
Status: offline
Hi,

Yes my exchange server was a stand alone unit with everything installed (including DNS active directory etc). So i will setup active directory the exact way that it was before and then what will be the next step?

Thanks for your help guys.

(in reply to de.blackman)
Post #: 8
RE: Can't mount store after recovery - 4.Feb.2008 8:21:07 PM   
pab_gm

 

Posts: 13
Joined: 31.Jan.2008
Status: offline
Hi,

the active directory wizard is running at the moment, after this should i install exchange with all my company details as they were on the last server?

Pablo.

(in reply to pab_gm)
Post #: 9
RE: Can't mount store after recovery - 5.Feb.2008 3:15:10 PM   
de.blackman

 

Posts: 3542
Joined: 4.Apr.2005
From: Toronto, Canada
Status: offline
Hi pab_gm,

since the exchange server was the only domain controller, complete the installation of active directory first. At this point, it really doesn't matter what your domain is called or how it is configured since you will have to install exchange from scratch anyways (sorry to bust your bubble :) )!

Once that is done, install exchange from scratch and make sure the organization name, administrative group name and storage group/mailbox database name match the configuration before the crash.

good luck!

_____________________________

Ibrahim Benna - Microsoft Exchange MVP
Forum Moderator
Navantis
@IbrahimBenna

(in reply to pab_gm)
Post #: 10
RE: Can't mount store after recovery - 5.Feb.2008 4:01:37 PM   
pab_gm

 

Posts: 13
Joined: 31.Jan.2008
Status: offline
Hi,

do you know if there is a way to extract the admin gropup, organization name etc out of the back up just so that everything is exactly the same?


Just want to get it right the first time!

Thanks.

(in reply to de.blackman)
Post #: 11
RE: Can't mount store after recovery - 6.Feb.2008 8:26:16 AM   
pab_gm

 

Posts: 13
Joined: 31.Jan.2008
Status: offline
Ok,

so i have installed exchange and im trying to restore the backup using ntbackup and i get the following error.

IM STUCK!!!!!

Any Ideas????????????????????????????????????


Restore Status
Operation: Restore

Backup of "MAIL\Microsoft Information Store\First Storage Group", Restored to"MAIL\Microsoft Information Store\First Storage Group"
Backup set #1 on media #1
Backup description: "Set created 29/01/2008 at 10:51 PM"

Restore started on 7/02/2008 at 12:22 AM.
Unable to restore Exchange data to MAIL\Microsoft Information Store\First Storage Group,
check the application event log for more information
Restore completed on 7/02/2008 at 12:22 AM.
Directories: 0
Files: 0
Bytes: 0
Time: 1 second

----------------------

(in reply to pab_gm)
Post #: 12
RE: Can't mount store after recovery - 6.Feb.2008 11:09:51 AM   
de.blackman

 

Posts: 3542
Joined: 4.Apr.2005
From: Toronto, Canada
Status: offline
Is the name of the server the same as it was before the crash?

_____________________________

Ibrahim Benna - Microsoft Exchange MVP
Forum Moderator
Navantis
@IbrahimBenna

(in reply to pab_gm)
Post #: 13
RE: Can't mount store after recovery - 6.Feb.2008 4:53:03 PM   
pab_gm

 

Posts: 13
Joined: 31.Jan.2008
Status: offline
hi,

yes the computer name is the same and the domain is the same. how ever i have changed the password to the administrator account. do you think this could affect the restore?

Pablo.

(in reply to de.blackman)
Post #: 14
RE: Can't mount store after recovery - 8.Feb.2008 9:09:15 AM   
de.blackman

 

Posts: 3542
Joined: 4.Apr.2005
From: Toronto, Canada
Status: offline
Using a different admin password would not affect a restore. What is the error you are getting in the application logs when trying to restore? Try restoring to an alternate location and see what happens? Do you have a file copy of the databases?

_____________________________

Ibrahim Benna - Microsoft Exchange MVP
Forum Moderator
Navantis
@IbrahimBenna

(in reply to pab_gm)
Post #: 15
RE: Can't mount store after recovery - 8.Feb.2008 2:57:57 PM   
pab_gm

 

Posts: 13
Joined: 31.Jan.2008
Status: offline
OK,

i get four erors

source MSExchangeIS

Failed to find a database to restore to from the Microsoft Active Directory.
Storage Group specified on the backup media is 3124aa26-7f0c-4f2b-bdbd-191b1b525983.
Database specified on backup media is Mailbox Store (MAIL), error is 0xc7fe1f46.

source ESE Backup


Information Store (4384) Callback function call ErrESECBRestoreGetDestination ended with error 0xC7FE1F46 Database can not be overwritten by a restore.
.
For more information, click http://www.microsoft.com/contentredirect.asp.

Source NTBackup


End Restore to 'MAIL\Microsoft Information Store\First Storage Group' 'Failed'
Verify: Off

Consult the backup report for more detail.

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.


source NTBackup


End Operation: Warnings or errors were encountered.
Consult the backup report for more details.
For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.



I could try to get some info from the hard drive that was in ther server before but its pretty bad shap, its making all sorts of clunking noises.

Does any of this help to diagnose the problem?


Regards

Pablo

(in reply to de.blackman)
Post #: 16
RE: Can't mount store after recovery - 8.Feb.2008 3:00:51 PM   
pab_gm

 

Posts: 13
Joined: 31.Jan.2008
Status: offline
Just thought i'd mention that if i try to restor to the desktop it gives me the same errors.

(in reply to pab_gm)
Post #: 17
RE: Can't mount store after recovery - 8.Feb.2008 4:45:42 PM   
de.blackman

 

Posts: 3542
Joined: 4.Apr.2005
From: Toronto, Canada
Status: offline
Can you please outline the steps you are making to perform the restore? have you emptied the folder on the hard drive that contains the database files and logs? Also have you selected that "the database can be overwritten by a restore" from the properties of the mailbox database in exchange system manager?

_____________________________

Ibrahim Benna - Microsoft Exchange MVP
Forum Moderator
Navantis
@IbrahimBenna

(in reply to pab_gm)
Post #: 18
RE: Can't mount store after recovery - 9.Feb.2008 11:57:25 AM   
David Trevallion

 

Posts: 2
Joined: 8.Feb.2008
Status: offline
I know that there has been mentions on here about the fact that Exchange was running on the same server as the DC so you would havebuild everything from scratch.

Does the backup that you are working with have the system state from the DC ?  If so you could considder the following:-
  1. Install a windows base build on your server
  2. Perform restore from your backup inclusing the system state.  This should hopefully get your original AD up and running
  3. If it's not there create the same directory structure where your exchange files sat, databases, smtp folders, MTA etc.
  4. Install Exchange using the /disasterrecovery flag.  The /disasterrecovery flag will pull the Exchange config out of AD and configure Exchange as it was before the disaster. 
  5. Restore the databases

If you really are going to have to start from scrath the try following Anderson Patricio's recent article Generating Active Directory Accounts using the mailbox information in the Mailbox Database (Part 2) on this site which should help get you out of your hole.

Hope this helps
Dave

(in reply to de.blackman)
Post #: 19
RE: Can't mount store after recovery - 11.Feb.2008 7:34:39 PM   
pab_gm

 

Posts: 13
Joined: 31.Jan.2008
Status: offline
Hi all,

Just thought i would let you guys know that i found a ghost image of my server with a fully functional system and i was able to perform a restore sucessfully.

Thanks for all your help.

Kindest Regards

Pablo Gonzalez

(in reply to David Trevallion)
Post #: 20

Page:   [1] 2   next >   >> << Older Topic    Newer Topic >>
All Forums >> [Microsoft Exchange 2003] >> Installation >> Can't mount store after recovery Page: [1] 2   next >   >>
Jump to:

New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Follow TechGenix on Twitter