• RSS
  • Twitter
  • FaceBook

Exchange Server Forums

Forums | Register | Login | My Profile | Inbox | RSS RSS icon | My Subscription | My Forums | Address Book | Member List | Search | FAQ | Ticket List | Log Out

Corrupt email attachments

Users viewing this topic: none

Logged in as: Guest
  Printable Version
All Forums >> [Microsoft Exchange 2003] >> General >> Corrupt email attachments Page: [1] 2   next >   >>
Login
Message << Older Topic   Newer Topic >>
Corrupt email attachments - 17.May2007 10:54:06 AM   
drhixson

 

Posts: 27
Joined: 27.Feb.2004
From: arkansas
Status: offline
hello everyone, I have a Win2003\Exchange2003 environment. I have ISA and GFI running as well. Everything is running well but the problem is, I have a user that sends a pdf attachment out to a DL of about 50 people. When he send the email with the attachment out, some of the reciepients are not able to open the attachment. they get a "attachment corrupt" error message. When my user re-sends the reciepent directly a second email with the attachment, they are able to open it. I am banging my head trying to figure out what is causing this, as it is causing some serious heat for me. Other users are not experiencing problems. It is just this one user. Any suggestions?
Post #: 1
RE: Corrupt email attachments - 17.May2007 11:31:07 AM   
uemurad

 

Posts: 8232
Joined: 7.Jan.2004
From: California, USA
Status: offline
Have someone with a corrupted attachment attempt to open it using OWA or using Outlook in non-cache mode.  If those can open the attachment, then you are likely looking at corrupted OST files.

_____________________________

Regards,

Dean T. Uemura
Microsoft MVP - Exchange (2007-2011)
exchangeguy.blogspot.com
uemurad@yahoo.com

(in reply to drhixson)
Post #: 2
RE: Corrupt email attachments - 17.May2007 11:49:45 AM   
drhixson

 

Posts: 27
Joined: 27.Feb.2004
From: arkansas
Status: offline
nope just tried it. One email im looking at here, has two pdf attachments. The first opened fine, the other says it is corrupt. The exact message in adobe is "there was an error opening this document. the file is damaged and could not be repaired.". I had the reciever try in outlook (non-cached) and OWA. Same response.

(in reply to drhixson)
Post #: 3
RE: Corrupt email attachments - 17.May2007 11:54:05 AM   
uemurad

 

Posts: 8232
Joined: 7.Jan.2004
From: California, USA
Status: offline
Try exporting the attachment using ExMerge with the Logging level increased.  If that fails, you might be looking at a larger corruption issue in your Mailbox Store.

_____________________________

Regards,

Dean T. Uemura
Microsoft MVP - Exchange (2007-2011)
exchangeguy.blogspot.com
uemurad@yahoo.com

(in reply to drhixson)
Post #: 4
RE: Corrupt email attachments - 17.May2007 12:00:46 PM   
drhixson

 

Posts: 27
Joined: 27.Feb.2004
From: arkansas
Status: offline
Can you see of any reason it could be the ISA server? I'm just trying to rule out possibilities.
also on the exmerge, are you suggesting doing that on my senders account? I dont understand exactly how that will help.

Oh and I just found out, the user just deleted all his sent items, and his deleted items...

(in reply to drhixson)
Post #: 5
RE: Corrupt email attachments - 17.May2007 12:52:25 PM   
uemurad

 

Posts: 8232
Joined: 7.Jan.2004
From: California, USA
Status: offline
I'm suggesting that you use ExMerge on a receiver's mailbox that displays the corrupted attachment.  In your situation I'd test pulling the attachment directly out of the mailbox store using ExMerge.  If it's corrupted there (ExMerge fails to export the attachment), I'd look for commonalities (e.g. all users belonging to a particular mailbox store).

Why?  Because of Single-instance-storage, there is a single copy of the attachment saved in each mailbox store and all mailboxes receiving the same message will only have pointers to it.  If two people have mailboxes in the same store, and one works while the other one doesn't, it would seem to indicate a problem with the pointers.

Let me know if you need instructions for export options, and/or regarding the ExMerge logging level.

_____________________________

Regards,

Dean T. Uemura
Microsoft MVP - Exchange (2007-2011)
exchangeguy.blogspot.com
uemurad@yahoo.com

(in reply to drhixson)
Post #: 6
RE: Corrupt email attachments - 17.May2007 1:34:37 PM   
drhixson

 

Posts: 27
Joined: 27.Feb.2004
From: arkansas
Status: offline
before I start, let me just say thank you for responding and all your assistance. It is greatly apprecieated.

I can't try to ExMerge on the recievers box, since the reciever is outside companies. I do however, have an email they they (the receiver) forwarded back to me , and I get the error attempting to open the attachment as well. If people within the store are included on the origional email, those users can open the attachment. I have tried sending the email to the DL from multiple computers, and from 2 different email accounts. Results are the same. It is like our system is somehow corrupting the attachments as they leave our organization. When I compare the file size's from the origional attachment and an attachment that has been forwarded to me from an outside reciever, the file are a few bites different. I know this is confusing. This is the other thing that is bothering me, if my users sends the email & attachment out to a couple people, no problem, its only when he is sending it to a DL of 50+ people. I have even had the user recreate the DL. Same problem. Again, I have had no instantances where the attachment is corrupted on emails within the store, it is only to people outside the company.

(in reply to uemurad)
Post #: 7
RE: Corrupt email attachments - 17.May2007 2:07:51 PM   
uemurad

 

Posts: 8232
Joined: 7.Jan.2004
From: California, USA
Status: offline
quote:

I can't try to ExMerge on the recievers box, since the reciever is outside companies.
Apologies - you are right.  I was confusing the direction of the message flow and who the recipients were.  Ignore the ExMerge suggestion.

Can you tell if the same outside people are affected every time?
Can you add a test account to the DL that you can test yourself (like gmail, hotmail, yahoo)?  Specifically, Yahoo allows you to see the full message header.  I'm curious what systems handle the message between your Exchange server and the outside.

_____________________________

Regards,

Dean T. Uemura
Microsoft MVP - Exchange (2007-2011)
exchangeguy.blogspot.com
uemurad@yahoo.com

(in reply to drhixson)
Post #: 8
RE: Corrupt email attachments - 18.May2007 10:45:18 AM   
drhixson

 

Posts: 27
Joined: 27.Feb.2004
From: arkansas
Status: offline
here is some more information I got from the user experiencing this problem. I am wondering if it is on our side at all?

  1. Are the same people affected on each mailing? Answer: NO
    1. Does everyone that you send the email to have the attachment corrupted? Answer: NO

  2. Does the problem happen on every email & attachment that you send out to your DL (distribution list) Answer: YES

(in reply to uemurad)
Post #: 9
RE: Corrupt email attachments - 22.May2007 6:38:26 AM   
mallinson

 

Posts: 4
Joined: 22.May2007
Status: offline
Hi,

I'm having this same issue at our end.  We've recently migrated all our mail onto two new servers in the same Admin group, same AD.  Running Win2003 Std & Exchange 2003 SP2 on both old and the new servers. Only 3 differences between old & new servers that I'm aware of (1) Different hardware (2) Windows 2003 SP1 on old server & SP2 on new servers (2) Trend Scanmail 6 on old server, Trend Scanmail 7 on new servers.  The corruption only seems to be with PDFs and if the same attachment is sent a 2nd time, it seems to go through ok..

Any matches to your situation regarding Scanmail, thats what I'm leaning toward at this stage?

E.

(in reply to drhixson)
Post #: 10
RE: Corrupt email attachments - 24.May2007 5:43:37 AM   
reddevilmikey

 

Posts: 42
Joined: 22.Sep.2005
Status: offline
Hi,

We had the same problem and then updatded our ScanMail 7 to patch 4. This fixed the problem.

Let me know if this helps...

(in reply to mallinson)
Post #: 11
RE: Corrupt email attachments - 24.May2007 8:34:34 AM   
hpickett

 

Posts: 3
Joined: 24.May2007
Status: offline
Same problem on our end. It started with attachments addressed to Distribution Lists randomly getting switched to winmail.dat or becoming corrupted. We installed Trend 7.0 patch 4 which fixed the winmail.dat issue but we still get corrupted attachments SOMETIMES on outgoing messages to a DL.


Happy to provide any additional info that could help!

Any additional suggestions appreciated.

(in reply to reddevilmikey)
Post #: 12
RE: Corrupt email attachments - 24.May2007 9:20:07 AM   
drhixson

 

Posts: 27
Joined: 27.Feb.2004
From: arkansas
Status: offline
I ended up replacing the users laptop, that fixed about 80% of the problems, but a few attachments were still getting corrupt. I then upgraded my ISA server from ISA2000 to ISA2006 and that seems, for now, to of fixed the problem. I too am running TrendMicro Scanmail but no updates were made to this app...

(in reply to hpickett)
Post #: 13
RE: Corrupt email attachments - 24.May2007 9:22:28 AM   
hpickett

 

Posts: 3
Joined: 24.May2007
Status: offline
No ISA server in our environment.

(in reply to drhixson)
Post #: 14
RE: Corrupt email attachments - 24.May2007 9:23:44 AM   
drhixson

 

Posts: 27
Joined: 27.Feb.2004
From: arkansas
Status: offline
quote:

ORIGINAL: hpickett

No ISA server in our environment.


are are you still having the same problem? If so let me know and I'll try to help you out.

(in reply to hpickett)
Post #: 15
RE: Corrupt email attachments - 24.May2007 1:00:33 PM   
mallinson

 

Posts: 4
Joined: 22.May2007
Status: offline
Thanx for the feedback guys.  Have installed SMEX Patch 4 & will monitor.  No ISA server in our environment either.  I'll provide feedback in a few days.

Thanks
EM

(in reply to drhixson)
Post #: 16
RE: Corrupt email attachments - 24.May2007 1:21:18 PM   
drhixson

 

Posts: 27
Joined: 27.Feb.2004
From: arkansas
Status: offline
looks like the one common thing for everyone, is we are all using the Trend Micro Scanmail...

(in reply to drhixson)
Post #: 17
RE: Corrupt email attachments - 28.May2007 6:04:56 AM   
mallinson

 

Posts: 4
Joined: 22.May2007
Status: offline
Bad news.. Still having the same problems even after Patch 4..  I have escalated to Trend Micro, so have to wait for their response..  Will keep you posted.

(in reply to drhixson)
Post #: 18
RE: Corrupt email attachments - 28.May2007 10:16:50 AM   
drhixson

 

Posts: 27
Joined: 27.Feb.2004
From: arkansas
Status: offline
if you stop Scanmail active scanning and\or stop the trend micro services, then try to send the email out, does that work? I didnt think of trying that...

(in reply to mallinson)
Post #: 19
RE: Corrupt email attachments - 29.May2007 9:32:40 AM   
hpickett

 

Posts: 3
Joined: 24.May2007
Status: offline
When you say yyou are using GFI, which product are you referring to?

(in reply to drhixson)
Post #: 20

Page:   [1] 2   next >   >> << Older Topic    Newer Topic >>
All Forums >> [Microsoft Exchange 2003] >> General >> Corrupt email attachments Page: [1] 2   next >   >>
Jump to:

New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Follow TechGenix on Twitter