• RSS
  • Twitter
  • FaceBook

Exchange Server Forums

Forums | Register | Login | My Profile | Inbox | RSS RSS icon | My Subscription | My Forums | Address Book | Member List | Search | FAQ | Ticket List | Log Out

Error upgrading to SP3

Users viewing this topic: none

Logged in as: Guest
  Printable Version
All Forums >> [Microsoft Exchange 2007] >> Installation >> Error upgrading to SP3 Page: [1]
Login
Message << Older Topic   Newer Topic >>
Error upgrading to SP3 - 30.Nov.2010 6:23:18 PM   
pedromrgoncalves

 

Posts: 5
Joined: 30.Nov.2010
Status: offline
I got the bellow error when trying to upgrade Exchange2007 to SP3.
Setup starts and checks everything ok, but when I click upgrade, after a while setup stops!
Please help!

The following 1 error(s) occurred during task execution:
[30-11-2010 23:10:54] [1] 0. ErrorRecord: Unable to get the product property 'PackageName'. This action is only valid for products that are currently installed. Error code is 1605.
[30-11-2010 23:10:54] [1] 0. ErrorRecord: Microsoft.Exchange.Configuration.Tasks.TaskException: Unable to get the product property 'PackageName'. This action is only valid for products that are currently installed. Error code is 1605. ---> System.ComponentModel.Win32Exception: This action is only valid for products that are currently installed
--- End of inner exception stack trace ---
at Microsoft.Exchange.Management.Deployment.MsiUtility.GetProductInfo(Guid productCode, String propertyName)
at Microsoft.Exchange.Management.Deployment.UninstallMsi.InternalValidate()
[30-11-2010 23:10:54] [1] [ERROR] Unable to get the product property 'PackageName'. This action is only valid for products that are currently installed. Error code is 1605.
[30-11-2010 23:10:54] [1] [ERROR] This action is only valid for products that are currently installed
[30-11-2010 23:10:54] [1] Setup is halting task execution because of one or more errors in a critical task.
[30-11-2010 23:10:54] [1] Finished executing component tasks.
[30-11-2010 23:10:54] [1] Ending processing.

Operating system is Windows SBS 2008 Premium (EN)

< Message edited by pedromrgoncalves -- 1.Dec.2010 7:50:44 AM >
Post #: 1
RE: Error upgrading to SP3 - 2.Dec.2010 5:04:29 AM   
adrian.pettitt

 

Posts: 240
Joined: 24.Sep.2009
From: UK
Status: offline
Overall it looks like one of 3 things.
1. Base Install of Exchange is not complete and it therefore cannot upgrade it.
2. The SP update package is corrupt and you need to get a new one.
3. You have the wrong version of the SP package, say 32 bit instaed of 64.

You might want to look at 2 and 3 first. If these turn out to not be the case then you will need to run the BPA against the server/org and see what it displays.

Adrian

(in reply to pedromrgoncalves)
Post #: 2
RE: Error upgrading to SP3 - 2.Dec.2010 8:18:45 AM   
pedromrgoncalves

 

Posts: 5
Joined: 30.Nov.2010
Status: offline
Adrian, thank you for the reply but,

1. Base install is complete (for sure) as system is working for about two years;
2. Done the download several times from different computers;
3. Exchange version is 64bit and so is the SP3.

(in reply to adrian.pettitt)
Post #: 3
RE: Error upgrading to SP3 - 2.Dec.2010 8:28:07 AM   
adrian.pettitt

 

Posts: 240
Joined: 24.Sep.2009
From: UK
Status: offline
A system can be improperly installed and still work, so that might not indicate a complete installation.
What does the BPA say.
What role(s) and types of roll are you SPing?

Adrian

(in reply to pedromrgoncalves)
Post #: 4
RE: Error upgrading to SP3 - 2.Dec.2010 8:32:32 AM   
pedromrgoncalves

 

Posts: 5
Joined: 30.Nov.2010
Status: offline
I'm running BPA now!
What do you mean by role(s) (SPing)???

Certificate SAN Mismatch
The subject alternative name (SAN) of SSL certificate for https://autodiscover.setrova.local/OAB does not appear to match the host address. Host address: autodiscover.setrova.local. Current SAN: DNS Name=setrova.local, DNS Name=remote.setrova.local, DNS Name=STRVSBS.setrova.local.

What does this mean? Is this making the update fail?

< Message edited by pedromrgoncalves -- 2.Dec.2010 8:38:24 AM >

(in reply to pedromrgoncalves)
Post #: 5
RE: Error upgrading to SP3 - 2.Dec.2010 8:38:39 AM   
adrian.pettitt

 

Posts: 240
Joined: 24.Sep.2009
From: UK
Status: offline
Are you SPing MBX, CAS, cluster?

Adrian

(in reply to pedromrgoncalves)
Post #: 6
RE: Error upgrading to SP3 - 2.Dec.2010 8:49:44 AM   
pedromrgoncalves

 

Posts: 5
Joined: 30.Nov.2010
Status: offline
Exchange is just used for internal email, nothing else!!!


I also tested the command test-outlookwebservices and got the error:

Id : 1006
Type : Error
Message : The Autodiscover service could not be contacted.

< Message edited by pedromrgoncalves -- 2.Dec.2010 8:54:06 AM >

(in reply to pedromrgoncalves)
Post #: 7
RE: Error upgrading to SP3 - 2.Dec.2010 8:57:46 AM   
adrian.pettitt

 

Posts: 240
Joined: 24.Sep.2009
From: UK
Status: offline
You must have misunderstood the Q.

You will have neeeded to installed Exchange roles on the server. Which roles are on the server that you are applying the SP to? What config, NLB, cluster (type).

Adrian

(in reply to pedromrgoncalves)
Post #: 8
RE: Error upgrading to SP3 - 2.Dec.2010 9:07:55 AM   
pedromrgoncalves

 

Posts: 5
Joined: 30.Nov.2010
Status: offline
The roles of the server are:

DHPC SERVER
DOMAIN CONTROLLER
RRAS
FILE SERVER
... and INTERNAL MAIL SERVER

(in reply to adrian.pettitt)
Post #: 9
RE: Error upgrading to SP3 - 3.Dec.2010 2:04:15 AM   
adrian.pettitt

 

Posts: 240
Joined: 24.Sep.2009
From: UK
Status: offline
Have you looked at documentation for installing on a DC?
I have no experience of this.
I am assuming you have CAS, MBX and HT roles installed, no resilience.

What did the BPA say?

(in reply to pedromrgoncalves)
Post #: 10
RE: Error upgrading to SP3 - 18.Dec.2010 1:11:47 AM   
terrence311

 

Posts: 1
Joined: 18.Dec.2010
Status: offline
I would like to upgrade to 2.0 soon but need to get upgraded to SP4 before I can do that. If anyone has any advice I would be very grateful.

_____________________________

love readings

(in reply to adrian.pettitt)
Post #: 11

Page:   [1] << Older Topic    Newer Topic >>
All Forums >> [Microsoft Exchange 2007] >> Installation >> Error upgrading to SP3 Page: [1]
Jump to:

New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Follow TechGenix on Twitter