• RSS
  • Twitter
  • FaceBook

Exchange Server Forums

Forums | Register | Login | My Profile | Inbox | RSS RSS icon | My Subscription | My Forums | Address Book | Member List | Search | FAQ | Ticket List | Log Out

Eseutil /d - Error while defragmenting

Users viewing this topic: none

Logged in as: Guest
  Printable Version
All Forums >> [Microsoft Exchange 2003] >> Information Stores >> Eseutil /d - Error while defragmenting Page: [1]
Login
Message << Older Topic   Newer Topic >>
Eseutil /d - Error while defragmenting - 16.May2004 8:20:00 PM   
dujohn

 

Posts: 77
Joined: 27.Sep.2003
From: United States
Status: offline
Hi, i was running the utility Eseutil /d to defrag "Prov1.edb" on our exchange server 2003. After finishing 10% it gave me the following error and the operation was aborted. I tried Microsoft support site..no luck..

Operation terminated with error -2102 (JET_errCallbackNotResolved, A callback fu
nction could not be found) after 2104.15 seconds.

Any suggestions?

Thanks.
John.
Post #: 1
RE: Eseutil /d - Error while defragmenting - 16.May2004 10:00:00 PM   
Henrik Walther

 

Posts: 6928
Joined: 21.Nov.2002
From: Copenhagen, Denmark
Status: offline
Hi John,

Haven't seen this one personally, but I just got a tip from MS, which you can try out.

This can occur with mismatched versions of jcb.dll. This file should exist in your Exchsrvr\bin and Winnt\system32.

The one in your Bin folder is likely to be the more current version. If this is the case, rename the jcb.dll in your winnt\system32 and then copy the jcb.dll from your Bin folder to System32 and try the defrag again.

[ May 16, 2004, 10:01 PM: Message edited by: Henrik Walther ]

(in reply to dujohn)
Post #: 2
RE: Eseutil /d - Error while defragmenting - 17.May2004 1:05:00 AM   
dujohn

 

Posts: 77
Joined: 27.Sep.2003
From: United States
Status: offline
Thanks Henrik. Actually i got the same tip from MS immediately after i posted this message. I will try this and will let you know.

Thanks Again.

John.

(in reply to dujohn)
Post #: 3
RE: Eseutil /d - Error while defragmenting - 10.May2009 3:58:07 AM   
ddktech

 

Posts: 2
Joined: 10.May2009
Status: offline
What I did to fix this issue is to put /3GB /USERVA=3030 in my boot.ini and then rebooted the server.  The problem went away and I was able to defrag the database.

Hope this helps someone else.

(in reply to dujohn)
Post #: 4
RE: Eseutil /d - Error while defragmenting - 10.Jun.2009 5:36:11 AM   
tonsai

 

Posts: 1
Joined: 10.Jun.2009
Status: offline
Hotfix: http://support.microsoft.com/kb/946111/en-us

(in reply to dujohn)
Post #: 5

Page:   [1] << Older Topic    Newer Topic >>
All Forums >> [Microsoft Exchange 2003] >> Information Stores >> Eseutil /d - Error while defragmenting Page: [1]
Jump to:

New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Follow TechGenix on Twitter