• RSS
  • Twitter
  • FaceBook

Exchange Server Forums

Forums | Register | Login | My Profile | Inbox | RSS RSS icon | My Subscription | My Forums | Address Book | Member List | Search | FAQ | Ticket List | Log Out

Exchange mail not routing to mailbox

Users viewing this topic: none

Logged in as: Guest
  Printable Version
All Forums >> [Microsoft Exchange 2003] >> Message Routing >> Exchange mail not routing to mailbox Page: [1]
Login
Message << Older Topic   Newer Topic >>
Exchange mail not routing to mailbox - 26.Nov.2006 7:10:35 PM   
raz

 

Posts: 29
Joined: 26.Nov.2006
Status: offline
Hi Guys
 
First-timer treading these boards,
 
Needs some help Please.
 
I have a 2k3 server with Exchange 2k3 installed. I have the infrastructure in place correctly i think because i have run smtpdiag and all test have passed, furthermore emails sent from external accounts to my domain can be seen in the messege tracking centre, but thats where they stop and dont get routed to the relevent mailboxes, messges sent to external recepients also dont get sent but also appear in the messege tracking centre.
 
What am i missing?  Its got me stumped but I'm Sure it will be a rookie mistake :)
 
Any ideas would be great.
 
Cheers
Raz
Post #: 1
RE: Exchange mail not routing to mailbox - 26.Nov.2006 8:16:34 PM   
jchong

 

Posts: 2516
Joined: 1.Dec.2005
From: Centreville, Virginia
Status: offline
Where do they stop in message tracking ie. categorizer etc. Are they stuck in a queue? If so which one?

Also have you run Exchange best practice analyzer?

http://www.microsoft.com/technet/prodtechnol/exchange/downloads/2003/analyzers/default.mspx

_____________________________

James Chong
MCSE | M+, S+, MCTS, Security+
msexchangetips.blogspot.com

(in reply to raz)
Post #: 2
RE: Exchange mail not routing to mailbox - 26.Nov.2006 8:27:56 PM   
skydawg

 

Posts: 60
Joined: 25.Nov.2006
Status: offline
Check your queues first, see where they are stuck, this is the best place to start troubleshooting what Exchange is doing with the messages.  If they are stuck in the SMTP virtual servers, you may want to take a look at DNS. 
 
You may want to take a look here - Open up Exchange System manager, drill down to Servers>Protocols>SMTP>Default SMTP Virtual Server>Properties>Deliver>Advanced Button>Configure External DNS Servers.  Click on the configure button, if there are no DNS servers there, add the external DNS servers. For inbound, make sure you have the IP pointed to your Exchange server, and that your MX records in your DNS are correct.
 
Thanks for the link James, that is a nice tool!

(in reply to raz)
Post #: 3
RE: Exchange mail not routing to mailbox - 26.Nov.2006 11:10:36 PM   
raz

 

Posts: 29
Joined: 26.Nov.2006
Status: offline
quote:

ORIGINAL: jchong

Where do they stop in message tracking ie. categorizer etc. Are they stuck in a queue? If so which one?

Also have you run Exchange best practice analyzer?

http://www.microsoft.com/technet/prodtechnol/exchange/downloads/2003/analyzers/default.mspx


Thanks Have run the MSBPA and it reports:





Link state not registered
Server: DS9-SISKO





SMTP instance 'Default SMTP Virtual Server' on server DS9-SISKO does not support the 'X-LINK2STATE' verb. This will cause routing updates to be frozen

What do i need to do here?

Also is the troubleshooting analyser worth running too?

Thanks Raz

(in reply to jchong)
Post #: 4
RE: Exchange mail not routing to mailbox - 27.Nov.2006 12:00:24 AM   
raz

 

Posts: 29
Joined: 26.Nov.2006
Status: offline
James and skydwag

Thanks for helping me out
the below is the report from the troubleshooting analyser....

question...isnt fabrikam one of microsofts test domain...i seem to remember this from my mcse?? what is it doing on my server??

now i'm really stumped...any pointers would be great

Thanks
Raz






Possible gateway problem
Area: Message Tracking Log




The message submitted by 'rahim.mawani@haydons-pharmacy.co.uk' to 'rahim_mawani@hotmail.com' appears to be stuck on Exchange gateway server ds9-sisko. Further analysis is necessary to determine whether messages may not go out to the Internet due to this.







Area: SMTP Queue Status







Server: ds9-sisko








'Remote delivery' queue (SMTP Connector: Internet Mail SMTP Connector (DS9-SISKO) - Fabrikam.com) is in retry
Server: ds9-sisko




The 'Remote delivery' queue (SMTP Connector: Internet Mail SMTP Connector (DS9-SISKO) - Fabrikam.com) on server ds9-sisko is in retry status. Source: 'Default SMTP Virtual Server'. Number of message(s) in the queue: 3. Additional status information: The remote server did not respond to a connection attempt.




Tell me more about this issue and how to resolve it.

< Message edited by raz -- 27.Nov.2006 12:03:08 AM >

(in reply to raz)
Post #: 5
RE: Exchange mail not routing to mailbox - 27.Nov.2006 12:28:13 AM   
skydawg

 

Posts: 60
Joined: 25.Nov.2006
Status: offline
From what I can gather from that, and doing a little research, it still points to DNS errors.  James may be better suited to take it from here, I have never used the MSBPA, but the errors come back as DNS errors, if I am not mistaken.

(in reply to raz)
Post #: 6
RE: Exchange mail not routing to mailbox - 27.Nov.2006 9:46:06 AM   
jchong

 

Posts: 2516
Joined: 1.Dec.2005
From: Centreville, Virginia
Status: offline
You have one server called ds9-sisko?
 
It appears that you have an Internet SMTP connector?  If so, lets go ahead and delete that for now. Delete all your smtp connectors.

Now try to send to the internet. If this does't work post back, then we'll try to troubleshoot your smtp virtual server. Dont' recreate the connectors.


_____________________________

James Chong
MCSE | M+, S+, MCTS, Security+
msexchangetips.blogspot.com

(in reply to raz)
Post #: 7
RE: Exchange mail not routing to mailbox - 27.Nov.2006 11:06:50 AM   
raz

 

Posts: 29
Joined: 26.Nov.2006
Status: offline
Thanks Guys...unfortunately it did not work...i have deleted all smtp connectors and tried to send mail to my domain mailbox and from my mailbox to a hotmail account and pop3 account, they still havent reached there after 1 hour

Thanks
Raz

(in reply to jchong)
Post #: 8
RE: Exchange mail not routing to mailbox - 27.Nov.2006 11:22:06 AM   
jchong

 

Posts: 2516
Joined: 1.Dec.2005
From: Centreville, Virginia
Status: offline
Ok, now let's at your smtp vs? How many smtp vs do you have? To simplify this, go ahead and delete this and recreate it. If you have any special configurations such as relay lists or anything you may want to record them. If not, just whack it and create a new VS?

_____________________________

James Chong
MCSE | M+, S+, MCTS, Security+
msexchangetips.blogspot.com

(in reply to raz)
Post #: 9
RE: Exchange mail not routing to mailbox - 27.Nov.2006 1:07:54 PM   
raz

 

Posts: 29
Joined: 26.Nov.2006
Status: offline
Thanks james

I currently only have the default smtp VS installed, which it wont let me delete it, i have tried to stop the service and create a new vs but it says that the port and server are in use. so no luck there

raz

(in reply to jchong)
Post #: 10
RE: Exchange mail not routing to mailbox - 27.Nov.2006 8:18:47 PM   
skydawg

 

Posts: 60
Joined: 25.Nov.2006
Status: offline
Did you go to the properties of the default VS and look to see if outside DNS is listed as I previously posted?  Open up Exchange System manager, drill down to Servers>Protocols>SMTP>Default SMTP Virtual Server>Right Click to bring up Properties>Delivery Tab>Advanced Button>Configure External DNS Servers.  I have a feeling Exchange isn't talking to the outside world.

(in reply to raz)
Post #: 11
RE: Exchange mail not routing to mailbox - 27.Nov.2006 9:35:38 PM   
raz

 

Posts: 29
Joined: 26.Nov.2006
Status: offline
 

I did put in my isp's dns servers as suggested, should i also put in the mail domain hosting dns as well as they are not the same?

BTW Ran the MSBPA and reports the following





Admin Group: First Administrative Group







Server: DS9-SISKO








External DNS servers in use for SMTP
Server: DS9-SISKO




SMTP instance 'Default SMTP Virtual Server' on server DS9-SISKO is configured to use an external DNS server.




Tell me more about this setting.

also of note is:





Admin Group: First Administrative Group







Server: DS9-SISKO








Database backup critical
Server: DS9-SISKO




Database 'Public Folder Store (DS9-SISKO)' on server DS9-SISKO has never had a full online backup.




Tell me more about this issue and how to resolve it.








Link state not registered
Server: DS9-SISKO




SMTP instance 'Default SMTP Virtual Server' on server DS9-SISKO does not support the 'X-LINK2STATE' verb. This will cause routing updates to be frozen.





Tell me more about this issue and how to resolve it.

Obviously not to worried about the backup at this stage but linkstate is my bugbear.


However it is not routing internally either.....would you recommend a reinstall as a worst case senario?

is there a good resource for setting up an exchange server?

Much appreciated James and skydwag for all your efforts, if you are ever in London UK I'll buy you guysa pint or three :)

Cheers Raz

(in reply to skydawg)
Post #: 12
RE: Exchange mail not routing to mailbox - 27.Nov.2006 9:37:15 PM   
jchong

 

Posts: 2516
Joined: 1.Dec.2005
From: Centreville, Virginia
Status: offline
Check the dns that skydawg mentioned.

It should not have anything in there.

Since you cant delete the default smtp vs, change the port number to another port say 2525. Then create a new smtp vs and assign it default port of 25 then restart your box.

_____________________________

James Chong
MCSE | M+, S+, MCTS, Security+
msexchangetips.blogspot.com

(in reply to skydawg)
Post #: 13
RE: Exchange mail not routing to mailbox - 27.Nov.2006 10:09:17 PM   
raz

 

Posts: 29
Joined: 26.Nov.2006
Status: offline
Ok i have now removed the dns in the default smtp vs, changed the port to 2525 aand created and started another one on port 25 with the same settings and restarted the box...still no email its been 10 min since i sent test msg to both hotmail and pop accounts..still no sign of them, also tried sending back msg to mail domain....nothing

anyting else i can try

cheers
raz

Ps Just run MSBPA..again Link state not registered on new smtp virtual server.

< Message edited by raz -- 27.Nov.2006 10:23:07 PM >

(in reply to jchong)
Post #: 14
RE: Exchange mail not routing to mailbox - 28.Nov.2006 9:45:03 PM   
raz

 

Posts: 29
Joined: 26.Nov.2006
Status: offline
is it worth a reinstall of exchange? do u think that will resolve the problem?

cheers
raz

(in reply to raz)
Post #: 15
Solved - 4.Dec.2006 9:59:46 PM   
raz

 

Posts: 29
Joined: 26.Nov.2006
Status: offline
After days  (and nights) anguish and hair pulling out, i uninstalled exchange and reinstalled exchange and voilla, an ominous error popped up about the current version of Mapi.dll or something not being compatible with exchange 2003 which must have been missed first time round. A quick google check post installation said the prob could be resolved by installing outlook 2003 on the server..so i did...wahay..mails started routing.

PS Removing Exchange is a pain in the a** but ther are some good resorces on this site.

(in reply to raz)
Post #: 16

Page:   [1] << Older Topic    Newer Topic >>
All Forums >> [Microsoft Exchange 2003] >> Message Routing >> Exchange mail not routing to mailbox Page: [1]
Jump to:

New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Follow TechGenix on Twitter