• RSS
  • Twitter
  • FaceBook

Exchange Server Forums

Forums | Register | Login | My Profile | Inbox | RSS RSS icon | My Subscription | My Forums | Address Book | Member List | Search | FAQ | Ticket List | Log Out

Exchange win2k3 enterprise edtition Forestprep error

Users viewing this topic: none

Logged in as: Guest
  Printable Version
All Forums >> [Microsoft Exchange 2003] >> Installation >> Exchange win2k3 enterprise edtition Forestprep error Page: [1]
Login
Message << Older Topic   Newer Topic >>
Exchange win2k3 enterprise edtition Forestprep error - 15.Aug.2003 12:59:00 PM   
KevinF

 

Posts: 5
Joined: 15.Aug.2003
From: London
Status: offline
Hello People,

When I attempt to run forestprep from a domain controller or member server I get an error message telling me the following.....

The component "Microsoft Exchange Forest Preperation" cannot be assigned the action "Forestprep" because:
-To install the first exchange server in a domain or to run setup in "/Forestprep" mode, you must be an Exchange Full administrator at the organisational level. You must use an account that has been granted the Full exchange administrator role on the exchange organisation using the exchange administrative delegation wizard.

Please see the link below for a graphical representation of what I typed.

http://www.electronicscene.com/m1/1806/1166/media/7904.jpg

I have 3 domain controllers, 1 running win2k3 enterprise edition an 2 domain controllers running win2k3 std edition.

Please help guys.

Cheers
Post #: 1
RE: Exchange win2k3 enterprise edtition Forestprep error - 15.Aug.2003 2:19:00 PM   
Henrik Walther

 

Posts: 6928
Joined: 21.Nov.2002
From: Copenhagen, Denmark
Status: offline
Hello Kevin,

You need to grant the proper permissions to the user you log on to the server with, then you can complete the ForestPrep part.

Check the following MS KB for details:

http://support.microsoft.com/?kbid=255788

Regards

(in reply to KevinF)
Post #: 2
RE: Exchange win2k3 enterprise edtition Forestprep error - 15.Aug.2003 2:51:00 PM   
KevinF

 

Posts: 5
Joined: 15.Aug.2003
From: London
Status: offline
Henrik,

Thanks for your reply, I have granted a total of 3 users all the rights needed for this task an more prior to posting this, but still having no joy mate. Any other suggestions?

Thanks

Kevin

(in reply to KevinF)
Post #: 3
RE: Exchange win2k3 enterprise edtition Forestprep error - 18.Aug.2003 4:23:00 AM   
ruwand

 

Posts: 41
Joined: 11.Oct.2002
From: Sri Lanka
Status: offline
Hey Kevin,

I had the same problem when I install it on a test enviorment. What I did was regedit-hkey_local_machine-software-microsoft-msexchange and delete the keys.

Then restarted the server. logged on as administrator, ran the setup. It worked.

So I thought it may be b'coz I ran the setup without the full administrator rights, there are entries in the registry. So removing these it should work. That was my logic.

Check it out.

Rat M

(in reply to KevinF)
Post #: 4
RE: Exchange win2k3 enterprise edtition Forestprep error - 22.Aug.2003 10:42:00 AM   
KevinF

 

Posts: 5
Joined: 15.Aug.2003
From: London
Status: offline
Thanks very much for your reply, I am gonna try this right now an let you know how I get on.

(in reply to KevinF)
Post #: 5
RE: Exchange win2k3 enterprise edtition Forestprep error - 22.Aug.2003 10:57:00 AM   
KevinF

 

Posts: 5
Joined: 15.Aug.2003
From: London
Status: offline
Unfortunately, I did not have this registry entry on my server, so I was unable to remove it. Thanks alot anyway. Any other ideas please??

(in reply to KevinF)
Post #: 6
RE: Exchange win2k3 enterprise edtition Forestprep error - 22.Aug.2003 1:15:00 PM   
t029248

 

Posts: 14
Joined: 8.Aug.2003
From: Holanda
Status: offline
Hi

I had the same problem, in my exchange test organization it was something with the old Exchange 2000 shema and the Exchange 2003 rc1 schema update.

If you are also in a test environment (http://www.electronicscene.com/m1/1806/1166/media/7904.jpg) try the following:
Remove the old exchange org from AD, you can try the [/removeorg] switch
http://support.microsoft.com/default.aspx?scid=kb;EN-US;Q260378
http://support.microsoft.com/default.aspx?scid=kb;EN-US;273478

If thatĂs not working you can use ADSIEDIT to remove all the exchange objects manually.

When the cleanup is done you can rerun setup /forestprep & /domainprep

In a live environment all that is not an option and youĂll have to figure out something else.

I hope this helps you out?

[ August 22, 2003, 01:17 PM: Message edited by: Drallas ]

(in reply to KevinF)
Post #: 7
RE: Exchange win2k3 enterprise edtition Forestprep error - 9.Sep.2003 8:48:00 AM   
KevinF

 

Posts: 5
Joined: 15.Aug.2003
From: London
Status: offline
Hello,

I have tried a removeorg, an the system tells me I do not have enough rights to edit the schema.

Any other ideas please.

thanks for all suggestions so far

(in reply to KevinF)
Post #: 8
RE: Exchange win2k3 enterprise edtition Forestprep error - 17.Sep.2003 1:11:00 AM   
genenius

 

Posts: 106
Joined: 20.Jun.2002
From: Kent, WA
Status: offline
Kevin, don't forget to make the user you're installing exchange with a Schema Admin.

In fact, make the user a member of the Enterprise Admins Group, Domain Admins Group, and Schema Admins Group. If it's saying you can't make changes to the schema, then you'll need schema admin rights. Hope this helps.

Oh, and are you running this in a Child Domain? If so, you'll need to grant the enterprise admins role from the parent domain level.

[ September 17, 2003, 01:13 AM: Message edited by: Gene Torres ]

(in reply to KevinF)
Post #: 9

Page:   [1] << Older Topic    Newer Topic >>
All Forums >> [Microsoft Exchange 2003] >> Installation >> Exchange win2k3 enterprise edtition Forestprep error Page: [1]
Jump to:

New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Follow TechGenix on Twitter