• RSS
  • Twitter
  • FaceBook

Exchange Server Forums

Forums | Register | Login | My Profile | Inbox | RSS RSS icon | My Subscription | My Forums | Address Book | Member List | Search | FAQ | Ticket List | Log Out

Help me!! Log files corrupted...

Users viewing this topic: none

Logged in as: Guest
  Printable Version
All Forums >> [Microsoft Exchange 2010] >> General >> Help me!! Log files corrupted... Page: [1] 2   next >   >>
Login
Message << Older Topic   Newer Topic >>
Help me!! Log files corrupted... - 20.Jun.2011 8:38:10 AM   
shadowlinux

 

Posts: 11
Joined: 20.Jun.2011
Status: offline
Hello Friends, I have a serious problem, I have a Database of
company I work about 74 GB of data. In the middle of
month of May, there was a power outage, and returned with the Exchange
Database Corrupted. I can extract the PST by software
others, however, is missing many emails. I did the procedure
repair by ESEUTIL complete, but to no avail, the error is constant
Log corrupted when assembling the base. I'll post the log that shows the
where this problem, many thanks for the kindness of friends who can
help me PS: I do not have the logs described in the last line below is
List is huge, I'm posting only the last lines.
Thanks!!
Lucas

LOG ##################

     Log file: C: \ Mailbox Database 1981968534 - C pia \ E0000030328.log
- OK
     Log file: C: \ Mailbox Database 1981968534 - C pia \ E0000030329.log
- OK
     Log file: C: \ Mailbox Database 1981968534 - C pia \ E000003032A.log
- OK
     Log file: C: \ Mailbox Database 1981968534 - C pia \ E000003032B.log
- OK
     Log file: C: \ Mailbox Database 1981968534 - C pia \ E000003032C.log
- OK
     Log file: C: \ Mailbox Database 1981968534 - C pia \ E000003032D.log
- OK
     Log file: C: \ Mailbox Database 1981968534 - C pia \ E000003032E.log
- OK
     Log file: C: \ Mailbox Database 1981968534 - C pia \ E000003032F.log
- OK
     Missing log file: E0000030330.log
     Log file: C: \ Mailbox Database 1981968534 - C pia \ E0000030331.log
               ERROR: Log damaged (unusable). Last Lgpos:
(0x30331, 8.0). Error -501.
     Log file: C: \ Mailbox Database 1981968534 - C pia \ E00.log
               ERROR: Missing log file (s). Log file generation is
197424 (0x30330), but expected generation is 197426 (0x30332).

Operation terminated with error -528 (JET_errMissingLogFile, Current
log file missing) after 1789.94 seconds.
Post #: 1
RE: Help me!! Log files corrupted... - 20.Jun.2011 9:08:21 AM   
mark@mvps.org

 

Posts: 6811
Joined: 9.Jun.2004
From: Philadelphia PA
Status: offline
I would guess either bad hardware or you are virus scanning. Are either of those two possibles?

_____________________________

Mark Arnold (Exchange MVP)
List Moderator

(in reply to shadowlinux)
Post #: 2
RE: Help me!! Log files corrupted... - 20.Jun.2011 9:13:05 AM   
shadowlinux

 

Posts: 11
Joined: 20.Jun.2011
Status: offline
Hello, I have changed the server, this problem happened just after the power in the company, and the server restarted ... I do not know what else to do. there is some method to mount this log is missing? just to mount the database?
Thanks,
Lucas- Brazil

(in reply to mark@mvps.org)
Post #: 3
RE: Help me!! Log files corrupted... - 20.Jun.2011 12:06:05 PM   
shadowlinux

 

Posts: 11
Joined: 20.Jun.2011
Status: offline
Please Friends! help me! 

(in reply to shadowlinux)
Post #: 4
RE: Help me!! Log files corrupted... - 20.Jun.2011 12:58:55 PM   
mark@mvps.org

 

Posts: 6811
Joined: 9.Jun.2004
From: Philadelphia PA
Status: offline
Do you have another replica in a DAG? If you do it's easiest to just stop replication, delete everything in there and then reseed.

If you don't have a copy you are going to have to accept data loss. This: http://msexchangeguru.com/2009/07/12/exchange-database-recovery-using-eseutil-commands/ is a good article to teach you how to bring your Exchange back up and running up to a point in time. The log file you posted contains the failed log point so you know how far you can get to.

Review the article and then make a fresh question here if you need assistance on a particular point.

_____________________________

Mark Arnold (Exchange MVP)
List Moderator

(in reply to shadowlinux)
Post #: 5
RE: Help me!! Log files corrupted... - 20.Jun.2011 1:41:19 PM   
shadowlinux

 

Posts: 11
Joined: 20.Jun.2011
Status: offline
Hello Mark my friend, had already followed this procedure, the problem is that the Database is Clean Shutdown, precisely because of the logs corrupteds. Still, the database will not mount. Meanwhile I am trying in many ways! I really appreciate your attention to me.
Regards,
Lucas

(in reply to mark@mvps.org)
Post #: 6
RE: Help me!! Log files corrupted... - 20.Jun.2011 2:04:43 PM   
shadowlinux

 

Posts: 11
Joined: 20.Jun.2011
Status: offline
Mark, if I try to mount the Base Clean Shutdown mode, without the log files, this error appears when installing the file. EDB.
Take a look

--------------------------------------------------------
Microsoft Exchange Error
--------------------------------------------------------
Failed to mount database 'Mailbox Database 1226870436'.

Mailbox Database 1226870436
Falha
Erro:
Unable to mount the specified database. Specified database: Mailbox Database 1226870436; Code Error: Operation failed Active Manager. Error: Action failed database. Error: The operation failed with the message: MapiExceptionCallFailed: Unable to mount database. (hr=0x80004005, ec=1276)
. [Database: Mailbox Database 1226870436, Server: msgsrv.grafica.local].



--------------------------------------------------------
OK
--------------------------------------------------------

(in reply to shadowlinux)
Post #: 7
RE: Help me!! Log files corrupted... - 21.Jun.2011 1:21:18 AM   
rockone

 

Posts: 13
Joined: 20.Jun.2011
Status: offline
I read the tutorial link given by Mark in the reply. Shadow, the guidelines are perfect. Try to redo all the things what you did and get back the data and reply. I guess it will work. Also, you may contact Microsoft if they can help you out.

_____________________________

How to Write a Check

(in reply to shadowlinux)
Post #: 8
RE: Help me!! Log files corrupted... - 21.Jun.2011 7:06:17 AM   
shadowlinux

 

Posts: 11
Joined: 20.Jun.2011
Status: offline
OK Rockone , I'll try to redo again, then I say, Thank you for your attention!

(in reply to rockone)
Post #: 9
RE: Help me!! Log files corrupted... - 28.Jun.2011 8:19:53 AM   
shadowlinux

 

Posts: 11
Joined: 20.Jun.2011
Status: offline
friends!! pls, i dont recovered my database...
Its error ...pls help me..pls...


:(

Microsoft Exchange Error
--------------------------------------------------------
Failed to mount database 'Mailbox Database 1226870436'.

Mailbox Database 1226870436
Falha
Erro:
Unable to mount the specified database. Specified database: Mailbox Database 1226870436; Code Error: Operation failed Active Manager. Error: Action failed database. Error: The operation failed with the message: MapiExceptionCallFailed: Unable to mount database. (hr=0x80004005, ec=1276)
. [Database: Mailbox Database 1226870436, Server: msgsrv.grafica.local].

(in reply to shadowlinux)
Post #: 10
RE: Help me!! Log files corrupted... - 28.Jun.2011 8:27:04 AM   
mark@mvps.org

 

Posts: 6811
Joined: 9.Jun.2004
From: Philadelphia PA
Status: offline
Many people have followed the guidelines you were given.

The best thing for you would be to open a case with Microsoft. Either that or go and buy Kroll PowerControls to crack open the store and recover what you can.

I assume you started the users off with a dial-tone store and are merely trying to get their old email back, right?

Call MS or download that product.

_____________________________

Mark Arnold (Exchange MVP)
List Moderator

(in reply to shadowlinux)
Post #: 11
RE: Help me!! Log files corrupted... - 1.Jul.2011 5:41:10 AM   
huadongscreen

 

Posts: 2
Joined: 1.Jul.2011
Status: offline
Help us!

_____________________________

water well screen
http://www.chinawellscreen.com

(in reply to mark@mvps.org)
Post #: 12
RE: Help me!! Log files corrupted... - 1.Jul.2011 2:56:13 PM   
shadowlinux

 

Posts: 11
Joined: 20.Jun.2011
Status: offline
i Try whit Kroll...more no sucessful

Look my error, i dont mount database, because this log

http://imageshack.us/photo/my-images/827/errorkgk.jpg/

(in reply to shadowlinux)
Post #: 13
RE: Help me!! Log files corrupted... - 13.Jul.2011 10:52:53 AM   
mvalente

 

Posts: 2
Joined: 13.Jul.2011
Status: offline
Hi ShadowLinux...

Resolution this problem, relatively simple...

1) Dismount Database;
2) Open Powershell console, navigate to folder EDB files database with logs Corrupted.
3)Run ESEUTIL /mh database e view status;
4)Run Eseutil /P Database (Repair Database);
5)Run Eseutil /mh e check on database with Clean Shutdown;
6)Run Eseutil /D database (desfragment);
7)Delete Logs referent database corrupted;
8) Mount Database;

Marcos Valente

quote:

ORIGINAL: shadowlinux

i Try whit Kroll...more no sucessful

Look my error, i dont mount database, because this log

http://imageshack.us/photo/my-images/827/errorkgk.jpg/

(in reply to shadowlinux)
Post #: 14
RE: Help me!! Log files corrupted... - 13.Jul.2011 12:05:08 PM   
mark@mvps.org

 

Posts: 6811
Joined: 9.Jun.2004
From: Philadelphia PA
Status: offline
Excellent news.One word of warning though. If you do have any replica's there you will need to reseed them. The eseutil /d breaks the replica's.
If you haven't got any replica's or only set up DAG replication after the /d then ignore, you're good to go.

_____________________________

Mark Arnold (Exchange MVP)
List Moderator

(in reply to mvalente)
Post #: 15
RE: Help me!! Log files corrupted... - 14.Jul.2011 7:08:25 AM   
shadowlinux

 

Posts: 11
Joined: 20.Jun.2011
Status: offline
Thanks Mark and Mvalente,
i dont mount my database whit the procedure
give me error on mount LOOK!!!

Summary: 2 item (s). 0 successful (s), 1 failed.
Elapsed time: 00:12:34


new recovery
failure

error:
Failed to connect to destination server "MSGSRV." Error: WMI Exception on server 'msgsrv.grafica.local': Call canceled

Attempting to use the command from the Exchange Management Shell:
mailboxdatabase-new-Server 'MSGSRV'-Name 'recovery'-EdbFilePath 'D: \ Program Files \ Microsoft \ Exchange Server \ V14 \ Mailbox \ Mailbox Database 1981968534 \ Mailbox Database 1981968534.edb'-LogFolderPath 'D: \ WINDOWS Software \ Microsoft \ Exchange Server \ V14 \ Mailbox \ Mailbox Database 1981968534 '

Elapsed Time: 00:12:34


mount Recovery
canceled




WHAT IS THIS??

(in reply to mark@mvps.org)
Post #: 16
RE: Help me!! Log files corrupted... - 14.Jul.2011 9:51:27 AM   
mvalente

 

Posts: 2
Joined: 13.Jul.2011
Status: offline
Hi Shadow!!!

You checked the event logs.

Send us the mistakes so that we can analyze and to help you.

_____________________________

Marcos Valente
TI Consulting / Support Tecnical
ACP - Altiris Certified Professional.
MCP - MCSA 2000/2003 + Messaging
MCP - Exchange Server
MCTS - W2K8

(in reply to shadowlinux)
Post #: 17
RE: Help me!! Log files corrupted... - 15.Jul.2011 11:41:52 AM   
shadowlinux

 

Posts: 11
Joined: 20.Jun.2011
Status: offline
Friend , this is Event LOG exchange



New MailboxDatabase
   Recovery = {True, Name = RecoverDB, Server = msgsrv.grafica.local, EdbFilePath = c: \ recovery \ RecoveryDB.edb, LogFolderPath = c: \ recovery \ logs}
   grafica.local / Users / Administrator
   S-1-5-21-450155462-981389502-2736918079-500
   S-1-5-21-450155462-981389502-2736918079-500
   ServerRemoteHost-Unknown
   6948
   
   20
   00:16:54.7338810
   View Entire Forest: 'False' Default Scope: 'grafica.local', Configuration Domain Controller: 'msgsrv.grafica.local', Preferred Global Catalog: 'msgsrv.grafica.local', Preferred Domain Controllers: '{msgsrv.grafica.local} '
   System.InvalidOperationException: Failed to connect to destination server "MSGSRV." Error: WMI Exception on server 'msgsrv.grafica.local': Call canceled
   7

(in reply to mvalente)
Post #: 18
RE: Help me!! Log files corrupted... - 20.Jan.2012 9:16:14 AM   
Ellinor

 

Posts: 99
Joined: 24.Oct.2011
Status: offline
Try the following solution:

1. Look folder c:\\Program Files\Exchsrvr\MDBDATA
2. Copy last E000xxx.log, E00.log and E00.chk to other place
3. Delete E00.log
4. Rename last E000xxx.log to E00.log
5. Execute
c:\\Program Files\Exchsrvr\MDBDATA>"c:\\Program Files\Exchsrvr\bin\Eseutil" /r e00
5. You may need this procedures with following order:
c:\\Program Files\Exchsrvr\MDBDATA>"c:\\Program Files\Exchsrvr\bin\Eseutil" /g

c:\\Program Files\Exchsrvr\MDBDATA>"c:\\Program Files\Exchsrvr\bin\Eseutil" /p
c:\\Program Files\Exchsrvr\MDBDATA>"c:\\Program Files\Exchsrvr\bin\Eseutil" /d


Hope it will work for you.


If above solution fails to solve the issue, you may use a third party Exchange server recovery software to repair and recover Exchange database. Such applications use advance scanning technique to repair the corrupted or damaged database files. One of the most globally used tool is mentioned here: http://bit.ly/1P7P9hF


After recovering the database with this tool, you can easily mount it on the Server. this tool is compatible with all versions of MS Exchange Server i.e. 2013, 2010, 2007, 2003, 2000, and 5.5.

< Message edited by Ellinor -- 3.Oct.2015 8:35:33 AM >

(in reply to shadowlinux)
Post #: 19
RE: Help me!! Log files corrupted... - 19.Nov.2013 4:34:56 AM   
larry.cartner

 

Posts: 5
Joined: 19.Aug.2013
Status: offline
Corruption in edb file badly affects the Exchange server performance and all user mailboxes & public folders stops stops working immediately. Thus, only log files are left to recover Exchange server and restore all mailboxes correctly. However, in adverse conditions when Exchange log files gets corrupted then possibilities of Exchange recovery also reduces. At this point, recover Exchange server data without log files from edb file.

_____________________________

exchange edb ****

(in reply to Ellinor)
Post #: 20

Page:   [1] 2   next >   >> << Older Topic    Newer Topic >>
All Forums >> [Microsoft Exchange 2010] >> General >> Help me!! Log files corrupted... Page: [1] 2   next >   >>
Jump to:

New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Follow TechGenix on Twitter