• RSS
  • Twitter
  • FaceBook

Exchange Server Forums

Forums | Register | Login | My Profile | Inbox | RSS RSS icon | My Subscription | My Forums | Address Book | Member List | Search | FAQ | Ticket List | Log Out

How to force SMTP authentication for local users only?

Users viewing this topic: none

Logged in as: Guest
  Printable Version
All Forums >> [Microsoft Exchange 2010] >> Secure Messaging >> How to force SMTP authentication for local users only? Page: [1]
Login
Message << Older Topic   Newer Topic >>
How to force SMTP authentication for local users only? - 20.Jan.2011 1:32:34 PM   
mrfixit3000

 

Posts: 6
Joined: 20.Jan.2011
Status: offline
So I've configured my Edge Transport server and also have Forefront Protection setup and working. I obviously need to allow anonymous users to the receive connector on the edge server so that the server will accept inbound email from outside sources.

However, I've found that I am able to send email FROM a local account, TO a local account, and have the server not ask for any authentication! I want to lock this down, but I can't find a setting anywhere in Exchange or Forefront to tell the receive connector to authenticate any session where the email is FROM a local user. Please advise!

Also, my Edge Transport server is, in fact, part of my main active directory, so integrated authentication should be possible.
Post #: 1
RE: How to force SMTP authentication for local users only? - 15.Feb.2011 5:27:40 AM   
turbodonkey

 

Posts: 1
Joined: 15.Feb.2011
Status: offline
I had the same issue on a new install, we were being spammed from out own doman!!

I had to remove a permission from the recieve connector:

remove-ADPermission -Identity <receive connector> -User "NT AUTHORITY\ANONYMOUS LOGON" -ExtendedRights ms-Exch-SMTP-Accept-Authoritative-Domain-Sender
to restore
add-ADPermission -Identity <receive connector> -User "NT AUTHORITY\ANONYMOUS LOGON" -ExtendedRights ms-Exch-SMTP-Accept-Authoritative-Domain-Sender

(in reply to mrfixit3000)
Post #: 2

Page:   [1] << Older Topic    Newer Topic >>
All Forums >> [Microsoft Exchange 2010] >> Secure Messaging >> How to force SMTP authentication for local users only? Page: [1]
Jump to:

New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Follow TechGenix on Twitter