• RSS
  • Twitter
  • FaceBook

Exchange Server Forums

Forums | Register | Login | My Profile | Inbox | RSS RSS icon | My Subscription | My Forums | Address Book | Member List | Search | FAQ | Ticket List | Log Out

Kemp HLB - Single Arm Config?

Users viewing this topic: none

Logged in as: Guest
  Printable Version
All Forums >> [Microsoft Exchange 2010] >> High Availability >> Kemp HLB - Single Arm Config? Page: [1]
Login
Message << Older Topic   Newer Topic >>
Kemp HLB - Single Arm Config? - 27.Sep.2011 7:33:17 PM   
Berserker

 

Posts: 2
Joined: 27.Sep.2011
Status: offline
Got through reviewing Henrik's article on Load Balancing Exchange 2010 CAS using a Hardware Load Balancer here: http://www.msexchange.org/articles_tutorials/exchange-server-2010/high-availability-recovery/load-balancing-exchange-2010-client-access-servers-using-hardware-load-balancer-solution-part1.html

There is something I don't quite understand that I was hoping someone could shed some light on. According to part 2 of the article, it looks like Henrik is setting up a single arm configuration and using L7 Transparency.

According to the Kemp manual, single arm is defined when the virtual services and the real servers are on the same subnet.

From the Kemp "LoadMaster Deployment Guide for MS Exchange 2010", page 9, it states the following under the L7 Transparency section:

No clients may be located in the same IP subnet with the Real Servers. If necessary, you can use additional ports on the LoadMaster to ensure that Real Servers and Clients are located on distinct IP subnets.

Providing that just the first condition above is met, in a L7 transparent single arm configuration (with Virtual Servers and Real Servers on the same subnet), all clients will be able to still achieve end-to-end connectivity. However, those clients located on the same subnet (and ONLY those clients) will be handled non-transparently, and may experience redundant re-authentication prompts. Virtual Services operating on L4 always act transparently, but end-to-end connectivity will NOT be possible for same-subnet clients.


http://www.kemptechnologies.com/fileadmin/content/downloads/documentation/5.1/KEMP_Exchange_2010_Deployment_Guide_5_1.pdf

My config is pretty straightforward, two multi-role Exchange 2010 servers in a CAS array. External clients <HTTPS> are going through a firewall and into the internal Exchange servers using NAT. Internal clients <MAPI and HTTPS> are on the same subnet as the Exchange servers.

So it looks like I would be using a one-armed config as well with a Kemp HLB.

My questions are, can I still use L7 Transparency like Henrik suggests in his guide if my clients and servers are on the same subnet?

What about the non-transparent issue as suggested by the Kemp manual for one-armed configs? Will Outlook continually prompt to re-authenticate then?

Thanks in advance for any help on this.
Post #: 1
RE: Kemp HLB - Single Arm Config? - 27.Oct.2011 8:17:06 PM   
Berserker

 

Posts: 2
Joined: 27.Sep.2011
Status: offline
Just a heads up, I got my questions answered at the Kemp forums. You can check out the replies there:

http://forums.kemptechnologies.com/viewtopic.php?f=4&t=12657

(in reply to Berserker)
Post #: 2

Page:   [1] << Older Topic    Newer Topic >>
All Forums >> [Microsoft Exchange 2010] >> High Availability >> Kemp HLB - Single Arm Config? Page: [1]
Jump to:

New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Follow TechGenix on Twitter