• RSS
  • Twitter
  • FaceBook

Exchange Server Forums

Forums | Register | Login | My Profile | Inbox | RSS RSS icon | My Subscription | My Forums | Address Book | Member List | Search | FAQ | Ticket List | Log Out

OWA External access failure

Users viewing this topic: none

Logged in as: Guest
  Printable Version
All Forums >> [Microsoft Exchange 2003] >> Outlook Web Access >> OWA External access failure Page: [1] 2   next >   >>
Login
Message << Older Topic   Newer Topic >>
OWA External access failure - 8.Aug.2007 5:02:44 AM   
helderp

 

Posts: 12
Joined: 8.Aug.2007
Status: offline
Hi!

I'm having a problem with OWA. I can access OWA within the organization but I can't access it outside. Outside, I can login and insert the user credentials but after that I only get a 403 error. Does anyone have a clue on what's hapenning? It's Exchange 2003...

PS: I only took control of this server 2 days ago so I'm trying to solve the mistakes that the other team has made before. It also has ISA installed but this does not seem to be the problem...
Post #: 1
RE: OWA External access failure - 8.Aug.2007 8:22:13 AM   
sudhakaranjr

 

Posts: 42
Joined: 15.May2007
Status: offline
Hi,
In most of the cases in this scnario it should be ISA causiing issue. do an nslookup from the ISA to Exchange . Check DNS Entries.

Check OWA listener in the ISA...it should have IP address.
__________________________

Please send the exact Error meesaage and do chck the following KB.
http://support.microsoft.com/kb/899384/en-us

1) do you use FBA? if so do you get the fba page while accessing OWA externally.
____________

Than ks,
Sudhakaran

(in reply to helderp)
Post #: 2
RE: OWA External access failure - 8.Aug.2007 8:27:25 AM   
leederbyshire

 

Posts: 1356
Joined: 4.Jan.2006
Status: offline
There are several reasons for a 403 status.  You will need to look at the IIS Logs on your Exchange server, to:

1. Make sure that the requests are actually getting to it through the ISA server, and
2. Find out what the substatus code number is for the 403 error.

Note that the times in the IIS Logs are in GMT.

_____________________________

Lee.
___________________________________

Outlook Web Access for PDA and WAP:
www.leederbyshire.com
___________________________________

(in reply to helderp)
Post #: 3
RE: OWA External access failure - 8.Aug.2007 10:27:53 AM   
helderp

 

Posts: 12
Joined: 8.Aug.2007
Status: offline
Ok, here it is:
2007-08-08 14:19:12 10.21.x.x GET /Exchange - 80 administrator 66.98.x.x Mozilla/4.0+(compatible;+MSIE+6.0;+Windows+NT+5.2;+SV1;+.NET+CLR+1.1.4322;+.NET+CLR+2.0.50727) 302 0 0

Thanks in advance.

< Message edited by helderp -- 8.Aug.2007 10:31:32 AM >

(in reply to leederbyshire)
Post #: 4
RE: OWA External access failure - 8.Aug.2007 10:40:33 AM   
leederbyshire

 

Posts: 1356
Joined: 4.Jan.2006
Status: offline
The third to last and the second to last numbers are the status and substatus.  In the line you pasted, the status;substatus is 302;0 .  Since you are getting a 403;x error, can you see a line soon after that one where the third to last number is 403 ?

_____________________________

Lee.
___________________________________

Outlook Web Access for PDA and WAP:
www.leederbyshire.com
___________________________________

(in reply to helderp)
Post #: 5
RE: OWA External access failure - 8.Aug.2007 10:49:59 AM   
helderp

 

Posts: 12
Joined: 8.Aug.2007
Status: offline
No, the number 403 never appears. I can login using my credentials but imediatlly after it fails with Error 403 Directory Listing Denied. I believe that permissions are correctly set up.

(in reply to leederbyshire)
Post #: 6
RE: OWA External access failure - 8.Aug.2007 11:02:04 AM   
leederbyshire

 

Posts: 1356
Joined: 4.Jan.2006
Status: offline
The 403 is probably coming from the ISA server then.  The 302 you saw in the IIS Logs means that your browser is being redirected to another URL.  You may have something like an http->https redirect set up, or Default Web Site to /Exchange.  So, assuming you type something like http://servername/exchange to go to OWA,  has the browser address bar changed to something else when the 403 error is displayed?

_____________________________

Lee.
___________________________________

Outlook Web Access for PDA and WAP:
www.leederbyshire.com
___________________________________

(in reply to helderp)
Post #: 7
RE: OWA External access failure - 8.Aug.2007 11:03:36 AM   
helderp

 

Posts: 12
Joined: 8.Aug.2007
Status: offline
Here are 3 attempts to access OWA
2007-08-08 14:23:06 10.21.x.x GET /Exchange - 80 administrator 66.98.x.x Mozilla/4.0+(compatible;+MSIE+6.0;+Windows+NT+5.2;+SV1;+.NET+CLR+1.1.4322;+.NET+CLR+2.0.50727) 302 0 0
2007-08-08 14:23:09 10.21.x.x GET /Exchange - 80 administrator 66.98.x.x Mozilla/4.0+(compatible;+MSIE+6.0;+Windows+NT+5.2;+SV1;+.NET+CLR+1.1.4322;+.NET+CLR+2.0.50727) 302 0 0
2007-08-08 14:23:11 10.21.x.x GET /Exchange - 80 administrator 66.98.x.x Mozilla/4.0+(compatible;+MSIE+6.0;+Windows+NT+5.2;+SV1;+.NET+CLR+1.1.4322;+.NET+CLR+2.0.50727) 302 0 0

This attempts were made from a connection outside the organization.

(in reply to leederbyshire)
Post #: 8
RE: OWA External access failure - 8.Aug.2007 11:06:13 AM   
helderp

 

Posts: 12
Joined: 8.Aug.2007
Status: offline
The server is www.hospital-vilaverde.com
If I put www.hospital-vilaverde.com/exchange it says it can't find the page
If I put webmail.hospital-vilaverde.com/exchange it also says it can't find the page
If I put webmail.hospital-vilaverde.com it asks me the credentials and then fails...

(in reply to leederbyshire)
Post #: 9
RE: OWA External access failure - 8.Aug.2007 11:15:38 AM   
leederbyshire

 

Posts: 1356
Joined: 4.Jan.2006
Status: offline
So, to go to OWA, you normally go to http://webmail.hospital-vilaverde.com (i.e. you don't have /Exchange on the end like the default setup would?)  After you type in the credentials and it fails, what address shows in your browser bar?  The same, or something slightly different?

_____________________________

Lee.
___________________________________

Outlook Web Access for PDA and WAP:
www.leederbyshire.com
___________________________________

(in reply to helderp)
Post #: 10
RE: OWA External access failure - 8.Aug.2007 11:21:19 AM   
helderp

 

Posts: 12
Joined: 8.Aug.2007
Status: offline
In Internet Explorer there is no change in the address bar but in firefox it changes to www.misericrdia-vilaverde.com/Exchange (misericordia is an alias for the domain)

(in reply to leederbyshire)
Post #: 11
RE: OWA External access failure - 8.Aug.2007 11:30:25 AM   
helderp

 

Posts: 12
Joined: 8.Aug.2007
Status: offline
I think I start to understand the problem, www.misericordia-vilaverde points to another internal server in the network that might be running exchange, so this seems to be a redirector problem. I will keep investigating. Thanks in advance.

(in reply to helderp)
Post #: 12
RE: OWA External access failure - 8.Aug.2007 11:33:23 AM   
leederbyshire

 

Posts: 1356
Joined: 4.Jan.2006
Status: offline
Is it possible that http://www.misericordia-vilaverde.com and http://webmail.hospital-vilaverde.com are two different servers?  The fact that the 403 error does not appear in webmail.hospital-vilaverde.com's IIS log makes me think that they are two different computers.  Also, if I try to ping both machines, they resolve to different IP addresses.  My guess is that the Default Web Site of webmail has been redirected to www.misericordia .

_____________________________

Lee.
___________________________________

Outlook Web Access for PDA and WAP:
www.leederbyshire.com
___________________________________

(in reply to helderp)
Post #: 13
RE: OWA External access failure - 8.Aug.2007 11:36:33 AM   
helderp

 

Posts: 12
Joined: 8.Aug.2007
Status: offline
But this redirection only happens from the external access, internally it dows the job right. I'm trying to figure out what's happening. Thank you very much for your precious help.

(in reply to leederbyshire)
Post #: 14
RE: OWA External access failure - 8.Aug.2007 11:42:36 AM   
leederbyshire

 

Posts: 1356
Joined: 4.Jan.2006
Status: offline
It's hard to say what's going on.  Since you have found 302 entries in the IIS log, then that would suggest that it is IIS doing the redirection.  But that doesn't explain why it works internally.  Maybe www.misericordia resolves to a different IP address internally?  Externally it appears to be at a totally different location, since the IP addresses are so different.

_____________________________

Lee.
___________________________________

Outlook Web Access for PDA and WAP:
www.leederbyshire.com
___________________________________

(in reply to helderp)
Post #: 15
RE: OWA External access failure - 8.Aug.2007 11:51:59 AM   
helderp

 

Posts: 12
Joined: 8.Aug.2007
Status: offline
Internally, webmail.hospital-vilaverde.com resolves to the correct server, so that user can access their email accounts. The problem tha I'm facing is that I'm having a hard time finding how the redirection is happening, and why is it happening only externally. Internally, the .10 server is contacted, but externally the request is somehow redirected to .9 server, that happens to have an Exchange entry in IIS. .9 is also the webserver that distributes the "normal" web pages. It's really weird...

(in reply to leederbyshire)
Post #: 16
RE: OWA External access failure - 8.Aug.2007 11:58:11 AM   
leederbyshire

 

Posts: 1356
Joined: 4.Jan.2006
Status: offline
Check the Home Directory properties of the Default Web Site, and the Exchange VDir on your OWA server.  Make sure that the resource location hasn't been changed to 'A redirection to a URL'.

_____________________________

Lee.
___________________________________

Outlook Web Access for PDA and WAP:
www.leederbyshire.com
___________________________________

(in reply to helderp)
Post #: 17
RE: OWA External access failure - 8.Aug.2007 12:02:41 PM   
helderp

 

Posts: 12
Joined: 8.Aug.2007
Status: offline
Everything is correct. I can't understand why is it being redirected to the other server.
the DNS record for webmail is set to .10 server wich is correct, but in the external network, after entering the credencials it goes to the server .9, the one that has misericordia.

(in reply to leederbyshire)
Post #: 18
RE: OWA External access failure - 8.Aug.2007 12:07:20 PM   
leederbyshire

 

Posts: 1356
Joined: 4.Jan.2006
Status: offline
Do your external and internal DNS records match?

(in reply to helderp)
Post #: 19
RE: OWA External access failure - 8.Aug.2007 12:15:49 PM   
helderp

 

Posts: 12
Joined: 8.Aug.2007
Status: offline
Yes, I think they are correct.

(in reply to leederbyshire)
Post #: 20

Page:   [1] 2   next >   >> << Older Topic    Newer Topic >>
All Forums >> [Microsoft Exchange 2003] >> Outlook Web Access >> OWA External access failure Page: [1] 2   next >   >>
Jump to:

New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Follow TechGenix on Twitter