• RSS
  • Twitter
  • FaceBook

Exchange Server Forums

Forums | Register | Login | My Profile | Inbox | RSS RSS icon | My Subscription | My Forums | Address Book | Member List | Search | FAQ | Ticket List | Log Out

OWA Logon Page

Users viewing this topic: none

Logged in as: Guest
  Printable Version
All Forums >> [Microsoft Exchange 2003] >> Message Routing >> OWA Logon Page Page: [1]
Login
Message << Older Topic   Newer Topic >>
OWA Logon Page - 8.Feb.2007 12:18:17 PM   
msXchanger

 

Posts: 65
Joined: 16.Jan.2007
Status: offline
No biggie here, but I was reading this tutorial on the OWA logon.asp page (http://www.msexchange.org/tutorials/OWA2003Forms-based-Authentication-default-domain.html) which made me question my configuration (what else is new). 
 
In the example given in the tutorial, the address for the OWA mailbox is https://mail.testdomain.com, however, for my OWA server, the address I use is https://mycompany.com/exchange/ and I get a popup logon window instead of the page in the tutorial.  This method works fine for me, as I can still access the Exchange mailbox. 
 
Now in the tutorial, Mr. Walther explains the path of the logon.asp file as C:\Program Files\Exchsrvr\exchweb\bin\auth\usa. 
For me, when I type in the address I use for my OWA, it obviously does not go to that directory.  Now, to add to it, if I attempt to access that directory from a web browser, I get the correct logon.asp page, but when I attempt to logon, I receive HTTP error 405:
 

"The page you are looking for cannot be displayed because an invalid method (HTTP verb) was used to attempt access."

 
So, if anyone is understanding my rantings here, gimme a little heads up to correctly config my Exchange Server.  Again, it's no biggie, because I can still access my Exchange mailboxes in OWA, but it'd be nice to have a customizable logon page. 

Thanks for any ideas, or help.
 
 
Post #: 1
RE: OWA Logon Page - 9.Feb.2007 6:19:22 PM   
msXchanger

 

Posts: 65
Joined: 16.Jan.2007
Status: offline
Anything? 

(in reply to msXchanger)
Post #: 2
RE: OWA Logon Page - 16.Feb.2007 5:31:56 AM   
Nicodemius

 

Posts: 42
Joined: 25.Jan.2007
From: London
Status: offline
First of all to get the screen you want you need to enable Form based authentication, otherwise you will see the normal username and password box pop up.

To Fix the Pop Up Login

System Manager.
Servers
Protocols
HTTP
Properties on Exchange Virtual Server
Settings Tab
and put a tick in Enable Form Based Authentication.
Leave compression on High.


https://yourcompany.com/exchange is the default path for exchange.

reason as to why https://mail.testdomain.com like the web page tutorial is because the user configured his IIS on his server/webserver to default to the screen you see

 
This error is because you didn't use https
 
The page you are looking for cannot be displayed because an invalid method (HTTP verb) was used to attempt access."





(in reply to msXchanger)
Post #: 3
RE: OWA Logon Page - 16.Feb.2007 2:54:56 PM   
msXchanger

 

Posts: 65
Joined: 16.Jan.2007
Status: offline
Thanks for the advice, but no go.

The config you suggested for my Exchange Virtual Server are already in place. 

And I don't know what else I can secure in the "...\exchweb\bin\auth\usa" directory of folders.  I am now asked for a password everystep of the way, and when I get to the owalogon.asp, I still get the same HTTP verb error. 


(in reply to msXchanger)
Post #: 4
RE: OWA Logon Page - 17.Feb.2007 2:50:26 PM   
Nicodemius

 

Posts: 42
Joined: 25.Jan.2007
From: London
Status: offline
Hey tell me how are your securing those folders? Explain the process your undertaking.
Also do you understand Active Server Pages??

< Message edited by Nicodemius -- 17.Feb.2007 2:57:48 PM >

(in reply to msXchanger)
Post #: 5
RE: OWA Logon Page - 21.Feb.2007 11:34:57 AM   
msXchanger

 

Posts: 65
Joined: 16.Jan.2007
Status: offline
Sorry about the delay in my response.

From what I understand, I can activate HTTPS in any folder in my Web Sites list in IIS by requiring SSL connections.  With a Certificate installed, I can go to Directory Security within the folder in question and check SSL connections/communications and from there whether or not I want 128-bit encryption. 

For instance, the Exchange Virtual Server listed under my website MyCompany.com, I expand the folder, right click the folder I want secured with HTTPS, and go to Directory Security, click on Edit on Secure Communications and then select SSL or not. 

How's that look?  Am I wrong?

(in reply to Nicodemius)
Post #: 6
RE: OWA Logon Page - 22.Feb.2007 7:32:29 AM   
Nicodemius

 

Posts: 42
Joined: 25.Jan.2007
From: London
Status: offline
Right you are securing the page correctly, but all your really need to do is apply SSL on your default web site and it will propriogate to the rest of the folders contained underneath it.

Directory for OWA:
Open IIS
Expand Default Website
Right Click on ExchWeb
Select Properties
Go to Virtual Directory
The Local path should be pointing to where you OWA Files are located
Default is: C:\Program Files\Exchsrvr\ExchWeb

If you going around changing the way your owa looks two files you going to be interested

owalogon.asp that redirects the user to the correct login.asp file.
it redirects by default it to the usa\logon.asp as it's the english version.
if you wanted it to be be in say hebrew you have owalogin.asp direct to heb\login.asp

to customize the login.asp there are a few strings you can change to give the look you want.
follow this link to technet to see what string to what and how you can customize it.
http://technet.microsoft.com/en-us/aa996007.aspx


Read also this article for additional information regarding redirecting.
http://technet.microsoft.com/en-us/library/aa995720.aspx

Lastly if you want to change the color or tweak a few settings for your users
install the owa administrator tool.
here is the link: http://www.microsoft.com/downloads/details.aspx?familyid=4BBE7065-A04E-43CA-8220-859212411E10&displaylang=en

if you still can't get the page up , could be that you missing files or changed something and it not happy with the changes.











(in reply to msXchanger)
Post #: 7
RE: OWA Logon Page - 26.Feb.2007 9:50:04 AM   
msXchanger

 

Posts: 65
Joined: 16.Jan.2007
Status: offline
Thanks a ton.  I will take a look at all of those and def will post again if I have more issues. 

(in reply to Nicodemius)
Post #: 8
RE: OWA Logon Page - 1.Mar.2007 12:44:16 AM   
msXchanger

 

Posts: 65
Joined: 16.Jan.2007
Status: offline
Ok, I'm missing a file or something.  Could you tell me exactly where the logon.asp and owalogon.asp files are supposed to be located? 

I haven't moved anything, but I have the owalogon.asp file located in:
"\\Program Files\Exchsrvr\ExchWeb\bin\auth\".

I also have the logon.asp located in:
\\Program Files\Exchsrvr\ExchWeb\bin\auth\usa\ and I moved it to \\ProgramFiles\Exchsrvr\ExchWeb to get the logon page to appear below*

I still get a popup window to authenticate users, when I type in the URL:
https://mywebsite/exchange/.

*I do get the actual logon page when I type:
https://mywebsite/exchweb/.
... but when I attempt to logon with sufficient credentials, I am pointed again to the "Page Cannot Be Displayed" message and the address bar points to the "owaauth.dll" located in \\Program Files\Exchsrvr\ExchWeb\bin\auth\. 

So I'm back to square one.  Is the error in the logon.asp page?  Have I lost a page somewhere?  Thanks and I'm sorry if this is confusing.

(in reply to msXchanger)
Post #: 9

Page:   [1] << Older Topic    Newer Topic >>
All Forums >> [Microsoft Exchange 2003] >> Message Routing >> OWA Logon Page Page: [1]
Jump to:

New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Follow TechGenix on Twitter