• RSS
  • Twitter
  • FaceBook

Exchange Server Forums

Forums | Register | Login | My Profile | Inbox | RSS RSS icon | My Subscription | My Forums | Address Book | Member List | Search | FAQ | Ticket List | Log Out

Public Folders, can not Mail Disable

Users viewing this topic: none

Logged in as: Guest
  Printable Version
All Forums >> [Microsoft Exchange 2003] >> Public Folders >> Public Folders, can not Mail Disable Page: [1]
Login
Message << Older Topic   Newer Topic >>
Public Folders, can not Mail Disable - 11.Jun.2004 10:12:00 PM   
vertices

 

Posts: 3
Joined: 11.Jun.2004
From: Flagler Beach, FL
Status: offline
We are running Exchange 2003 Enterprise on Win Server 2003. All updates including SP1 are applied to Exchange. All current Win 2003 server updates are also applied. Exchange is running in Native Mode.

This installation is only 30 days old.

Whenever we create Public Folders, either through an Outlook client or through ESM, they are automatically mail enabled. They then pull down STMP addresses through the recipient policy.

On most Exchange installations, public folders by default are NOT mail enabled. The biggest problem is that we can't mail disable these folders as the only option is to mail enable them.

When you try to mail enable the folders again anyway (in the hopes of it righting itself), ESM gives an error saying the folders are already mail enabled.

So to summarize, ANY public folder created is created as mail enabled by default. However the option under "All tasks" that normally switches to "Mail Disable" when the folder is Mail enabled does not switch. It stays as "Mail Enable" for the option. Thereby there is no way to mail disable the folder.

We have removed the public SMTP addresses from the folders manually and disabled "update from Recipient Policy" so that no one can actually email these public folder from the outside, but we really would prefer to mail disable them.

I would be most grateful to anyone who can assist with this problem.

Thanx in advance. "[Smile]"

[ June 11, 2004, 10:49 PM: Message edited by: vertices ]
Post #: 1
RE: Public Folders, can not Mail Disable - 18.Jun.2004 10:48:00 PM   
vertices

 

Posts: 3
Joined: 11.Jun.2004
From: Flagler Beach, FL
Status: offline
Bump.

Still looking for some help with this matter.

(in reply to vertices)
Post #: 2
RE: Public Folders, can not Mail Disable - 20.Nov.2004 4:19:00 AM   
mayanknt

 

Posts: 14
Joined: 10.Nov.2004
From: NewYork
Status: offline
If your Exchange org is in mixed mode, this is the default. In Native mode, public folders are not automatically mail-enabled when created.

here is the Low Tech solutions
[Wink]
IN ESM> Folders>public folders>folder name>Right-click the folder and choose All-Tasks->Mail Disable. This will remove the email addresses.
[Big Grin]

(in reply to vertices)
Post #: 3
RE: Public Folders, can not Mail Disable - 14.Oct.2005 3:04:40 PM   
lobmeyer

 

Posts: 4
Joined: 21.Apr.2005
From: USA
Status: offline
We are experiencing this problem as well.  We have tried to disable them with WMI scripts and doing it by hand.

Here is what we are seeing:

This was an new box where we replicated over from 5.5 as part of the migration.

Current W2k3 Enterprise
Exchange 2K3 Enterprise

All patches and Hotfixes.

I believe that as part of the replication from 5.5 all PFs were mail enabled.

From the Enterprise System Manager ("ESM") for folders that came over, if I right click on the folder under tasks, it says that I can "Mail Enable" the folder which is what you would expect. 

Now here is the problem.  The folder even though at this point ESM doesn't believe it is mail enabled it really is.  If you then look under properties the folder has all the email addresses according to the recipient policy.

If after you check the properties you go back to the tasks you see that you are now given the option to "Mail Disable" the folder.  I try it and it does NOT WORK.

There have been suggestions in MS news groups to just delete the Public Folder in the Exchange System Objects in the Users & Computers MMC.  I am concerned that this will orphan these enties from the AD and I will have future problems with Public Folders.  I also believe that if you do this you will NEVER be able to "Mail Enable" that PF again.  I have posted notes in all the MS Managed News Groups but no one has answered.  I cross posted in a few others and hope that I would receive a reply but I haven't.

Has anyone from here found a solution for this?  It is a very frustrating problem.

Sincerely,

Fred Lobmeyer

(in reply to mayanknt)
Post #: 4
RE: Public Folders, can not Mail Disable - 21.Nov.2005 12:19:04 PM   
Kurros

 

Posts: 2
Joined: 21.Nov.2005
From: Amsterdam, The Netherlands, Europe
Status: offline
quote:

ORIGINAL: lobmeyer

We are experiencing this problem as well.  We have tried to disable them with WMI scripts and doing it by hand.

Here is what we are seeing:

This was an new box where we replicated over from 5.5 as part of the migration.

Current W2k3 Enterprise
Exchange 2K3 Enterprise

All patches and Hotfixes.

I believe that as part of the replication from 5.5 all PFs were mail enabled.

From the Enterprise System Manager ("ESM") for folders that came over, if I right click on the folder under tasks, it says that I can "Mail Enable" the folder which is what you would expect. 

Now here is the problem.  The folder even though at this point ESM doesn't believe it is mail enabled it really is.  If you then look under properties the folder has all the email addresses according to the recipient policy.

If after you check the properties you go back to the tasks you see that you are now given the option to "Mail Disable" the folder.  I try it and it does NOT WORK.

There have been suggestions in MS news groups to just delete the Public Folder in the Exchange System Objects in the Users & Computers MMC.  I am concerned that this will orphan these enties from the AD and I will have future problems with Public Folders.  I also believe that if you do this you will NEVER be able to "Mail Enable" that PF again.  I have posted notes in all the MS Managed News Groups but no one has answered.  I cross posted in a few others and hope that I would receive a reply but I haven't.

Has anyone from here found a solution for this?  It is a very frustrating problem.

Sincerely,

Fred Lobmeyer


We have the same problem. Is there a solution or a work around, so that Public Folders don't get a email address ?
Hope to hear from anybody.

Sincerely,

Kurros.

(in reply to lobmeyer)
Post #: 5
RE: Public Folders, can not Mail Disable - 21.Nov.2005 1:24:22 PM   
lobmeyer

 

Posts: 4
Joined: 21.Apr.2005
From: USA
Status: offline
The solution is not fun.

First a question.  Is the 5.5 Server gone?  If not then you will continue to have this problem.

Now if the 5.5 servers are all gone then try this experiment.

Create a new Public Folder from Outlook.  Check in ESM I believe (or at least in my case) the folder will be created without being mail enabled and will function as you expect.

Now how to fix all those broken folders:

You have to Bring up AD Users and Computers.
   Click View and Check Advanced Features

This will show you a new item under your Domain called "Microsoft Exchange System Objects"

You will then see a list of all the items in the Public Folders.

You will then need to delete these by hand one by one.  Make sure you don't delete things you are not sure if they are public folders or not. 

My suggestion is to try a few and then check the Public Folder property in ESM.  Remember this is AD you are deleting the items from so you may need to wait for Replication to complete or force replication in "AD Sites and Servers".

Any questions let me know.  I deleted a few hundred entries.  I think I have carpal mouse syndrome now!  ;-(

Fred

(in reply to vertices)
Post #: 6
RE: Public Folders, can not Mail Disable - 22.Nov.2005 11:15:03 AM   
Kurros

 

Posts: 2
Joined: 21.Nov.2005
From: Amsterdam, The Netherlands, Europe
Status: offline
I think we have a different problem than.

We have a BackEnd server. This is a member server of our domain.
On this server we installed a new version of Exchange 2003 Enterprise Edition. We didn't use Exchange before, so we didn't had to migrate.

When we make new Public Folders, they get a email address. It's not possible to disable this.
The properties of the Public Folders shows the option 'Mail Enable', but not 'Mail Disable'.

When I try to click 'Mail Enable' (so that I can disable it after) it says 'The Public Folder Is Already Mail Enabled'.
Also I Can't remove the email addresses. Then the programs says that there has to be one default email address.

Anybody have an idea how I can disable mail for Public Folders and make sure new Public Folders doesn't get a email address (execpt if I configure it to have one) ?

Thank you in advance.

Sincerely

Kurros

(in reply to lobmeyer)
Post #: 7
RE: Public Folders, can not Mail Disable - 22.Nov.2005 1:29:27 PM   
lobmeyer

 

Posts: 4
Joined: 21.Apr.2005
From: USA
Status: offline
Check your recipient policies.  This is what I believe governs the creation of these email addresses.

Also check to make sure that you don't have these entries listed in "AD Users and Computers".  AD dictates what is mail enabled or disabled.  If an entry exists in AD then the folder is basically "Mail Enabled" as it was explained to me.  If there is no record then the SMTP Service can't find a place to deliver it to.  May be the MTA not exactly sure what does the lookup in AD.

Fred

(in reply to Kurros)
Post #: 8

Page:   [1] << Older Topic    Newer Topic >>
All Forums >> [Microsoft Exchange 2003] >> Public Folders >> Public Folders, can not Mail Disable Page: [1]
Jump to:

New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Follow TechGenix on Twitter