• RSS
  • Twitter
  • FaceBook

Exchange Server Forums

Forums | Register | Login | My Profile | Inbox | RSS RSS icon | My Subscription | My Forums | Address Book | Member List | Search | FAQ | Ticket List | Log Out

Random Password prompt on WM6 Active sync

Users viewing this topic: none

Logged in as: Guest
  Printable Version
All Forums >> [Microsoft Exchange 2007] >> Mobility >> Random Password prompt on WM6 Active sync Page: [1]
Login
Message << Older Topic   Newer Topic >>
Random Password prompt on WM6 Active sync - 24.Apr.2009 4:22:52 AM   
mrbraid

 

Posts: 5
Joined: 24.Apr.2009
Status: offline
We have several devices all running either Windows mobile 6 or 6.1 and randomly when they try to sync they get prompted to enter a password.

It should be noted that if they cancel this and then try to sync again in about 5-10 seconds then it works fine without the password prompt.

Also we have several iPhones running on the same activesync setup and they work fine without ever being prompted with a password.

The config is as follows:

Firewall (Checkpoint)
>> ISA 2006 as reverse proxy with a web listerner on port 443 (Cert from Verisign)
>> Exchange 2007 CAS server
>> Exchnage 2007 Mailbox server

Like I said this all works most of the time but randomly users get prompted for there username and password event though they tick the save password on the devices.


Any advice would be much appriciated.

Regards

Mike
Post #: 1
RE: Random Password prompt on WM6 Active sync - 24.Apr.2009 10:49:54 AM   
de.blackman

 

Posts: 3542
Joined: 4.Apr.2005
From: Toronto, Canada
Status: offline
If you check on the activesync policy, is it set to require password? If so have you tried disabling this setting?

_____________________________

Ibrahim Benna - Microsoft Exchange MVP
Forum Moderator
Navantis
@IbrahimBenna

(in reply to mrbraid)
Post #: 2
RE: Random Password prompt on WM6 Active sync - 24.Apr.2009 11:06:26 AM   
mrbraid

 

Posts: 5
Joined: 24.Apr.2009
Status: offline
They have a password policy set to disbale passwords.

The problem is they are getting prompted for there Domain passwords and not device passwords.

(in reply to de.blackman)
Post #: 3
RE: Random Password prompt on WM6 Active sync - 24.Apr.2009 11:08:45 AM   
de.blackman

 

Posts: 3542
Joined: 4.Apr.2005
From: Toronto, Canada
Status: offline
What authentication method(s) are set on the OWA and Microsoft-Server-ActiveSync folder on the CAS server (in Exchange Management console/server config/Client Access)?

_____________________________

Ibrahim Benna - Microsoft Exchange MVP
Forum Moderator
Navantis
@IbrahimBenna

(in reply to mrbraid)
Post #: 4
RE: Random Password prompt on WM6 Active sync - 24.Apr.2009 11:10:08 AM   
mrbraid

 

Posts: 5
Joined: 24.Apr.2009
Status: offline
They are both set to Basic Authentication.

Also the ISA is using FBA with AD

(in reply to de.blackman)
Post #: 5
RE: Random Password prompt on WM6 Active sync - 30.Apr.2009 5:51:48 AM   
aguess

 

Posts: 2
Joined: 30.Apr.2009
Status: offline
I've had the same problem for the past couple of years.  I've had so few users on it that i've not really tried hard to resolve it - like you say, if you click cancel and then send+receive again it works fine.

Also, like you, it's only genuine windows mobile devices that have the problem.  Any nokia, iPhone, Touch, symbian, etc etc works fine and is never prompted.

I've in the past been told it's the heart beat, but as it's every telco and works fine on other phones I don't think it is.

I'm looking at the listener on ISA 2006 now after a google search threw up http://forums.isaserver.org/m_2002013984/mpage_1/key_/tm.htm#2002013994

I've just changed from FBA on the listener to basic HTML and seeing what happens ...

(in reply to mrbraid)
Post #: 6
RE: Random Password prompt on WM6 Active sync - 30.Apr.2009 7:16:10 AM   
mrbraid

 

Posts: 5
Joined: 24.Apr.2009
Status: offline
Thanks for the reply. I have just tried installing the certificate on the device and as yet it has not prompted me for a password.

In terms of FBA or not, nether of them solved the issue for me so Im hoping this cert install on the device go OK.

Any more Ideas anyone??

Cheers

Mike

(in reply to aguess)
Post #: 7
RE: Random Password prompt on WM6 Active sync - 30.Apr.2009 8:20:51 AM   
aguess

 

Posts: 2
Joined: 30.Apr.2009
Status: offline
hmmm ... it's only been a couple of hours, but since i made the change on the listener, but i (or several of the users i asked) haven't been prompted for a password.

as you have a verisign cert (i have a GoDaddy cheapo $15 cert, but it works the same), you really shouldn't have to install it or the CA on the phone as it should be known.

the change i made was on the listener on the Active Sync rule on my ISA 2006 server.  on the authentication tab of the listener i changed the drop down list to HTTP Authentication and ticked the Basic option.  I left the default to windows AD for validation method.

i don't use the server for anything else incoming, so this should be fine for me.  as i said, since making this change i've not been prompted once.

(in reply to mrbraid)
Post #: 8
RE: Random Password prompt on WM6 Active sync - 27.May2009 9:47:44 AM   
mrbraid

 

Posts: 5
Joined: 24.Apr.2009
Status: offline
I finally figured out what was wrong.

We were using 443 from the client to the ISA server and then using bridging to convert the port from 443 to 80 for the traffic between ISA and exchnage.

This is fine for an OWA setup (Which is where we evolved from) but as per the technet site Microsft exchange active sync doesnt support SSL offloading (another term for bridging).

Anyway thought it may be worth posting this just in case someone else has the issue.

If anyone has any questions please let me know and I will do my best to answer them.

Cheers

Mike

(in reply to aguess)
Post #: 9

Page:   [1] << Older Topic    Newer Topic >>
All Forums >> [Microsoft Exchange 2007] >> Mobility >> Random Password prompt on WM6 Active sync Page: [1]
Jump to:

New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Follow TechGenix on Twitter