• RSS
  • Twitter
  • FaceBook

Exchange Server Forums

Forums | Register | Login | My Profile | Inbox | RSS RSS icon | My Subscription | My Forums | Address Book | Member List | Search | FAQ | Ticket List | Log Out

Re-creating/copying public folder from old mail server to a new mail server

Users viewing this topic: none

Logged in as: Guest
  Printable Version
All Forums >> [Microsoft Exchange 2003] >> Public Folders >> Re-creating/copying public folder from old mail server to a new mail server Page: [1] 2   next >   >>
Login
Message << Older Topic   Newer Topic >>
Re-creating/copying public folder from old mail server ... - 12.Sep.2007 6:17:51 AM   
matth76

 

Posts: 25
Joined: 12.Sep.2007
Status: offline
Hi

We have an old mail server with Exchange 2000.  We now have a totally new server machine with Exchange 2003 (sp2). We successfully moved all the mail boxes to this new machine.  However simply moving or copying old public folders to the new machine is proving more difficult, and I don't want to risk losing all the content of the public folders. 

Please can anyone help me on how to re-create the new public folders that are on the old server to our new server?  We want to keep all the content of the old public folders so no emails are lost (this is very important). Please bear with me as I am a novice to Exchange!  Any help is appreciated.

Thank you for any help.
Matt
Post #: 1
RE: Re-creating/copying public folder from old mail ser... - 12.Sep.2007 7:35:44 AM   
ismail.mohammed

 

Posts: 3018
Joined: 9.May2007
From: India
Status: offline
hi,

If your old server is still existing in the environment...

Go to the properties of each public then click on replica tab and add the new server over there, i guess you can manage folder option also when you right click the pf .

Make sure you are replicating the system folder also

I guess this link should  help you
http://support.microsoft.com/kb/822931

(in reply to matth76)
Post #: 2
RE: Re-creating/copying public folder from old mail ser... - 12.Sep.2007 7:55:14 AM   
matth76

 

Posts: 25
Joined: 12.Sep.2007
Status: offline
quote:

ORIGINAL: ismail.mohammed

hi,

If your old server is still existing in the environment...

Go to the properties of each public then click on replica tab and add the new server over there, i guess you can manage folder option also when you right click the pf .

Make sure you are replicating the system folder also

I guess this link should  help you
http://support.microsoft.com/kb/822931


Hi

Thank you for your reply.  I will try what you suggest.  Please can you tell me if I first have to create new "empty" public folders on the new server or is this not necessary?

Both servers are on the same network domain.  What is the system folder called or named as?  When I replicate the public folders from the old mail server to the new mail server will the folders keep the same name and path name (in case that folder was actually a sub folder of another folder)?

We already have two public folders on the new mail server.  When I "replicate" the public folders from the old mail server to the new mail server will the public folders that are already on the new mail server still exist - or will they be overwritten?

And after I have finished the replication will the public folders still remain on the old mail server (just in case anything goes wrong)?

Finally I assume I do all this within the "Public Folders" folder and not the "Public Folder Instances" folder?

Once the public folders from the old mail server have been replicated onto the new mail server my plan is to totally remove the old mail server from our network, and probably get rid off the machine altogether as it is very old.  Do I have to do anything before doing this?

Thank you very much for any help.

< Message edited by matth76 -- 12.Sep.2007 9:17:06 AM >

(in reply to ismail.mohammed)
Post #: 3
RE: Re-creating/copying public folder from old mail ser... - 13.Sep.2007 12:06:48 AM   
ismail.mohammed

 

Posts: 3018
Joined: 9.May2007
From: India
Status: offline
hi,

When you start replicating it will create a copy of the public folder on the destination server. Just you have confirm the size and items, it might vary but not much if you have successfull replication. Laterly you can remove the old server from the replica tab. It won't cause you any issue.

System folders are very important folder when you install first exchange server in the site that server will hold this information, it will store schedule free busy, oab etc. so you need to replicate it. and laterly you can remove the old from replica

This is one of the best article from microsoft which i use to follow all the time before i could migration
How to remove the first Exchange Server 2003 computer from the administrative group
http://support.microsoft.com/kb/822931

(in reply to matth76)
Post #: 4
RE: Re-creating/copying public folder from old mail ser... - 13.Sep.2007 5:53:10 AM   
matth76

 

Posts: 25
Joined: 12.Sep.2007
Status: offline
Hi

Thank you for your reply.  I am now pretty sure I can replicate the public folders to the new mail server.  My question is what do I do with the original folders on the old mail server (the source server)?  For each of the public folders on the old mail server do I need to go into the Replication tab and then highlight the public folder store that references the old mail server and click "remove"?  Is there anything else I need to do so I can fully remove the old (source) mail server from our network?

For safety sake I am going to replicate all public folders from the old mail server to the new mail server, to ensure all system folders are replicated. 

Thank you again for all your help.  I really appreciate it.

(in reply to ismail.mohammed)
Post #: 5
RE: Re-creating/copying public folder from old mail ser... - 13.Sep.2007 6:40:30 AM   
ismail.mohammed

 

Posts: 3018
Joined: 9.May2007
From: India
Status: offline
you can remove the replica from manage setting when you right click the public folder or you can use pfdavadmin.

Your are right you need to highlight the old server name and remove the server from the replica tab.

(in reply to matth76)
Post #: 6
RE: Re-creating/copying public folder from old mail ser... - 14.Sep.2007 5:39:33 AM   
matth76

 

Posts: 25
Joined: 12.Sep.2007
Status: offline
Hi

I have tried replicating one of the public folders on the old mail server to the new mail server.  However it is still not appearing in the new mail server's "Public Folder Store".  It says the replication status is "In Sync".  Is there a small delay before it appears in the new mail server's "Public Folder Store"?

Thank you again for your help.

(in reply to ismail.mohammed)
Post #: 7
RE: Re-creating/copying public folder from old mail ser... - 14.Sep.2007 6:01:27 AM   
ismail.mohammed

 

Posts: 3018
Joined: 9.May2007
From: India
Status: offline
hi,

you can check the status by increasing the diagnostic logging. create a new test pf and check it out
http://msexchangeteam.com/archive/2006/01/17/417611.aspx

Check out the above article for pf replicaiton

(in reply to matth76)
Post #: 8
RE: Re-creating/copying public folder from old mail ser... - 14.Sep.2007 6:08:21 AM   
matth76

 

Posts: 25
Joined: 12.Sep.2007
Status: offline
Thank you for your reply.  I am right in assuming the replicated folder should "appear" in the "Public Folder Store" list on the new mail server?   Currently it only appears in the old mail server's Public Folder Store list of public folders.  I would have thought after the replication it will also appear in the new mail server's public folder store.

The replication status of the public folders that I have tried to replicate says they are "In Sync" meaning I assume it has fully replicated - yet I cannot see the public folder on the new mail server.

I will check out the link you provided.  Thank you. 

How will I know when the replication is complete and that I can remove the public folder from the old mail server public folder store?  When the replication status says: "In sync"?

Would you happen to know why I may receive this message:

A folder design conflict has occurred in "SabreHoldings". The design of this folder has been simultaneously modified on two or more folder replicas. Only the set of changes made last have been saved.


Thank you again.

< Message edited by matth76 -- 14.Sep.2007 11:17:09 AM >

(in reply to ismail.mohammed)
Post #: 9
RE: Re-creating/copying public folder from old mail ser... - 17.Sep.2007 5:08:30 AM   
matth76

 

Posts: 25
Joined: 12.Sep.2007
Status: offline
Hi

Over the weekend I successfully replicated a few of the public folders from the old mail server to the new mail server.  The number of "items" in the new mail server successfully matches the old mail server but the actual "size" does not.  Will the size differ on the new mail server to what the size is on the old mail server?  Why is this?  Is it only the number of "items" that I need to ensure matches the old server?

Thank you for your help.  I appreciate it.

(in reply to matth76)
Post #: 10
RE: Re-creating/copying public folder from old mail ser... - 17.Sep.2007 5:32:30 AM   
ismail.mohammed

 

Posts: 3018
Joined: 9.May2007
From: India
Status: offline
hi matth,

Thank you keeping us posting the current status...
In my environment also it is the same only i can match the items but not size means it will vary but not much....

Let me know if anything else you need from our msexchange.org blog for migration...

(in reply to matth76)
Post #: 11
RE: Re-creating/copying public folder from old mail ser... - 17.Sep.2007 7:35:09 AM   
matth76

 

Posts: 25
Joined: 12.Sep.2007
Status: offline
Hi Mohammed

Thank you for your reply.  Is there a reason why some public folders that I have successfully replicated to the new mail server would still be displayed in the "Public Folder Instances" section on the old mail server - even though I have removed the old mail server from the replication properties of the public folder?  The public folder does not show up in the "Public folders" section on the old mail server which is correct.

It only happens with two or three public folders.  Some disappear as expected once I have fully replicated them to the new mail server and removed the old mail server from the replication properties of the public folder. 

Also would you know if replication of public folders would stop half way and then not go any further?  There are 2494 items in the source (old) mail server but so far only 1061 items have replicated on the new mail server.  I have waited a couple of hours and it seems to go no further. I have tried doing it all again and the second time it reached the same 1061 items and doesn't seem to go any further.  Is there some kind of setting I can check?

Thank you again for any help.

< Message edited by matth76 -- 17.Sep.2007 10:25:39 AM >

(in reply to ismail.mohammed)
Post #: 12
RE: Re-creating/copying public folder from old mail ser... - 18.Sep.2007 12:10:33 AM   
ismail.mohammed

 

Posts: 3018
Joined: 9.May2007
From: India
Status: offline
hi,

When you remove a store from the replica list on a folder, that store does not immediately delete the data. Instead, it sends out a special 0x20 status request to all the other replicas. This is called a Replica Delete Pending Status Request (RDPSR), and can not be distinguished from a normal status request in the application log. A RDPSR contains a flag that indicates the replica is pending deletion. When the other stores receive this 0x20, they respond with a special 0x10 called a Replica Delete Pending Ack (RDPA). The RDPA indicates that it’s ok to delete that data – but the other stores only send this 0x10 if they already have all the CNs that the pending deletion replica has. The replica will only be deleted once the store has received a 0x10 indicating that someone else has the data.

Public Folder Replication Troubleshooting – Part 3: Troubleshooting Replica Deletion and Common Problems
http://msexchangeteam.com/archive/2006/01/23/417974.aspx

How to decommission a Public Folder server without losing any data
http://msexchangeteam.com/archive/2004/05/04/126015.aspx

 Migrating public folders to Exchange 2003
http://searchexchange.techtarget.com/tip/0,289483,sid43_gci1068012,00.html


(in reply to matth76)
Post #: 13
RE: Re-creating/copying public folder from old mail ser... - 18.Sep.2007 4:39:58 AM   
matth76

 

Posts: 25
Joined: 12.Sep.2007
Status: offline
Hi

Thank you for your reply and help.  Would you know why the replication process would stop half way through and go no further?  It keeps stopping at the same number of items for some reason.  Everything was fine until the last couple of public folders - which are not particularly big (I have replicated bigger folders successfully) but for some reason the latest two do not seem to replicate past a certain number of items.

I have made sure there is no replication file size limit on the new mail server but this too has not worked.  Is there a reason for this?

Thank you again for all your help.

(in reply to ismail.mohammed)
Post #: 14
RE: Re-creating/copying public folder from old mail ser... - 18.Sep.2007 4:53:51 AM   
ismail.mohammed

 

Posts: 3018
Joined: 9.May2007
From: India
Status: offline
hi,

Then please have a look on how to troubleshoot public folder replication
How to troubleshoot public folder replication problems in Exchange 2000 Server and in Exchange Server 2003
http://support.microsoft.com/kb/842273

(in reply to matth76)
Post #: 15
RE: Re-creating/copying public folder from old mail ser... - 18.Sep.2007 6:48:13 AM   
matth76

 

Posts: 25
Joined: 12.Sep.2007
Status: offline
Thank you for the link however it doesn't help me.  I've had a good look through it and it doesn't say anywhere about how to troubleshoot replication process stopping half way through.  I did set up some of the diagnostic logging but so far have had no Exchange errors.  I have done searches on my problem but can't find anything that would relate to the problem I am having where the replication is only replicating a certain number of items but not all of them.  Would you know what  might be the cause of the problem I am having?

Do you think the replication process is filtering out certain emails (due to size, or Exchange version)?  I ask this because the replicated emails only ever go up to a certain date 31/1/2006, whereas the emails on the old mail server go all the way up to today's date - so basically everything from 31/1/2006 up to today's date is not able to be replicated for some reason. 

Thank you again for your help Mohammed

< Message edited by matth76 -- 18.Sep.2007 6:55:32 AM >

(in reply to ismail.mohammed)
Post #: 16
RE: Re-creating/copying public folder from old mail ser... - 18.Sep.2007 7:24:30 AM   
ismail.mohammed

 

Posts: 3018
Joined: 9.May2007
From: India
Status: offline
hi matt,

Create one test folder and increase diagnostic logging on both the server and check the replication status and vice versa and if it is working fine.
Then post some content on source public folder server or else create a test folder on the main folder which is not replicating and do the same thing on the destination server.

(in reply to matth76)
Post #: 17
RE: Re-creating/copying public folder from old mail ser... - 18.Sep.2007 9:15:42 AM   
matth76

 

Posts: 25
Joined: 12.Sep.2007
Status: offline
Hi Mohammed

I have tried what you suggest with no success.  The problem seems to be related purely to two particular public folders.  All other public folders have replicated successfully - some much bigger than the two folders that I am having trouble with.  It seems to be related to date or size I would imagine.

Is there anything I can check in the property settings to see why this might be happening?

Bit of a strange problem.  I have searched in great detail through your links and many other pages in Microsoft but not found an answer to my issue.

Thank you for any help.

(in reply to ismail.mohammed)
Post #: 18
RE: Re-creating/copying public folder from old mail ser... - 18.Sep.2007 10:46:27 PM   
ismail.mohammed

 

Posts: 3018
Joined: 9.May2007
From: India
Status: offline
pls check your mailbox...and mail me your opinion..

(in reply to matth76)
Post #: 19
RE: Re-creating/copying public folder from old mail ser... - 16.Oct.2007 7:50:11 AM   
matth76

 

Posts: 25
Joined: 12.Sep.2007
Status: offline
Hi Mohammed
Sorry for the long delay. I have been away. Everything replicates successfully. It only remaining folders that all replicate successfully - but only up to a certain date. Say there are 1000 items - only 800 will replicate successfully for example. And when I go in and look at the emails that been replicated everything is fine up to a certain date. The size of the folders is much smaller than some other much larger public folders that did replicate 100% of the items.
What could cause the replication only up to a certain date?

I'm sure I mentioned this already but the original / source mail server has Exchange 2000 on it, and the new mail server that I am replicating everything to has Exchange 2003.  Could this cause the strange cut off up to a certain date?

Thank you again for your help.

< Message edited by matth76 -- 16.Oct.2007 8:31:22 AM >

(in reply to ismail.mohammed)
Post #: 20

Page:   [1] 2   next >   >> << Older Topic    Newer Topic >>
All Forums >> [Microsoft Exchange 2003] >> Public Folders >> Re-creating/copying public folder from old mail server to a new mail server Page: [1] 2   next >   >>
Jump to:

New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Follow TechGenix on Twitter