• RSS
  • Twitter
  • FaceBook

Exchange Server Forums

Forums | Register | Login | My Profile | Inbox | RSS RSS icon | My Subscription | My Forums | Address Book | Member List | Search | FAQ | Ticket List | Log Out

Re-install OWA?

Users viewing this topic: none

Logged in as: Guest
  Printable Version
All Forums >> [Microsoft Exchange 2007] >> Outlook Web Access >> Re-install OWA? Page: [1]
Login
Message << Older Topic   Newer Topic >>
Re-install OWA? - 3.Jan.2008 12:21:23 PM   
padair

 

Posts: 6
Joined: 11.Jun.2007
Status: offline
I recently had an issue that killed IIS.  The .NET 1.1 SP1 update seems to knock out IIS (and it warns you) but the repair it recommended didn't work.  I since have IIS running again but I had to remove the IIS application server role and then re-add it.  Now that its added again none of the OWA/Exchange app pools or websites are there. 

Is there a simple way to get the necessary OWA/Exchange config back in IIS?  I certainly don't want to have to uninstall all of Exchange server and re-add just to accomplish this.

Any help appreciated.

Thanks, Paul.
Post #: 1
RE: Re-install OWA? - 3.Jan.2008 1:14:42 PM   
leederbyshire

 

Posts: 1356
Joined: 4.Jan.2006
Status: offline
If you re-install IIS, then you normally need to re-install Exchange, too (you don't need to uninstall first).  You might try this (method 3 is easiest):
http://support.microsoft.com/kb/883380
but you may not find the required entries in your metabase file.

_____________________________

Lee.
___________________________________

Outlook Web Access for PDA and WAP:
www.leederbyshire.com
___________________________________

(in reply to padair)
Post #: 2
RE: Re-install OWA? - 3.Jan.2008 4:39:05 PM   
padair

 

Posts: 6
Joined: 11.Jun.2007
Status: offline
Do you know if this link (or another?) works for Exchange 2007?

(in reply to leederbyshire)
Post #: 3
RE: Re-install OWA? - 3.Jan.2008 5:36:28 PM   
padair

 

Posts: 6
Joined: 11.Jun.2007
Status: offline
http://support.microsoft.com/kb/320202/en-us

This did the trick.  So if you ever screw-up your IIS/OWA config this page worked.  Just follow the Exchange 2007 steps line by line.  Worked for me.

(in reply to padair)
Post #: 4
RE: Re-install OWA? - 16.Aug.2008 3:42:11 AM   
genic

 

Posts: 9
Joined: 10.Feb.2008
Status: offline
padair, thank you..thank you..thank you...i just had the exact same thing happen to me (well i screw'd the hole in the wall a different way) and i have been looking for this redo for a bit. this is one of the many reasons i love this place. thank you again!

(in reply to padair)
Post #: 5
RE: Re-install OWA? - 5.Jan.2009 1:22:39 PM   
daffoml

 

Posts: 1
Joined: 5.Jan.2009
Status: offline
Thanks as well!  This is just what I needed!

I will say one thing, I am all on Server 2008/Exch 2007SP1, so I also added the following commands to the end:

  • get-owavirtualdirectory -server server_name -DomainController dc_name | ? {$_.OwaVersion -eq "Exchange2007"} | remove-owavirtualdirectory -DomainController dc_name
  • new-OwaVirtualDirectory -OwaVersion "Exchange2007" -DomainController dc_name

(in reply to genic)
Post #: 6
RE: Re-install OWA? - 29.Aug.2011 11:11:00 AM   
Johnnyg5

 

Posts: 8
Joined: 31.Jan.2011
Status: offline
This worked for me. Thanks for posting it.

(in reply to daffoml)
Post #: 7
RE: Re-install OWA? - 19.Oct.2011 6:00:23 PM   
shanmarsh1

 

Posts: 139
Joined: 13.Sep.2011
Status: offline
My OWA 2003 need to be reinstalled on a New Hardware. I need to keep the same IP and FQDN, what is the best way to achieve this goal?

(in reply to padair)
Post #: 8

Page:   [1] << Older Topic    Newer Topic >>
All Forums >> [Microsoft Exchange 2007] >> Outlook Web Access >> Re-install OWA? Page: [1]
Jump to:

New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Follow TechGenix on Twitter