• RSS
  • Twitter
  • FaceBook

Exchange Server Forums

Forums | Register | Login | My Profile | Inbox | RSS RSS icon | My Subscription | My Forums | Address Book | Member List | Search | FAQ | Ticket List | Log Out

Registered Exchange services have disappeared

Users viewing this topic: none

Logged in as: Guest
  Printable Version
All Forums >> [Microsoft Exchange 5.5] >> General >> Registered Exchange services have disappeared Page: [1]
Login
Message << Older Topic   Newer Topic >>
Registered Exchange services have disappeared - 31.Dec.2010 5:14:33 PM   
stevemen

 

Posts: 12
Joined: 20.Jun.2006
Status: offline
I have a primary and secondary Exchange server 5.5. Primary is Standard, secondary is Enterprise. The secondary will eventually take over but until then I moved only non-essential users onto the secondary to make sure things were working as they should. Its been about a month now and everything was running as expected. I figured it was time to physically move the secondary in with all the other servers which meant turning it off, unplugging and plugging.
After I moved it, turned it on, cmos battery must be dead because I needed to correct the time on mb. After correction, rebooted, server booted just fine until I noticed that exchange was not running. I went into "services" and noticed that all Exchange services were no longer in there.
All my directories are there, my priv.edb and pub.edb are there. Its like Exchange got uninstalled.
Can someone help in trying to explain how this can happen and how can I register the services without reinstalling Exchange?
I did create a system backup, so can I just restore that?
Please, anyone, assistance is very much needed here.

< Message edited by stevemen -- 31.Dec.2010 5:18:43 PM >
Post #: 1
RE: Registered Exchange services have disappeared - 31.Dec.2010 5:26:20 PM   
mark@mvps.org

 

Posts: 6811
Joined: 9.Jun.2004
From: Philadelphia PA
Status: offline
A weird one. What do all the system and application logs say about this? Is the store and the database and/or drive still there?

And 5.5? What's the constraint here?

_____________________________

Mark Arnold (Exchange MVP)
List Moderator

(in reply to stevemen)
Post #: 2
RE: Registered Exchange services have disappeared - 31.Dec.2010 5:32:26 PM   
stevemen

 

Posts: 12
Joined: 20.Jun.2006
Status: offline
Budget contraints prevent us from upgrading. I have been running 5.5 for about 10 years now and it has been good, its just that the 16gb limitation was killing me.

The logs say nothing that would help explain this phenomenon.

I'm really not sure how to proceed here. There is always that concern that I should have done something first.

What about the "system state restore"?

Oh by the way, it is running on Windows Server 2000.

(in reply to mark@mvps.org)
Post #: 3
RE: Registered Exchange services have disappeared - 31.Dec.2010 5:35:22 PM   
stevemen

 

Posts: 12
Joined: 20.Jun.2006
Status: offline
I am going to assume that the store and database are still there thats why I mentioned that the directories and files are still there. I have a 2.5gb priv.edb file which is about right. There wasn't a whole lot of user's on it yet.

When you say "store" what file/files would tell me that its there?

(in reply to stevemen)
Post #: 4
RE: Registered Exchange services have disappeared - 31.Dec.2010 5:44:29 PM   
mark@mvps.org

 

Posts: 6811
Joined: 9.Jun.2004
From: Philadelphia PA
Status: offline
So long as the files are indeed there I would firstly try a system state restore. However, I would initially do a full backup of the whole Windows partition so that you have the thing that's gone awry retained in case you need to go back to it and start again. Stop every service you possibly can and then run the backup.
If the system state puts the services back - and it should because that's what the thing is supposed to do, then since everything else is the same (including the machine name) the directory service should start ok. That is your biggest concern right now.
If the system state won't bring everything back then you're left with little other choice than to reinstall Exchange. I can't remember if there is even a reinstall or whether you are going to have to uninstall and then install.

Something to remember is that just because the box was working OK for years the number of people who have a good enough memory to help you out is probably into single digits. Microsoft won't touch you so you're into private forums like this. 5.5 was a nice solution but it was always a little tricky if the underlying Windows fell over and W2K is not great. I'd have stuck with NT4 but of course that would probably have been brutal to install onto a new-ish server.

_____________________________

Mark Arnold (Exchange MVP)
List Moderator

(in reply to stevemen)
Post #: 5

Page:   [1] << Older Topic    Newer Topic >>
All Forums >> [Microsoft Exchange 5.5] >> General >> Registered Exchange services have disappeared Page: [1]
Jump to:

New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Follow TechGenix on Twitter