• RSS
  • Twitter
  • FaceBook

Exchange Server Forums

Forums | Register | Login | My Profile | Inbox | RSS RSS icon | My Subscription | My Forums | Address Book | Member List | Search | FAQ | Ticket List | Log Out

Shutdown takes very long after isntall Exchange 2003

Users viewing this topic: none

Logged in as: Guest
  Printable Version
All Forums >> [Microsoft Exchange 2003] >> Installation >> Shutdown takes very long after isntall Exchange 2003 Page: [1]
Login
Message << Older Topic   Newer Topic >>
Shutdown takes very long after isntall Exchange 2003 - 7.Sep.2003 12:24:00 AM   
Samplex

 

Posts: 49
Joined: 12.Jul.2003
From: Netherlands
Status: offline
I installed Windows 2003 Standard Edition VLK
Run WIndows update, made a domain with dcpromo.
Installed Exchange 2003 Enterprise edition all goes oke, but when i try to restart my server or shutdown my server it takes sooooo long 10 min or longer to shutdown my pc or restart it.

Who know how this happens. before exchange 2003 it restarted in no time but since exchange 2003 it takes ages
Post #: 1
RE: Shutdown takes very long after isntall Exchange 2003 - 7.Sep.2003 10:07:00 AM   
Henrik Walther

 

Posts: 6928
Joined: 21.Nov.2002
From: Copenhagen, Denmark
Status: offline
Hello Samplex,

What Exchange 2003 build version are you using ?

Regards

(in reply to Samplex)
Post #: 2
RE: Shutdown takes very long after isntall Exchange 2003 - 7.Sep.2003 10:28:00 AM   
Samplex

 

Posts: 49
Joined: 12.Jul.2003
From: Netherlands
Status: offline
Its v6.5 (Build 6944.4)

(in reply to Samplex)
Post #: 3
RE: Shutdown takes very long after isntall Exchange 2003 - 7.Sep.2003 3:11:00 PM   
Henrik Walther

 

Posts: 6928
Joined: 21.Nov.2002
From: Copenhagen, Denmark
Status: offline
Several people has, especially doing the Exchange 2003 BETA stages, complained about slow shutdowns (from 5 to 25 minutes) of Windows 2003 servers with Exchange 2003 installed.

As it's only some people who are experiencing the problem, it would be hard to believe its by design [Eek!]

But Microsoft PSS has in the past given this answer:

This is by design and is expected behavior.

CAUSE - Due to some optimizations in the AD, the directory shuts down
before the Exchange services. However, DSAccess is still attempting to
retry failed searches (retries every 150 seconds) before it finally
gives up.

SOLUTION - For a fast shutdown or restart of the server, stop Exchange
services manually prior to initiating the shutdown.


Hope this helps!

Regards

(in reply to Samplex)
Post #: 4
RE: Shutdown takes very long after isntall Exchange 2003 - 7.Sep.2003 4:30:00 PM   
Samplex

 

Posts: 49
Joined: 12.Jul.2003
From: Netherlands
Status: offline
Is there no regisrty hack or modififcation for this? restarting a server no takes more then 30 min.!

i stopped all services but still it takes long to shut down. not as long with exchange running but still some time

[ September 07, 2003, 05:20 PM: Message edited by: Samplex ]

(in reply to Samplex)
Post #: 5
RE: Shutdown takes very long after isntall Exchange 2003 - 7.Sep.2003 9:12:00 PM   
Henrik Walther

 

Posts: 6928
Joined: 21.Nov.2002
From: Copenhagen, Denmark
Status: offline
No general hacks or reg modifications exists.

What else do you run on the server, There must be a lot of stuff (see services) to shutdown since it takes that long ?

If the Exchange Server is a Domain Controller, you could (if possible) try to remove that role from it as well.

Regards

(in reply to Samplex)
Post #: 6
RE: Shutdown takes very long after isntall Exchange 2003 - 7.Sep.2003 9:20:00 PM   
Samplex

 

Posts: 49
Joined: 12.Jul.2003
From: Netherlands
Status: offline
Yes its a domain controller too.
I want it to be a DC also.

Lets hope MS comes with a fix soon becuase this is hell..

I think the final build should be RC3

(in reply to Samplex)
Post #: 7
RE: Shutdown takes very long after isntall Exchange 2003 - 9.Sep.2003 2:46:00 PM   
willz75

 

Posts: 10
Joined: 9.Sep.2003
From: Au
Status: offline
Yeah I'm experiencing exactly the same problems, takes me about 10mins before it will shutdown. I have reinstalled Windows 2003 and Exchange 2003 numerous times and it still happens. I hope there is a better fix than shutting down the MS Exchange services prior to reboot :S

(in reply to Samplex)
Post #: 8
RE: Shutdown takes very long after isntall Exchange 2003 - 9.Sep.2003 3:08:00 PM   
willz75

 

Posts: 10
Joined: 9.Sep.2003
From: Au
Status: offline
By stopping all exchange services it shutdown in about 3 minutes compared to 10 minutes... better but I hope there is a proper fix for this.

(in reply to Samplex)
Post #: 9
RE: Shutdown takes very long after isntall Exchange 2003 - 9.Sep.2003 4:02:00 PM   
iscott

 

Posts: 2
Joined: 9.Sep.2003
From: louisiana
Status: offline
I've noticed the same issue with my ex2003 server, I was thinking it might be an AD problem.

(in reply to Samplex)
Post #: 10
RE: Shutdown takes very long after isntall Exchange 2003 - 9.Sep.2003 8:09:00 PM   
brentivey

 

Posts: 4
Joined: 13.Sep.2002
From: Kansas City
Status: offline
Add Me to the list of people that are having this problem. It is happening on 2 seperate systems. One with Windows 2000 and Exchange 2k3, and the other with Windows 2003 and Exchange 2k3. Two Seperate OS's leaving only Exchange 2k3 as the common denominator.

I hope there is some news soon.

(in reply to Samplex)
Post #: 11
RE: Shutdown takes very long after isntall Exchange 2003 - 9.Sep.2003 8:45:00 PM   
brentivey

 

Posts: 4
Joined: 13.Sep.2002
From: Kansas City
Status: offline
TEMPORARY FIX

Registry Edit.

HKLM/System/CurrentControlSet/Control

Change the WaitToKillServiceTimeout from 600,000 to about 120,000.

That changes how long to wait from 10min (600,000 ms) to 2min (120,000ms)

It seems that a service is not wanting to shutdown correctly, and Windows is waiting the 10 min. per service to shutdown.

I am planning to only change this while configuring the Server, and once all my reboots are done, I will most likely change it back to the default 600,000, but this will at least help waiting 1hr per day, just on reboots during server initial config.

Good Luck. -

(in reply to Samplex)
Post #: 12
RE: Shutdown takes very long after isntall Exchange 2003 - 9.Sep.2003 8:50:00 PM   
Henrik Walther

 

Posts: 6928
Joined: 21.Nov.2002
From: Copenhagen, Denmark
Status: offline
Hello again,

As I already mentioned the problem is caused by optimizations i AD and the fact that DSAccess needs to timeout before shutdown of the Exchange Services.

My guess is Microsoft at some point in the near future will come out with a hotfix, maybe a fix which will lower the DSAccess timeouts etc.

But until then I guess we all need to have patience [Roll Eyes]

Note it's not everybody who have these extremely long shutdown times, as an example my Exchange 2003 server generally shuts down after 2-3 minutes (I use the final build).

Regards

(in reply to Samplex)
Post #: 13
RE: Shutdown takes very long after isntall Exchange 2003 - 10.Sep.2003 1:47:00 AM   
willz75

 

Posts: 10
Joined: 9.Sep.2003
From: Au
Status: offline
Henrik,

Your workaround seems to work for me, at this stage I've done a batch file to stop all Exchange services prior to shutdown and it works a charm, typically takes 2-3mins now. Thanks for the tip!

Thanks

(in reply to Samplex)
Post #: 14
RE: Shutdown takes very long after isntall Exchange 2003 - 10.Sep.2003 7:55:00 AM   
Samplex

 

Posts: 49
Joined: 12.Jul.2003
From: Netherlands
Status: offline
@willz

Can you please post the index of your batch file?

[ September 10, 2003, 07:57 AM: Message edited by: Samplex ]

(in reply to Samplex)
Post #: 15
RE: Shutdown takes very long after isntall Exchange 2003 - 10.Sep.2003 1:33:00 PM   
willz75

 

Posts: 10
Joined: 9.Sep.2003
From: Au
Status: offline
quote:
Originally posted by Samplex:
@willz

Can you please post the index of your batch file?

Simple batch file using the SC.exe command:

sc stop MSExchangeMTA
sc stop MSExchangeMGMT
sc stop MSExchangeIS
sc stop MSExchangeSA

Give it say 10-20 secs before shutting down the server as the services take a bit of time to stop.
It beats going into services and manually stopping them [Razz]

Hope this helps
Willz75

(in reply to Samplex)
Post #: 16
RE: Shutdown takes very long after isntall Exchange 2003 - 15.Sep.2003 10:59:00 PM   
fustrated

 

Posts: 3
Joined: 2.Sep.2003
From: usa
Status: offline
are you recieving any error upon boot up.... I had a similar issue after I loaded some patches the nlb service was failing and taking forever to shutdown. Via a knowledge base I removed the info that it ask and shutdown has now sped up.

(in reply to Samplex)
Post #: 17
RE: Shutdown takes very long after isntall Exchange 2003 - 16.Sep.2003 2:45:00 AM   
willz75

 

Posts: 10
Joined: 9.Sep.2003
From: Au
Status: offline
Yes, when it boots up after a long shutdown there are 4 or so Exchange related errors saying it can't locate domain controller and so on...
Which knowledgebase article is this?

[ September 16, 2003, 02:47 AM: Message edited by: willz75 ]

(in reply to Samplex)
Post #: 18

Page:   [1] << Older Topic    Newer Topic >>
All Forums >> [Microsoft Exchange 2003] >> Installation >> Shutdown takes very long after isntall Exchange 2003 Page: [1]
Jump to:

New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Follow TechGenix on Twitter