• RSS
  • Twitter
  • FaceBook

Exchange Server Forums

Forums | Register | Login | My Profile | Inbox | RSS RSS icon | My Subscription | My Forums | Address Book | Member List | Search | FAQ | Ticket List | Log Out

Store's will not mount...Please Help!

Users viewing this topic: none

Logged in as: Guest
  Printable Version
All Forums >> [Microsoft Exchange 2003] >> Installation >> Store's will not mount...Please Help! Page: [1]
Login
Message << Older Topic   Newer Topic >>
Store's will not mount...Please Help! - 30.Nov.2006 4:17:03 PM   
Crummy

 

Posts: 5
Joined: 30.Nov.2006
Status: offline
Hello all,

First I'll start off saying that our server crashed about a week ago. We finnaly got everything back up and running and restored, but the Exchange isnt working. When I go and try to mount the Mailbox Store and the Public Folder Store it gives me this error:
"An internal processing error has occured. Try restarting the Exchange System Manager or the Microsoft Exchange Informatio Store Service, or both. ID No: c1041724." I have restarted both of those services multiple times and still get the same error.

I also ran the Microsoft Exchange Server Best Practics Analyzer Tool. With this I got this error:
"Cannot connect to port 25 of the routing group master. Server SBS01 is a routing gropu master but a connection to port 25 cannot be established from the workstation where this tool is running."

I have looked at the solution but everything checks out. I have everything setup they way its supposed to be to my knowledge.
When I try to do a nslookup.exe, it says that it "Can't find server name for address 10.10.1.20" Timed out. Default Server UnKnown Address: 10.10.1.20:
I tried a restore a few days ago, and tried to restore the public folders and database...could this have possibly corupted the Exchange??
If somebody could help me resolove this issue it would be greatly appriciated, I am stuck between a rock and a hard place!

< Message edited by Crummy -- 30.Nov.2006 4:20:12 PM >
Post #: 1
RE: Store's will not mount...Please Help! - 30.Nov.2006 4:20:00 PM   
jchong

 

Posts: 2516
Joined: 1.Dec.2005
From: Centreville, Virginia
Status: offline
Run exchange troubleshooting assistant and run through the mount questionaire.

http://www.microsoft.com/technet/prodtechnol/exchange/downloads/2003/analyzers/default.mspx

_____________________________

James Chong
MCSE | M+, S+, MCTS, Security+
msexchangetips.blogspot.com

(in reply to Crummy)
Post #: 2
RE: Store's will not mount...Please Help! - 30.Nov.2006 4:35:42 PM   
Crummy

 

Posts: 5
Joined: 30.Nov.2006
Status: offline

I did as you said and ran the Mount problem report this is what it gave me:
 

Analysis Results: Public Folder Store (SBS01)

Database Status is 'Dirty ShutDown'


Detail: All necessary log files required to recover this database are present. Exchange server will try to automatically recover this database if you mount it. This may fail if (1) another database in the storage group is not in a recoverable state or (2) if there are missing or mismatched transaction log or checkpoint files or (3) if the database or its required transaction log files are damaged.

Database Information:

Domain controller you selected is :
Server you selected is : SBS01
Storage group you selected is : First Storage Group
Database you selected is : Public Folder Store (SBS01)
Lowest Required Log File is: 0x844
Max Required Log File is : 0x844
Lowest Log File Found in Log Directory : E0000001.log
Highest Log File Found in Log Directory: E0000844.log

(in reply to jchong)
Post #: 3
RE: Store's will not mount...Please Help! - 30.Nov.2006 4:45:01 PM   
jchong

 

Posts: 2516
Joined: 1.Dec.2005
From: Centreville, Virginia
Status: offline
Can you see if your log file has your your checkpoint file ends with .chk? If so try cutting it and moving it to another folder so Exchange can replay all your logs from the beginning in case this file is corrupt. If that doesn't work you may have to resort to running a repair eseutil /p

_____________________________

James Chong
MCSE | M+, S+, MCTS, Security+
msexchangetips.blogspot.com

(in reply to Crummy)
Post #: 4
RE: Store's will not mount...Please Help! - 30.Nov.2006 5:00:22 PM   
Crummy

 

Posts: 5
Joined: 30.Nov.2006
Status: offline
Exchange isnt my strongest point lol so if I sound like an idiot, I apoligize.

To make certain, where would that log file be located? I did a seach under my Exchange folder and the only .chk that comes up is an R00.chk file. When I seach for a checkpoint nothing comes up and when I do a check* three files come up but they are all .gif files.

I have tried running the eseutil/p. Its acting strange to me.
I cannot go to the cmd prompt and open the eseutil.exe. I have to do a search or go to my bin folder under exchange and open it. Then when I type one of the letters to run an operation it scrolls through a bunch of stuff really quick and then the window closes and it dosent tell me anything.
Is this how this eseutil is supposed to work or no?

(in reply to jchong)
Post #: 5
RE: Store's will not mount...Please Help! - 30.Nov.2006 5:12:30 PM   
jchong

 

Posts: 2516
Joined: 1.Dec.2005
From: Centreville, Virginia
Status: offline
Don't worry about the chk point file if it's now showing up. Your db would've just attempted to replay all your logs if it's not present, but since you can't mount it's prob not an issue with that. You will prob have to run eseutil to repair.

Run eseutil /p from your Exchange bin directory. So open a command prompt and change your directory to your exchange bin folder.
Go to this link below and find the link
How to Run Eseutil /P (Repair) in Different Scenarios.

http://www.microsoft.com/technet/prodtechnol/exchange/Guides/ESEUtil/31e8e734-54dc-4710-95f0-6b9cab8ff2df.mspx?mfr=true

_____________________________

James Chong
MCSE | M+, S+, MCTS, Security+
msexchangetips.blogspot.com

(in reply to Crummy)
Post #: 6
RE: Store's will not mount...Please Help! - 1.Dec.2006 10:04:55 AM   
Crummy

 

Posts: 5
Joined: 30.Nov.2006
Status: offline
Ok, so I open the eseutil.exe file from the bin folder and it comes up with the cmd screen and the top reads Description: Maintenance utilities for Microsoft Exchange Server databases.
Modes of Operation:......Then it list all of the modes, at the bottom of that it gives this: <<<<<Press a key for mroe help>>>>>
D=Defragmentation, R=Recovery, G=inteGrity, K=checKsum, P=rePair, M=file duMp, Y=copY file, C=restore.
No matter what button I hit, it runs really fast though a bunch of stuff and then the screen closes its self. I cannot type in a command or anything.

(in reply to jchong)
Post #: 7
RE: Store's will not mount...Please Help! - 1.Dec.2006 10:59:34 AM   
de.blackman

 

Posts: 3542
Joined: 4.Apr.2005
From: Toronto, Canada
Status: offline
from the log entries you reported from the troubleshooting assistant, it seems the log files that are required are already in place.

1. Go to the location where your E00x.log files are located. Create a new folder in there. Move ALL the log files into that folder
2. From the newly created folder, copy the  E0000844.log file back into the location where the logs originally existed.
3. Rename this file to E00.log and try to mount the store.

Is it only the public folder store that is not mounting?

_____________________________

Ibrahim Benna - Microsoft Exchange MVP
Forum Moderator
Navantis
@IbrahimBenna

(in reply to Crummy)
Post #: 8
RE: Store's will not mount...Please Help! - 1.Dec.2006 11:13:30 AM   
Crummy

 

Posts: 5
Joined: 30.Nov.2006
Status: offline
Ok, I put all of the .log files in the new folder, all the .log files I have are as follows:
E00.log
E0000001.log
E0000840.log
E0000841.log
E0000842.log
E0000843.log
E0000844.log
res1.log
res2.log

I put the E0000844.log back in the MDBDATA folder where they were originally, renamed it to E00.log, closed the window, brought the System Manager back up and tried to mount the store. I thought it was going to because it was taking a little longer than ussual, but it still failed with the same error telling me to restart the services. I even did the steps over and restarted the services before trying to mount the store and it still didnt work.

I'm not able to mount the Public Store or the Mailbox Store.

< Message edited by Crummy -- 1.Dec.2006 11:21:36 AM >

(in reply to de.blackman)
Post #: 9
RE: Store's will not mount...Please Help! - 1.Dec.2006 12:11:05 PM   
jchong

 

Posts: 2516
Joined: 1.Dec.2005
From: Centreville, Virginia
Status: offline
c:\programfiles\exchsrvr\bin>eseutil \p c:\programfiles\exchsrvr\mbbdata\priv.edb

You will need to confirm the paths with where your bin and db is stored.

I would also make a copy of your db to another drive or folder so you have a backup in case.


_____________________________

James Chong
MCSE | M+, S+, MCTS, Security+
msexchangetips.blogspot.com

(in reply to Crummy)
Post #: 10
RE: Store's will not mount...Please Help! - 1.Dec.2006 7:45:48 PM   
jchong

 

Posts: 2516
Joined: 1.Dec.2005
From: Centreville, Virginia
Status: offline
One other thing I want to point out. This is odd because, Exchange troubleshooting asistant reports that all your log files are there, but it won't mount. Now running eseutil may or may not fix it, because this issue may not be related to db corruption or log file issues. Mounting issues can also be caused by not having the same parameters as the original box. For example things like not having the same service pack level as the original box can cause it not to mount. Running eseutil won't help in this case. Are you sure when you built the server it's as much of a clone as possible meaning same service pack, patch level, db path etc?

Also if the eseutil does not get it to mount, I want you to go ahead and export the headers of your db and log files and post them.

http://www.msexchange.org/articles/Transaction-Logs-Lifeblood-Exchange.html

_____________________________

James Chong
MCSE | M+, S+, MCTS, Security+
msexchangetips.blogspot.com

(in reply to jchong)
Post #: 11

Page:   [1] << Older Topic    Newer Topic >>
All Forums >> [Microsoft Exchange 2003] >> Installation >> Store's will not mount...Please Help! Page: [1]
Jump to:

New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Follow TechGenix on Twitter