• RSS
  • Twitter
  • FaceBook

Exchange Server Forums

Forums | Register | Login | My Profile | Inbox | RSS RSS icon | My Subscription | My Forums | Address Book | Member List | Search | FAQ | Ticket List | Log Out

Test-outlookwebservices

Users viewing this topic: none

Logged in as: Guest
  Printable Version
All Forums >> [Microsoft Exchange 2007] >> Mobility >> Test-outlookwebservices Page: [1]
Login
Message << Older Topic   Newer Topic >>
Test-outlookwebservices - 4.Nov.2008 4:17:36 PM   
stevenjwilliams83

 

Posts: 102
Joined: 18.Mar.2008
Status: offline
>test-outlookwebservices swilliams
                   Id                                                               Type Message
                   --                                                               ---- -------
                 1003                                                        Information About to test AutoDiscover with the e-mail address swilliams@q...
                 1006                                                        Information The Autodiscover service was contacted at https://exch07srv01....
                 1016                                                            Success [EXCH]-Successfully contacted the AS service at https://exch07...
                 1015                                                        Information [EXCH]-The OAB is not configured for this user.
                 1014                                                            Success [EXCH]-Successfully contacted the UM service at https://exch07...
                 1013                                                              Error When contacting https://mail.MyDomain.com/EWS/Exchange.asmx r...
                 1016                                                              Error [EXPR]-Error when contacting the AS service at
https://mail.My...
                  1015                                                        Information [EXPR]-The OAB is not configured for this user.
                 1014                                                            Success [EXPR]-Successfully contacted the UM service at https://mail.M...
                 1017                                                            Success [EXPR]-Successfully contacted the RPC/HTTP service at https://...
                 1006                                                            Success The Autodiscover service was tested successfully.
                 1021                                                        Information The following web services generated errors....


Why am I getting errors on the two in bold?  Everything else seems ok.
Post #: 1
RE: Test-outlookwebservices - 5.Nov.2008 3:42:35 PM   
Naddy

 

Posts: 139
Joined: 22.Oct.2008
Status: offline
Hi Mate,

can you post the error messages with details and also the infomation event detail just after these 2 error messages.

(in reply to stevenjwilliams83)
Post #: 2
RE: Test-outlookwebservices - 6.Nov.2008 2:24:53 PM   
stevenjwilliams83

 

Posts: 102
Joined: 18.Mar.2008
Status: offline
Is this what you are looking for?

Id      : 1003
Type    : Information
Message : About to test AutoDiscover with the e-mail address swilliams@MyDomain.com.
Id      : 1006
Type    : Information
Message : The Autodiscover service was contacted at https://exch07srv01.MyDomain.local/Autodiscover/Autodiscover.xml.
Id      : 1016
Type    : Success
Message : [EXCH]-Successfully contacted the AS service at https://exch07srv01.MyDomain.local/EWS/Exchange.asmx. The elapsed time was 62 milliseconds.
Id      : 1015
Type    : Information
Message : [EXCH]-The OAB is not configured for this user.
Id      : 1014
Type    : Success
Message : [EXCH]-Successfully contacted the UM service at https://exch07srv01.MyDomain.local/UnifiedMessaging/Service.asmx. The elapsed time was 31 milliseconds.
Id      : 1013
Type    : Error
Message : When contacting https://mail.MyDomain.com/EWS/Exchange.asmx received the error The request failed with an empty response.
Id      : 1016
Type    : Error
Message : [EXPR]-Error when contacting the AS service at https://mail.MyDomain.com/EWS/Exchange.asmx. The elapsed time was 15 milliseconds.
Id      : 1015
Type    : Information
Message : [EXPR]-The OAB is not configured for this user.
Id      : 1014
Type    : Success
Message : [EXPR]-Successfully contacted the UM service at https://mail.MyDomain.com/UnifiedMessaging/Service.asmx. The elapsed time was 15 milliseconds.
Id      : 1017
Type    : Success
Message : [EXPR]-Successfully contacted the RPC/HTTP service at https://mail.MyDomain.com/Rpc. The elapsed time was 0 milliseconds.
Id      : 1006
Type    : Success
Message : The Autodiscover service was tested successfully.
Id      : 1021
Type    : Information
Message : The following web services generated errors.
             As in EXPR
         Please use the prior output to diagnose and correct the errors.

(in reply to stevenjwilliams83)
Post #: 3
RE: Test-outlookwebservices - 6.Nov.2008 3:12:36 PM   
Exchange_Geek

 

Posts: 1287
Joined: 31.Dec.2006
Status: offline
1) Does your certificate have Subject Alternate Name with "mail.MyDomain.com" specified in it (You can find this running command Get-ExchangeCertificate)
Ref: Link

2) Does your DNS have a record hosted for mail.mydomain.com registered ?
If you perform nslookup for this - does mail.mydomain.com resolve ??

(in reply to stevenjwilliams83)
Post #: 4
RE: Test-outlookwebservices - 6.Nov.2008 3:29:47 PM   
stevenjwilliams83

 

Posts: 102
Joined: 18.Mar.2008
Status: offline
[PS] C:\Documents and Settings\Administrator>get-exchangecertificate
Thumbprint                                Services   Subject
----------                                --------   -------
7728E0B764E326C4B20794D2D7E0B17AF3E6FCB2  IP.W.      CN=mail.MyDomain.com, OU=IT, O="CompanyName", L=City, S=State, C=US
5BBA6739902C544E427A43D9E9977F40A0EA86E6  .P..S      CN=exch07srv01

Nslookup resolves mail.MyDomain.com to the external IP address of my ISA server.

(in reply to Exchange_Geek)
Post #: 5
RE: Test-outlookwebservices - 6.Nov.2008 4:01:06 PM   
Naddy

 

Posts: 139
Joined: 22.Oct.2008
Status: offline
Thanks for the post. Did you checked the Autodiscovery if not then....hold down the CTRL key and right click on the outlook  icon and click on the option "Test Email Auto configutarion" ......uncheck the options 'use guessmart' and ' secure guessmart authentication'.....check the result.

Are the Client users having any issues with OWA or Outlook anywhere.?

(in reply to stevenjwilliams83)
Post #: 6
RE: Test-outlookwebservices - 6.Nov.2008 4:45:36 PM   
stevenjwilliams83

 

Posts: 102
Joined: 18.Mar.2008
Status: offline
Autodiscovery results were good, but the only results that came up for exch07srv01.MyDomain.local which is my internal url..... No problems with outlook anywhere or OWA....the only problem I have is that i cant use autodiscover feature outside my internal network when PC is not part of Domain....but if I program HTTP over RPC settings in the client everything works great.  Ideas??

(in reply to Naddy)
Post #: 7
RE: Test-outlookwebservices - 6.Nov.2008 4:50:46 PM   
Exchange_Geek

 

Posts: 1287
Joined: 31.Dec.2006
Status: offline
Ref: http://exchange-genie.blogspot.com/2007/07/autodiscover-ad-attribute.html

(in reply to stevenjwilliams83)
Post #: 8
RE: Test-outlookwebservices - 6.Nov.2008 4:56:00 PM   
stevenjwilliams83

 

Posts: 102
Joined: 18.Mar.2008
Status: offline
What does it mean when it says OAB is not configured for this user?

(in reply to Exchange_Geek)
Post #: 9
RE: Test-outlookwebservices - 6.Nov.2008 5:05:49 PM   
Exchange_Geek

 

Posts: 1287
Joined: 31.Dec.2006
Status: offline
quote:

No problems with outlook anywhere or OWA....the only problem I have is that i cant use autodiscover feature outside my internal network when PC is not part of Domain.


Buddy, OA or Outlook anywhere comes into the picture only when your client box is not connected to the network + OwA has nothing to do with Autodisovery service.

So, for you the outlook anywhere doesn't seem to work i believe.

(in reply to stevenjwilliams83)
Post #: 10
RE: Test-outlookwebservices - 6.Nov.2008 5:19:36 PM   
Naddy

 

Posts: 139
Joined: 22.Oct.2008
Status: offline
quote:

What does it mean when it says OAB is not configured for this user?


The Mailbox database in which the user has their Mailbox is pointing to the correct OAB which is in Exchange 2007

(in reply to stevenjwilliams83)
Post #: 11
RE: Test-outlookwebservices - 6.Nov.2008 6:47:27 PM   
Naddy

 

Posts: 139
Joined: 22.Oct.2008
Status: offline
sorry,
The Mailbox database in which the users have their Mailbox is not pointing to the correct OAB which is in Exchange 2007

(in reply to Naddy)
Post #: 12
RE: Test-outlookwebservices - 7.Nov.2008 9:38:24 AM   
stevenjwilliams83

 

Posts: 102
Joined: 18.Mar.2008
Status: offline
No, outlook anywhere works.  I am a user with a laptop connected to my domain on the internal network, when i configure the Exchange proxy settings in my outlook, and leave my local network and go home I can still access my exchange server via outlook, just like i was at the office.  By autodiscover not working I meant, if I have a brand new laptop, not a member of the domain, and I try to set up a new inbox for my username, I cant just enter in email address and password, I need to actually select manual settings and set Exchange proxy up to set up the inbox for my username. 

(in reply to Exchange_Geek)
Post #: 13
RE: Test-outlookwebservices - 7.Nov.2008 9:44:39 AM   
stevenjwilliams83

 

Posts: 102
Joined: 18.Mar.2008
Status: offline
Well everything I can see OAB is good.  And I have uninstalled my 2003 exchange server, so nothing is held over there?  How do i fix this?

(in reply to Naddy)
Post #: 14

Page:   [1] << Older Topic    Newer Topic >>
All Forums >> [Microsoft Exchange 2007] >> Mobility >> Test-outlookwebservices Page: [1]
Jump to:

New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Follow TechGenix on Twitter