• RSS
  • Twitter
  • FaceBook

Exchange Server Forums

Forums | Register | Login | My Profile | Inbox | RSS RSS icon | My Subscription | My Forums | Address Book | Member List | Search | FAQ | Ticket List | Log Out

Unable to uninstall Exchange due to a "potential DAG"

Users viewing this topic: none

Logged in as: Guest
  Printable Version
All Forums >> [Microsoft Exchange 2013] >> High Availability >> Unable to uninstall Exchange due to a "potential DAG" Page: [1]
Login
Message << Older Topic   Newer Topic >>
Unable to uninstall Exchange due to a "potential D... - 20.Oct.2016 3:21:14 AM   
rubzzz34

 

Posts: 2
Joined: 20.Oct.2016
Status: offline
Hi guys,

This is the first time I post on this forum ;-)
I'm working as an Exchange Administrator, and facing a weird issue : Let me explain the context

Context is simple, I've to demote Exchange infrastructure on 2 exchange servers. These servers are not members of an availability group.
Following technet advice, i move the monitoring & arbitration mailboxes from this server to the other one.
I've also been able to dismount & destroy the database after the move. Faulted server doesn't hold anymore any database and of course any mailboxes.

Trying to uninstall the product fails indicating that the server is member of a DAG.

I tried to seek into the registry and in this registry hive HKLM\SOFTWARE\Microsoft\ExchangeServer\v15\ActiveManager I found a key 'LastKnownDagName' indicating the DAG created in the past.
Obviously, I've backed-up the hive and remove this entry.

Of course, I'm still not able to uninstall on this second exchange server.... Heeeeeelppppp !!!! this issue is going to make me crazy :PPP


Thank you very much for your help ;-)
Post #: 1
RE: Unable to uninstall Exchange due to a "potenti... - 20.Oct.2016 8:33:50 AM   
rubzzz34

 

Posts: 2
Joined: 20.Oct.2016
Status: offline
Hi guys,

Issue seems to be resolved, I will share with you the results of my investigations.
After, capturing some traces using procmon & also checking the exchangesetuplog, i've seen the exchange setup process tries to check the presence of a Cluster Service.

Mine was not setup, nor usefull, but still being present on the services side.
Consequence, the system should not use it, but due to the presence it results has if it were having Availability Groups.

After having disabled the service and retry to uninstall, the process is currently running and uninstalling my first node.

I hope this could help anyone ;-)

(in reply to rubzzz34)
Post #: 2

Page:   [1] << Older Topic    Newer Topic >>
All Forums >> [Microsoft Exchange 2013] >> High Availability >> Unable to uninstall Exchange due to a "potential DAG" Page: [1]
Jump to:

New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Follow TechGenix on Twitter