• RSS
  • Twitter
  • FaceBook

Exchange Server Forums

Forums | Register | Login | My Profile | Inbox | RSS RSS icon | My Subscription | My Forums | Address Book | Member List | Search | FAQ | Ticket List | Log Out

Using RPC with Vista

Users viewing this topic: none

Logged in as: Guest
  Printable Version
All Forums >> [Microsoft Exchange 2007] >> Mobility >> Using RPC with Vista Page: [1]
Login
Message << Older Topic   Newer Topic >>
Using RPC with Vista - 3.Jun.2008 1:34:09 PM   
cmiller02

 

Posts: 2
Joined: 3.Jun.2008
Status: offline
I seem to be having a problem using RPC with Vista on a remote PC. Everything works fine when it is setup on XP but with Vista it will not connect using the same setup techniques. I've changed the authentication from Basic to NTLM and back again, reset the users AD password, tried qualifiying his login name with @abc.com and still will not connect. We are using Exchange 2007. Has anyone else had this problem when migrating over to Vista, if so please help! 
Post #: 1
RE: Using RPC with Vista - 3.Jun.2008 5:19:44 PM   
romrunning

 

Posts: 50
Joined: 13.May2008
Status: offline
You may want to include more info on what exactly doesn't work and any error msgs.

(in reply to cmiller02)
Post #: 2
RE: Using RPC with Vista - 4.Jun.2008 10:12:15 AM   
cmiller02

 

Posts: 2
Joined: 3.Jun.2008
Status: offline
Here are the details:

Error message is: Exchange Server cannot be contacted, no error codes

Things I have tried:

1. RPC registry fix (found this by googling)
2. Changing the SMTP Authentication from Basic to NTLM
3. Fully qualifiying user loginID with @----. ---
4. Disabling the firewall on remote users PC

Never had this problem with Office 2003/XP. There seems to be alot of posts about this problem  on the new but no viable solution. Most users are having the problem with Office 2007 running on XP OS, I'm trying ot connect with Office 2007 running on Vista.

Any ideas?

(in reply to romrunning)
Post #: 3
RE: Using RPC with Vista - 4.Jun.2008 1:51:12 PM   
romrunning

 

Posts: 50
Joined: 13.May2008
Status: offline
It sounds like it can't contact the FQDN of your Exchange svr.  I would check the RPC over HTTPS settings in Outlook - make sure they're set up correctly.  You generally should always use Basic authentication w/Mutual as most firewalls don't open up/handle NTLM.  The server listed there should be your CAS.  Check off both options to alway connect using HTTPS first.  If you're connecting through a VPN, make sure you can either resolve DNS through the VPN or add a HOSTS entry. 

(in reply to cmiller02)
Post #: 4
RE: Using RPC with Vista - 17.Jun.2008 6:24:04 PM   
leungda

 

Posts: 50
Joined: 22.Mar.2008
Status: offline
if you using outlook 2007, it should be easy. The Exchange 2007 come with Autodiscover service. You just input your name / email address / password on outlook 2007 and it will do all the necessary setting for you automatically. try to run a test for the autodiscover service in powershell. It should tell you a lot of thing.

(in reply to romrunning)
Post #: 5

Page:   [1] << Older Topic    Newer Topic >>
All Forums >> [Microsoft Exchange 2007] >> Mobility >> Using RPC with Vista Page: [1]
Jump to:

New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Follow TechGenix on Twitter