• RSS
  • Twitter
  • FaceBook

Exchange Server Forums

Forums | Register | Login | My Profile | Inbox | RSS RSS icon | My Subscription | My Forums | Address Book | Member List | Search | FAQ | Ticket List | Log Out

Why transport rules are applied only once in an environment with 2 hub servers?

Users viewing this topic: none

Logged in as: Guest
  Printable Version
All Forums >> [Microsoft Exchange 2010] >> General >> Why transport rules are applied only once in an environment with 2 hub servers? Page: [1]
Login
Message << Older Topic   Newer Topic >>
Why transport rules are applied only once in an environ... - 18.Oct.2016 9:39:37 AM   
alekseydiachok

 

Posts: 2
Joined: 18.Oct.2016
Status: offline
Environment

1. I have an environment with 2 HUB transport servers: hub1 and hub2. Messages from mail box server go to hub1. If message is internal, then it is routed to to the mail box server, where recipient's mail box is kept. If message contains external recipients, then it is sent to hub2 which is internet-facing.
2. There is transport rule, which stops message and generates NDR to the sender if message subject contains "-Error-Stop-Message" string. As I know transport rules on hub servers are global.
3. On hub2 I have custom transport agent which analyzes message content and appends message subject with the "-Error-Stop-Message" in some cases.

Issue

If message from the mailbox server is sent directly to hub2 server, then everything works fine: transport agent appends subject, transport rule agent applies transport rules, as a result message is stopped and sender receives NDR.

However, if external message is sent to hub1 server, then to hub2, agent processes message, appends subject, but transport rules are not applied - NDR is not generated and message is sent to the Internet. So it seems that transport rules are applied only once - on hub1 in this scenario (subject does not contain "-Error-Stop-Message" string on hub1, because custom transport agent is on hub2). If message with external recipients is sent from hub1 to hub2, rules are not applied on hub2, because they have already been applied on hub1 server.

Question

1. Can someone explain this behavior?
2. Is there a way to fire transport rules on the hub2 server (not only on hub1) if message is sent from mailbox server, then to hub1, and then to hub2?
Post #: 1

Page:   [1] << Older Topic    Newer Topic >>
All Forums >> [Microsoft Exchange 2010] >> General >> Why transport rules are applied only once in an environment with 2 hub servers? Page: [1]
Jump to:

New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Follow TechGenix on Twitter