I cant do forestprep, domain corrupt? (Full Version)

All Forums >> [Microsoft Exchange 2003] >> Installation



Message


Zulan -> I cant do forestprep, domain corrupt? (7.Dec.2004 10:43:00 AM)

I am trying to install a second Exchange server for my organization. This second exchange server is supposed to be a front-end server for OWA. I am running 2 domain controllers on Windows 2000 Server and I am running Exchange 2000. So I installed a new Windows 2000 server and tried to install Exchange 2000 on top of that. But I got an error message trying to assign the action. Something about not being Full Exchange administrator. I am pretty sure the account I was using was full Exchange Admin. But I found a solution to that. Delegate the rights from exchange and the message disappeared. But now something else came up. So I thought, lets just skip this and try with 2003 instead. So I reinstalled the server with Windows 2003 server and then tried to install Exchange 2003. But this time I get something about domain prep. I try to run domainprep but then it complains that I havenĘt done ForestPrep so I try to run that, guess what, a new errormessage:

The component "Microsoft Exchange Forest Preparation" cannot be assigned the action "forestPrep" beacuse:
- Either you do not have permission to update the Active Directory schema or Active Directory service is currently too busy.

So I found this http://support.microsoft.com/kb/q319944 but when I run dcdiag /test:knowsofroleholders /v command I donĘt get the error message they have in their example (com is the Schema Owner, but is deleted.)

I get:

Domain Controller Diagnosis

Performing initial setup:
* Connecting to directory service on server ad1.
* Collecting site info.
* Identifying all servers.
* Identifying all NC cross-refs.
* Found 2 DC(s). Testing 1 of them.
Done gathering initial info.

Doing initial required tests

Testing server: Default-First-Site-Name\AD1
Starting test: Connectivity
* Active Directory LDAP Services Check
* Active Directory RPC Services Check
......................... AD1 passed test Connectivity

Doing primary tests

Testing server: Default-First-Site-Name\AD1
Test omitted by user request: Replications
Test omitted by user request: Topology
Test omitted by user request: CutoffServers
Test omitted by user request: NCSecDesc
Test omitted by user request: NetLogons
Test omitted by user request: Advertising
Starting test: KnowsOfRoleHolders
Role Schema Owner = CN=NTDS Settings,CN=AD1,CN=Servers,CN=Default-First
-Site-Name,CN=Sites,CN=Configuration,DC=appium,DC=com
Role Domain Owner = CN=NTDS Settings,CN=AD1,CN=Servers,CN=Default-First
-Site-Name,CN=Sites,CN=Configuration,DC=appium,DC=com
Role PDC Owner = CN=NTDS Settings,CN=AD1,CN=Servers,CN=Default-First-Si
te-Name,CN=Sites,CN=Configuration,DC=appium,DC=com
Role Rid Owner = CN=NTDS Settings,CN=AD1,CN=Servers,CN=Default-First-Si
te-Name,CN=Sites,CN=Configuration,DC=appium,DC=com
Role Infrastructure Update Owner = CN=NTDS Settings,CN=AD1,CN=Servers,C
N=Default-First-Site-Name,CN=Sites,CN=Configuration,DC=appium,DC=com
......................... AD1 passed test KnowsOfRoleHolders
Test omitted by user request: RidManager
Test omitted by user request: MachineAccount
Test omitted by user request: Services
Test omitted by user request: OutboundSecureChannels
Test omitted by user request: ObjectsReplicated
Test omitted by user request: frssysvol
Test omitted by user request: frsevent
Test omitted by user request: kccevent
Test omitted by user request: systemlog
Test omitted by user request: VerifyReplicas
Test omitted by user request: VerifyReferences
Test omitted by user request: VerifyEnterpriseReferences

Running partition tests on : Schema
Test omitted by user request: CrossRefValidation
Test omitted by user request: CheckSDRefDom

Running partition tests on : Configuration
Test omitted by user request: CrossRefValidation
Test omitted by user request: CheckSDRefDom

Running partition tests on : appium
Test omitted by user request: CrossRefValidation
Test omitted by user request: CheckSDRefDom

Running enterprise tests on : appium.com
Test omitted by user request: Intersite
Test omitted by user request: FsmoCheck

What could be wrong, I am starting to fear the worst, that something is corrupt on my domain controllers.

I am really gratefull that you have taken your time to read this long question.




rytmehans -> RE: I cant do forestprep, domain corrupt? (8.Dec.2004 11:26:00 PM)

Hi,

From which server did you run forestprep?

It should be run on the schema master.




Zulan -> RE: I cant do forestprep, domain corrupt? (9.Dec.2004 8:38:00 AM)

Thanks for your answer, I have howerver solved the problem. I thought that if you where enterprise manager and domain manager that you where set to do whatever, but this wasnt the case. I had to add schema master to that account and then it worked like a charm :-)

To answer your question, I did run forestprep on the newly installed server.




Page: [1]