• RSS
  • Twitter
  • FaceBook

Exchange Server Forums

Forums | Register | Login | My Profile | Inbox | RSS RSS icon | My Subscription | My Forums | Address Book | Member List | Search | FAQ | Ticket List | Log Out

messages pending submission queue

Users viewing this topic: none

Logged in as: Guest
  Printable Version
All Forums >> [Microsoft Exchange 2003] >> Message Routing >> messages pending submission queue Page: [1]
Login
Message << Older Topic   Newer Topic >>
messages pending submission queue - 15.Jan.2004 10:42:00 AM   
stevet

 

Posts: 1
Joined: 15.Jan.2004
From: UK
Status: offline
We have a fairly simple setup. Exchange 2003 in a small native mode AD domain. We have recently upgraded from exchange 200 and now use GFI for antispam.
We have an intermittant problem whereby the messages pending submission queue fills up and the whole of exchange grinds to a halt. The only solution we have found so far is to re-start the machine with SMTP disabled and manually remove the messages from the queue. There's nothing in the event log or logfiles to tell us that there was any problem.

Any ideas would be appreciated! "[Confused]"
Post #: 1
RE: messages pending submission queue - 15.Jan.2004 11:54:00 PM   
Velocat

 

Posts: 576
Joined: 6.Jan.2004
From: Tucson, AZ
Status: offline
Quick thought jumps into my head...could you have a virus outbreak?

(in reply to stevet)
Post #: 2
RE: messages pending submission queue - 21.Jan.2004 5:27:00 PM   
bjcooper

 

Posts: 5
Joined: 20.Jan.2004
From: Grand Prairie, TX
Status: offline
I also have a similiar problem: Exchange 2003 with Surfcontrol email filtering running on a frontend server. SMTP (Exchange) is set to listen on 26, but send on 25. Surfcontrol is set to listen and send on 25. Exchange knows to forward all outbounds (smart host) to itself on port 25.

Outbounds work spiffy... Inbounds get tossed into deferred delivery queues.

It smells like an SMTP routing issue, but I can't put my finger on it.

(in reply to stevet)
Post #: 3
RE: messages pending submission queue - 30.Jan.2004 6:06:00 AM   
Guest
I also have a similar problem!

It's been driving me insane. Not as bad as our friend who has to reboot his server, but mail takes 10 minutes to deliver and seems to get stuck in the 'messages pending submission' queue...any ideas anyone?

(in reply to stevet)
  Post #: 4
RE: messages pending submission queue - 30.Jan.2004 6:20:00 AM   
Guest
Yo Catz!

I think I fixed it, if you are running GFI (like I am) it's EVIL I tell you! EVVVILLL!

Even if you stop the GFI service to see if that stops mail from accuulating in the 'Messages Pending Submission' - it's not a proper indication if GFI is causing the problem! It's EVVILL!

Go into GFI and see if you have any disclaimers on, if you do, disable them - give that a try,

Warwick

(in reply to stevet)
  Post #: 5
RE: messages pending submission queue - 1.Mar.2004 6:55:00 AM   
Guest
I am having the same problem across a couple of sites running 2003 Small Business Server. Exchange periodically hangs and the messages pending submission queue fills. A couple of restarts of the server and it rectifies but this is obviously not the best long term solution. We are running Trend Scanmail on both. Any suggestions would be appreciated.

(in reply to stevet)
  Post #: 6
RE: messages pending submission queue - 15.Dec.2004 3:31:00 PM   
Guest
Hi All,

Running GFI here too... just had this happen... I did not restart the box though [Wink] I did however have to stop SMTP and restart it along with Exchange and the mail started flowing again.

Please post if anyone knows a sure way to debug this. Thanks.

(in reply to stevet)
  Post #: 7
RE: messages pending submission queue - 15.Dec.2004 6:06:00 PM   
Guest
Folks, If you have GFI and your message submission queue is backing up than you have either one problem listed below given your DNS settings are correct.

1) DNS blacklist is taking too long to check messages in your queue as this is public database and time to time it is heavly utilized.

2) You may have corrupted message in your message queue.

Problem number one can be resolved by disabling DNS database check temporarily in your GFI.

Problem number two can be resolved by re-naming queue directory and re-creating new queue directory. Drop few messages at a time from old (renamed directory) to Pick up directory to isolate the corrupted message. If your queue starts to build than you know one of the message you dropped in the last batch is bad.

Hope this helps !

Sandman

(in reply to stevet)
  Post #: 8
RE: messages pending submission queue - 24.Dec.2004 9:49:00 AM   
froffel

 

Posts: 2
Joined: 24.Dec.2004
From: Netherlands
Status: offline
I think it is clear to me that the problem is GFI. We also use GFI in combination with exchange 2003. The only way to disable GFI is uninstalling it.

GTX and marry christmas,

Frank Roffel.

(in reply to stevet)
Post #: 9
RE: messages pending submission queue - 24.Dec.2004 7:49:00 PM   
wtb5

 

Posts: 29
Joined: 5.Mar.2004
From: NY
Status: offline
GFI is the company name, are you refering to MailEssentials?

(in reply to stevet)
Post #: 10
RE: messages pending submission queue - 24.Dec.2004 11:24:00 PM   
wtb5

 

Posts: 29
Joined: 5.Mar.2004
From: NY
Status: offline
FYI: I think I have the problem solved. GFI just posted a new update to MailEssentials (ftp://ftp.gfi.com/mailessentials101.exe). Simply updating the software didn't do it, however, removing, rebooting and installing the update did the trick. Anyway time will tell for sure. BTW all of my settings and even the activation key were left intact so I didn't have to do any reconfiguration.

(in reply to stevet)
Post #: 11
RE: messages pending submission queue - 30.Dec.2004 12:03:00 AM   
wtb5

 

Posts: 29
Joined: 5.Mar.2004
From: NY
Status: offline
Spoke too soon, problem resurfaced within 24 hours. Removing MailEssentials has fixed the problem for several days so I'll be on the phone with them to resolve or get a refund. If anyone is even thinking about using GFI products they may want to pause to see how these apparently numerous incidents are resolved .....

(in reply to stevet)
Post #: 12
RE: messages pending submission queue - 11.Jan.2005 7:36:00 AM   
rocknob

 

Posts: 1
Joined: 11.Jan.2005
From: South Africa
Status: offline
I have about 10 SBS servers which have all had this problem occasionally. The server run Trend's AntiVirus Suite but I have had the same problem on a box without anti-virus (It was a brand new installation) I do exclude all the Exchange and SMTP folder from the antivirus.

As a workaround you can just kill the inetinfo.exe process in Task Manager or reset IIS. I have found that it is difficult to just try stop the SMTP service.

(in reply to stevet)
Post #: 13
RE: messages pending submission queue - 13.Jan.2005 4:47:00 PM   
Doorslam

 

Posts: 91
Joined: 13.Jan.2005
From: Dallas
Status: offline
I had this same problem yesterday. I noticed alot of people think it is GFI, which I don't think is the case with me. We have Mail Essentials on our gateway, not on our Exchange server. I was still unable to send messages within our organization, which tells me it is not a GFI problem since the mail is not being routed that way.

I did see one poster say it could be a corrupted email. When I look at the queue on our server(through system manager), 1 message is not being forwarded. I can see the message in the queue in its respective folder, but am unable to delete it.

Anyone have any ideas how to clear/purge this message out of our system? The message is not important so it does not need to be saved.

(in reply to stevet)
Post #: 14
RE: messages pending submission queue - 13.Jan.2005 4:58:00 PM   
Doorslam

 

Posts: 91
Joined: 13.Jan.2005
From: Dallas
Status: offline
Found it... right click the Queue in System Manager. Chose Find Messages then Find Now. Your message that you want to delete should pop-up. You can right click on it and choose on of the delete options.

(in reply to stevet)
Post #: 15
RE: messages pending submission queue - 25.Jan.2005 9:07:00 PM   
Guest
Had the problem right away on an Exchange server with mailboxes. Moved the GFI MailEssentials to a front end server and it worked fine for 5 days then began backing up the queues again.

The queues clear immediately when I stop the GFI services. And fill up when I start the GFI services. I am also able to restart my SMTP service without rebooting the server if I stop the GFI services first.

Apparently this was a problem with an earlier MailEssentials build. The latest one was supposed to fix it . . . oops.

(in reply to stevet)
  Post #: 16
RE: messages pending submission queue - 25.Jan.2005 9:32:00 PM   
catron37

 

Posts: 136
Joined: 19.Jan.2005
From: Mississauga - Canada
Status: offline
Messages sitting in the presubmission queue are generally speaking not held by Exchange since these queue is for third party event sinks. If you want to disable GFI:
To disable the GFI mail essentials sinks
=================================
1. From Windows Explorer open Program Files\GFI\MailEssentials and double click
stop_snks.cmd.
2. Restart the GFI MailEssentials Attendant service.
3. Restart the IISADMIN service.

To re-enable the GFI SMTP sinks navigate back to Program Files\GFI\MailEssentials
and double click start_snks.cmd

This is a good way to test whether these messages have anything to do with GFI. In some situation I would also look for DSAccess problems in the Application log or running the dcdiag tool.
Hope this helps.

(in reply to stevet)
Post #: 17
RE: messages pending submission queue - 25.Jan.2005 9:37:00 PM   
catron37

 

Posts: 136
Joined: 19.Jan.2005
From: Mississauga - Canada
Status: offline
Another note here:
To get rid of inbound or relayed messages you can just shut down SMTP and rename vsi 1 folder and then start back SMTP service. It will create a brand new structure for vsi 1. For the messages in outbound queues, they can be enumarated or found and deleted manually. In a situation of a corrupted message in the temp tables you will need MFCMAPI to delete these messages found at:
http://support.microsoft.com/default.aspx?scid=kb;en-us;291794

(in reply to stevet)
Post #: 18
RE: messages pending submission queue - 25.Jan.2005 9:40:00 PM   
catron37

 

Posts: 136
Joined: 19.Jan.2005
From: Mississauga - Canada
Status: offline
One more note: make sure that you have the right AV exclusions in place. Do not forget about C:\Windows\System32\Inetsrv folder since this is the one with the inetinfo.exe and metabase.bin. They are used by the IIS(metabase). You can end up with a corrupted metabase - reinstall IIS and Exchange.
Regards...

(in reply to stevet)
Post #: 19
RE: messages pending submission queue - 9.Feb.2005 8:46:00 PM   
hockey2389

 

Posts: 2
Joined: 3.Dec.2004
From: Maryland
Status: offline
I am having the same exact problems as mentioned above and am also running GFI. I have installed the latest version (upgraded, did not remove and reinstall). Was there ever a FIX that was found. I saw a lot of workarounds, IE: restart SMTP/GFI. Thanks!

Kevin

(in reply to stevet)
Post #: 20

Page:   [1] << Older Topic    Newer Topic >>
All Forums >> [Microsoft Exchange 2003] >> Message Routing >> messages pending submission queue Page: [1]
Jump to:

New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Follow TechGenix on Twitter