• RSS
  • Twitter
  • FaceBook

Exchange Server Forums

Forums | Register | Login | My Profile | Inbox | RSS RSS icon | My Subscription | My Forums | Address Book | Member List | Search | FAQ | Ticket List | Log Out

RE: Cannot send mail to certain domains

Users viewing this topic: none

Logged in as: Guest
  Printable Version
All Forums >> [Microsoft Exchange 2003] >> Message Routing >> RE: Cannot send mail to certain domains Page: <<   < prev  2 3 [4] 5 6   next >   >>
Login
Message << Older Topic   Newer Topic >>
RE: Cannot send mail to certain domains - 27.Oct.2004 3:58:00 PM   
engine101

 

Posts: 6
Joined: 27.Oct.2004
From: MD/DC
Status: offline
Oh Man! You guys are life savers! I've been working on this for 6 days. But since i was getting proper nslookups i didn't figure my DNS was screwed. Anyway, adding an external DNS server seems ot have resolved my issues.

Thanks a lot people!

(in reply to snap355)
Post #: 61
RE: Cannot send mail to certain domains - 28.Oct.2004 9:02:00 AM   
Guest
I had the same problem with Windows SBS Server 2003 and a Cisco PIX506.

To resolve the problem, I needed to remove the 'fixup dns 512' line from the pix.

This line limited the size of the DNS packet to 512 bytes, which stopped the DNS server from receiving all of the DNS data. This is for new DNS functionality, and will only effect domains where their DNS servers support the additional functionality.

(in reply to snap355)
  Post #: 62
RE: Cannot send mail to certain domains - 28.Oct.2004 11:12:00 AM   
t029248

 

Posts: 14
Joined: 8.Aug.2003
From: Holanda
Status: offline
Thanks, to this topic i could solve :E2K3 can receive mail but canĂt send outbound mail.

But i don't like the ISP DNS's server in the SMTP since it was not needed before and is not needed in other situations.

(in reply to snap355)
Post #: 63
RE: Cannot send mail to certain domains - 28.Oct.2004 3:31:00 PM   
koggen

 

Posts: 980
Joined: 31.Oct.2001
From: G÷teborg - Sweden
Status: offline
You might want to try the workaround mentioned in this KB article http://support.microsoft.com/default.aspx?scid=kb;en-us;828731. I stumbled across a link to the article on another forum (thanks Lasse Pettersson).

(in reply to snap355)
Post #: 64
RE: Cannot send mail to certain domains - 10.Nov.2004 7:51:00 PM   
icepick

 

Posts: 1
Joined: 10.Nov.2004
From: Denver Colorado
Status: offline
Hi all:

I this is my first posting, but I'm an avid reader of all postings.

I have been pounding my head agenst the keyboard on this for awhile, brand new install of w2003 server and exchange. And I seen this issue.

I am lucky to have a linux machine doing my firewalling, so I turned on a tcpdump to find out what the hell was going on.

Appreatly, when M$ dose a look up on the domain, it pulls the domain a record, disregarding the MX record. and tries to send the mail to the domain a record. This is obvously not right. This would explain why some mail get to it's destation, and some do not. If the IP for the MX record is the same as the domain a record. it will work fine. Even changing the DNS in the virtual SMTP record wont work becuase it still looks at the domain a record, not the mx - didn't these guys test stuff before release?

With hotmail - the mx record is mx1.hotmail.com, but Exchange 2003 sends to lc1.bay0.hotmail.com, wich is the a record for the domain it's self. I'm not sure how to fix this, but THAT IS THE PROBLEM!

Luck to all

IcePick

(in reply to snap355)
Post #: 65
RE: Cannot send mail to certain domains - 11.Nov.2004 4:05:00 AM   
Guest
I am also having this problem with Exchange Server 2003 and Trend Micro (not serverprotect, just the normal officescan client which is installed on the server). I have put the exclusions in place, will see if it makes a difference.
Thanks for the advice! :-)

(in reply to snap355)
  Post #: 66
RE: Cannot send mail to certain domains - 21.Dec.2004 3:21:00 PM   
raw

 

Posts: 27
Joined: 3.Jul.2002
From: Florida
Status: offline
I've had this very same problem since I
migrated from Exchange 5.5 to Exchange 2003. I'm sort of confused as to where the problem really is because Exchange doesn't do my DNS lookups on outbound mail. I'm having the same problem everyone else is having (can't send to hotmail, gmail, or yahoo) and in my network I have a GFI MailEssentials server as my front end server and my Exchange server is my backend server.

Anyway, nothing is sitting in my Exchange queues but they are sitting in my GFI queue which is strange because GFI only uses IIS SMTP and I still have mail waiting in queue.

Any new ideas? I also verified the DNS servers I am supposed to be using with my ISP and they are correct.

As everyone else here stated, on a reboot after a change to the SMTP config, it sends out all of the email but then just gets hosed up again after a short period.

(in reply to snap355)
Post #: 67
RE: Cannot send mail to certain domains - 24.Dec.2004 4:52:00 PM   
BeTaCam

 

Posts: 423
Joined: 24.Feb.2003
From: India
Status: offline
just an idea,

I looked up on all the domains that were posted on the thread.The Mx and A record seem to point to the same IP in majority of the cases.

So when i do a reverse lookup , im not sure whether its the Mx or A responding.

I unchecked the DNSreverse lookup on SMTP/prperties and the gave an iisreset,i have a zero queue now

Sounds illogical, but thats the only reason why remote telnet session would "disconnect" and not
"quit"

[Roll Eyes]

(in reply to snap355)
Post #: 68
RE: Cannot send mail to certain domains - 4.Jan.2005 10:34:00 PM   
Guest
We have had the same prob at three of our client locations. If you have a pix firewall thats your answer you need to turn off dns fixup because it by default only lets 512 byte replies through. It has to do with that and microsoft EDNSO. You can change it through microsoft as well but its must easier to change the pix entry.

(in reply to snap355)
  Post #: 69
RE: Cannot send mail to certain domains - 5.Jan.2005 12:31:00 AM   
Guest
Thank you sooooo much for the SAV 9 Internet Email tip! We had SAV installed on this server way before EX. This little prob had become a huge headache.

(in reply to snap355)
  Post #: 70
RE: Cannot send mail to certain domains - 5.Jan.2005 5:21:00 PM   
webpilot

 

Posts: 67
Joined: 18.Aug.2004
From: Lat: 27.98N, Lon: 82.28W
Status: offline
quote:
Originally posted by Johan Sandqvist:
There's little need for a whitepaper there. Just create a SMTP Connector and tell it to forward email to a relay.

Go to Exchange System Manager->Connectors. Right-click and choose New->SMTP Connector. On the General tab give the connector a descriptive name. Enable "Forward all mail through..." and enter the relay server of your ISP. Click the Add button and add your server's SMTP virtual server instance. Switch to the Address Space tab, add SMTP Address Space, set Email domain to * (which means all domains, i.e. all outbound email is routed to the relay) and click OK. Make sure that "Allow messages to be relayed..." is NOT ENABLED. Doing so basically opens up your server for anonymous relaying, which is bad.

Click OK to save settings. That's all. Outbound email will now flow through your ISP's relay instead, hopefully allowing you to send email without problems.

// Johan

would we then have to make the ISP server our MX 10 record or could we still accept mail directly inbound.

Also with the isp being the mail relay what sor tof fail over can be built in to this? Can a second connector be made to do dns in case the smart host is lost.

(in reply to snap355)
Post #: 71
RE: Cannot send mail to certain domains - 6.Jan.2005 4:54:00 AM   
Guest
after reading all info here, one person had the exact solution. the error is a firewall issue and has nothing to do with exchange. the command fixup protocol dns maximum-length 512 is the problem, a simple no of this command solved the issue

(in reply to snap355)
  Post #: 72
RE: Cannot send mail to certain domains - 6.Jan.2005 11:22:00 PM   
Guest
I had the same problem sending to aol.com and yahoo.com so I followed snap355 instructions and that fix my problem.
Big Thanks to snap355

Following is a copy of snap355 instructions:

Check the microsoft DNS resolution issues.
To work around this issue, turn off the EDNS0 feature in Windows Server 2003. To do this, follow these steps:
Install the Dnscmd.exe program from the Windows Server 2003 Support Tools. To install the Windows Support Tools, right-click Suptools.msi in the Support\Tools folder on the Windows Server 2003 CD-ROM, and then click Install. Follow the steps in the Windows Support Tools Setup Wizard to complete the installation of the Windows Support Tools.
At a command prompt, type the following command, and then press ENTER:
dnscmd /config /enableednsprobes 0

Note Type a 0 (zero) and not the letter "O" after "enableednsprobes" in this command.

The following information appears:Registry property enableednsprobes successfully reset.
Command completed successfully.
After you run this command, Windows Server 2003 DNS no longer advertises its EDNS0 capabilities. As a result, the Windows Server 2003 DNS server will not be sent UDP packets that are larger than 512 bytes.

(in reply to snap355)
  Post #: 73
RE: Cannot send mail to certain domains - 11.Jan.2005 9:50:00 AM   
ycthow

 

Posts: 5
Joined: 11.Jan.2005
From: Malaysia
Status: offline
my exchange mail server have problem. certain email server cant be send. like yahoo.com.

but i can receive mail from yahoo.com.

then have any idea?

(in reply to snap355)
Post #: 74
RE: Cannot send mail to certain domains - 12.Jan.2005 5:37:00 AM   
microsoftee

 

Posts: 22
Joined: 15.Jul.2004
From: Pakistan
Status: offline
I also have the same problem for a week, its receiving outside mails but can't send. It remains in SMTP queue forever.
I've already did lot of things i.e. I run the command dnscmd /config /enableednsprobes 0, I've checked DNS, its working, I telnet outside SMTP, its connecting, I've set the same working ISP's DNS in Exchange System Manager, Configure External DNS option but its still not working, I've checked my in black list, its not there. I'm running Exchange for a year and it was working fine. I don't know how it stops working suddenly last week.

Please help me fix this problem

(in reply to snap355)
Post #: 75
RE: Cannot send mail to certain domains - 13.Jan.2005 4:02:00 PM   
Guest
This response cured the aol and yahoo problem for me as well.
Guys had the same problem and was fixed by adding my external DNS server(s) into the SMTP Virtual Server.

Open your ˘Exchange system manager÷-> ˘Administrative groups÷->÷First Administrative group÷->÷Servers÷-˘Your Server÷->÷Protocols÷->÷SMTP÷->Right Click ˘Default Virtual Server÷->÷Properties÷->÷Delivery÷->Press ÷Advanced÷ Button->Press ˘Configure÷ Button near the ˘Configure external DNS servers÷->

We are running a Cisco Pix 515, Barracudda Spam Firewall, SAV CE 9.0, SAV for SMTP, Exchange 2000 front-end and back-end servers, 2 AD DNS servers.

(in reply to snap355)
  Post #: 76
RE: Cannot send mail to certain domains - 13.Jan.2005 6:30:00 PM   
lemming05

 

Posts: 1
Joined: 13.Jan.2005
From: gta, Ontario, Canada
Status: offline
As per mike b.'s suggestion above (Sept. 29), I created a separate SMTP connector for one particular domain. This domain's 1st, 2nd and 3rd MX records were offline, but 4th, 5th and 6th were available.
Running Exchange Server 2003 SP1. No problems sending to yahoo, aol, gmail, etc. I had previously tried disabling Symantec Antivirus 9.01, changed EHLO to HELO and added to our PIX "no fixup DNS 512" without resolution.

In new SMTP connector option box "Forward all mail though this connector to the following smart host" I entered the 4th server's IP address enclosed in []. Stopped/started the SMTP Virtual Server and Presto! - 2 days of accumulated e-mail was sent.

Thanks to all those who have posted here!
Next to call Micro$oft about this feature.....

(in reply to snap355)
Post #: 77
RE: Cannot send mail to certain domains - 14.Jan.2005 5:06:00 AM   
ycthow

 

Posts: 5
Joined: 11.Jan.2005
From: Malaysia
Status: offline
i already try change external dns but still cant send the mail to yahoo mail. some more also restart the server when i change external dns. if i send to yahoo mail, then later on i'll received error message:-

this error message:---

This is an automatically generated Delivery Status Notification.

THIS IS A WARNING MESSAGE ONLY.

YOU DO NOT NEED TO RESEND YOUR MESSAGE.

Delivery to the following recipients has been delayed.

ycthow@yahoo.com

so have any solution?

(in reply to snap355)
Post #: 78
RE: Cannot send mail to certain domains - 19.Jan.2005 10:58:00 PM   
Guest
Just to give everyone some info on what worked for me. I have been having this issue for the last couple of days, but only with 2 remote mail servers. I tried all the changes listed here and none helped.

I looked into the firewall settings several times before noting that the firewall was answering back as my SMTP server.

It seems the firewall (watchguard firebox) was acting as an SMTP proxy and the hosts we were sending to did not like that. I changed it to a SMTP filter and everything started working.

Hope this helps somebody.

(in reply to snap355)
  Post #: 79
RE: Cannot send mail to certain domains - 22.Jan.2005 4:29:00 AM   
ycthow

 

Posts: 5
Joined: 11.Jan.2005
From: Malaysia
Status: offline
finally, i solve my problem already. cause i check for yahoo support. then yahoo support said our ip address already blocked. so he will open back for us. now, i can send to yahoo mail server....

(in reply to snap355)
Post #: 80

Page:   <<   < prev  2 3 [4] 5 6   next >   >> << Older Topic    Newer Topic >>
All Forums >> [Microsoft Exchange 2003] >> Message Routing >> RE: Cannot send mail to certain domains Page: <<   < prev  2 3 [4] 5 6   next >   >>
Jump to:

New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Follow TechGenix on Twitter