Cannot send mail to certain domains (Full Version)

All Forums >> [Microsoft Exchange 2003] >> Message Routing


snap355 -> Cannot send mail to certain domains (23.Jul.2004 4:09:00 AM)

Hi all,

I cannot send emails to or Our domain has a PTR record, meaning it has a reverse DNS record for the domain. When performing nslookup, it resolves to the proper IP addy. There's only one MX record for this domain.

The system is SBS MS Exchange Svr 2003. It's behind a Pix firewall. I can send mails to other domains, just not these two.

I do not receive any NDRs messages. However, when I go to look at the queue and I cancel one my emails to yahoo, this is what I get This message was rejected due to the current administrative policy by the destination server. Please retry at a later time. If that fails, contact your system administrator.
< #4.3.2>

I check out at least 3 different sites to verify that I'm not blacklisted.

I can telnet to to get a response. I can also telnet to the mail server from another public source and that works as well.

Any ideas?

snap355 -> RE: Cannot send mail to certain domains (23.Jul.2004 10:25:00 PM)

The solution? One stinking abbreviation. D N S and how it's used with MS

[ July 23, 2004, 10:26 PM: Message edited by: snap355 ]

abarrote -> RE: Cannot send mail to certain domains (27.Jul.2004 9:45:00 AM)

hi... have you solved the problem?

I'm having a similar problem with my Exchange Server...
I cannot send email to some domains (, and others included) and they stay in the queue until a timeout NDR is issued. I get these error messages while they're in the queue:
- The semaphore timeout period has expired
- The connection was dropped by the remote host
- Unable to bind to the destination server in DNS
- The connection was dropped due to an SMTP protocol event sink

however, I can nslookup all the domains...

also, sometimes I get this error at system's event viewer:

Event ID: 2013
SMTP could not connect to any DNS server. Either none are configured, or all are down.

Event ID: 2012
SMTP could not connect to the DNS server ''. The protocol used was 'UDP'. It may be down or inaccessible is my DC with DNS Server

any ideas on how to solve this?


[ July 27, 2004, 09:45 AM: Message edited by: abarrote ]

Guest -> RE: Cannot send mail to certain domains (27.Jul.2004 6:54:00 PM)

I had similar problems and ended up renaming my mail server (it had been named with an _ instead of a hyphen).

Once I did this and cleared up the resulting mess everything started working fine.

Guest -> RE: Cannot send mail to certain domains (27.Jul.2004 6:57:00 PM)

... and I changed my DNS to point to an external server.

snap355 -> RE: Cannot send mail to certain domains (28.Jul.2004 2:31:00 AM)

Are you behind any type of firewall? If so, check how the firewall is forwarding MS DNS external requests to it.

Guest -> RE: Cannot send mail to certain domains (28.Jul.2004 7:42:00 AM)

Here is an article on what you can and can not have as names for Exchange servers:;en-us;841091&Product=exch2003

abarrote -> RE: Cannot send mail to certain domains (28.Jul.2004 8:49:00 AM)

the server name is certainly not the problem... it is a simple word...

also, I'm behind a firewall but it worked fine so far. The problem started to happen almost a week ago and I have this server up and running since January without a single problem...

I think the problem might be at the DNS server or at my ISP firewall... They're now checking it...

abarrote -> RE: Cannot send mail to certain domains (29.Jul.2004 2:41:00 PM)


there was no Reverse DNS configured at the MX Record, so I asked them to configure it...
it was yesterday noon... and so far, the problem remains...

does it take too long to replicate the info through the internet?
I'm starting to think this won't solve the problem.. [Frown]

abarrote -> RE: Cannot send mail to certain domains (30.Jul.2004 12:07:00 PM)

hi... it's been almost two days since the reverse DNS was properly configured and some emails still remain forever in the queue...

I really need some help here...
can anybody help me out?

jdawg53 -> RE: Cannot send mail to certain domains (30.Jul.2004 6:51:00 PM)

I'm having the exact same proble so I don't know if I would be of much help. Now that you have added the reverse entry, can you telnet to yahoo (command: telnet 25).

For me, when I reboot the Exchange Server then all of the messages in queue get released and go to the problematic domains (which are different than your -, and others). Are you experiencing this also?

abarrote -> RE: Cannot send mail to certain domains (31.Jul.2004 11:04:00 PM)

that's strange...

I can't telnet yahoo (although mails sent to are not among the ones with problems) on port 25, but instead I CAN telnet and IS among the domains with problems...

can someone explain this? :-\

and, unlike your server, when I reboot the Exchange Server, nothing changes on the queue: the emails stay there... [Frown]

ChrisWhite85 -> RE: Cannot send mail to certain domains (2.Aug.2004 12:25:00 PM)

When i reboot my mail server all my mails leave. I cant send to anyone unless i reboot my mail server.

However, i can telnet my smart hosts and send mail via telnet.

Its exchange+routing that is at fault on my system for sure.


mgtang -> RE: Cannot send mail to certain domains (10.Aug.2004 3:14:00 AM)

I got the same problem [Confused] I've searched lots of documents by using . Found one guy said that he resolve this problem by call the tech support. It is a problem, not our Exchange server?

abarrote -> RE: Cannot send mail to certain domains (10.Aug.2004 6:13:00 PM)

wait a minute.. we all have the same problem?

maybe it's a bug or something... damn!
I thought it was DNS but I can telnet all those domains...

I don't know what to do to solve this...
anybody has any ideas?


snap355 -> RE: Cannot send mail to certain domains (11.Aug.2004 4:47:00 PM)

Check the microsoft DNS resolution issues.
To work around this issue, turn off the EDNS0 feature in Windows Server 2003. To do this, follow these steps:
Install the Dnscmd.exe program from the Windows Server 2003 Support Tools. To install the Windows Support Tools, right-click Suptools.msi in the Support\Tools folder on the Windows Server 2003 CD-ROM, and then click Install. Follow the steps in the Windows Support Tools Setup Wizard to complete the installation of the Windows Support Tools.
At a command prompt, type the following command, and then press ENTER:
dnscmd /config /enableednsprobes 0

Note Type a 0 (zero) and not the letter "O" after "enableednsprobes" in this command.

The following information appears:Registry property enableednsprobes successfully reset.
Command completed successfully.
After you run this command, Windows Server 2003 DNS no longer advertises its EDNS0 capabilities. As a result, the Windows Server 2003 DNS server will not be sent UDP packets that are larger than 512 bytes.

snap355 -> RE: Cannot send mail to certain domains (11.Aug.2004 4:51:00 PM)

Also, make sure you are not blacklisted or on the open relay list. Make sure reverse DNS has a record for your domain name. Check to make sure that you can telnet to the mail server for or Turn off any filters that you may have on the Exchange settings or any SPAM service you may have.

Good luck!

drutzen -> RE: Cannot send mail to certain domains (12.Aug.2004 3:31:00 PM)

hey ppl, i have EXACTLY THE SAME PROB with one of our customers.

i think it started last week or so (some guy there said after a reboot..)

some mails can be send, some just stay in the send queue and don't.. ( for example..)

the domain is not in any blacklist as far as i can see..

We use Win2003 with Exchange 2003 without any smarthost. E-Mails are directly sent using DNS..
The server is also the DC with dns and stuff..

i searched all over the web and couldnt find any solution yet.. but i am "glad" that i aint the only person having problems with that.

later today i will install Exchange SP1 and add the ISP's DNS-Server-Adresses to the servers DNS-forward-list..

but still, i dont know why it worked before and suddenly.. nada .. [Frown]

[ August 12, 2004, 03:43 PM: Message edited by: drutzen ]

mgtang -> RE: Cannot send mail to certain domains (14.Aug.2004 3:19:00 PM)

Hi Guys, I got my problem RESOLVED finally [Smile] . My problem is: cannot send email to or The email (which is being sent to or is also stuck in the ˘Queues÷. My problem is caused by the external DNS server, I always use an old Internet DNS server but it works fine for all the sites except connecting to Hotmail by SMTP. When I change it to a new Internet DNS server, problem resolved. Here is the location of changing the external DNS server: Open your ˘Exchange system manager÷-> ˘Administrative groups÷->÷First Administrative group÷->÷Servers÷-˘Your Server÷->÷Protocols÷->÷SMTP÷->Right Click ˘Default Virtual Server÷->÷Properties÷->÷Delivery÷->Press ÷Advanced÷ Button->Press ˘Configure÷ Button near the ˘Configure external DNS servers÷-> Then remove your old DNS server and add a new one.

I think you should call your ISP and ask them for a GOOD DNS server address. Hope this information will resolve your problem as well. [Cool]

SurenR -> RE: Cannot send mail to certain domains (16.Aug.2004 11:17:00 AM)

I have exactly the same problem as described by you guys. The domain that my Exchange server is having problems with is When a mail addressed to is submitted all other mails get held up in the queue. The mails are sent when the server is restarted.

If I leave the message in the queue long enough I get the ndr with the message saying
This message was rejected due to the current administrative policy by the destination server. Please retry at a later time. If that fails, contact your system administrator.
To resolve this situation -

Enable SMTP logging on your default virtual server.
To turn on Diagnostics Logging on the MSExchangeTransport service, follow these steps:
1. Start Exchange System Manager.
2. Expand Servers, right-click Your_ Server_Name, and then click Properties.
3. Click the Diagnostics Logging tab, and then click MSExchangeTransport under Services.
4. Under Categories, click the category that you want to log.
5. Under Logging Level, click the appropriate logging level for the issue that you are investigating:
o None
o Minimum
o Medium
o Maximum
Note: to see event messages turn up the logging level to medium or high.
Check to see if you receive the following event messages in Events viewer with event logging turned on.

Event ID 7004

This is an SMTP protocol error log for virtual server ID 1, connection #29. The
remote host "", responded to the SMTP command "xexch50" with
"504 Need to authenticate first ". The full command sent was "XEXCH50 2336 3 ".
This will probably cause the connection to fail.

The message is generated when the responding server in the 7004 event does not understand the XEXCH 50 command from your exchange 2003 server, or a firewall blocks the exchange of blobs between the exchange servers.

Note: This is normal if they server indicated in the 7004 is an out_of_ org server
or internet servers (E2k or E2k3). Exchange 5.5 with 5.5.2657.72 or higher IMCs
will respond back to this with a 7004 event " 505 Authentication required" This is
normal when sending to Exchange 55. servers. You can configure this behavior with
the HKLM\ System\CurrentControlSet\Services\SMTPSVC\XEXCH50\SuppressExternal to
1.(DWORD) to control Exchange from attempting to send XEXCH50 outside of the org.

Articles worth checking out is and;en-us;818222
Also make sure your DNS settings have a reverse DNS setting for your domain, and that you are not on any black lists.

Hope this helps guys

Page: [1] 2 3 4 5   next >   >>