• RSS
  • Twitter
  • FaceBook

Exchange Server Forums

Forums | Register | Login | My Profile | Inbox | RSS RSS icon | My Subscription | My Forums | Address Book | Member List | Search | FAQ | Ticket List | Log Out

Error: "504 Need to authenticate first"

Users viewing this topic: none

Logged in as: Guest
  Printable Version
All Forums >> [Microsoft Exchange 2003] >> Message Routing >> Error: "504 Need to authenticate first" Page: [1]
Login
Message << Older Topic   Newer Topic >>
Error: "504 Need to authenticate first" - 26.Oct.2005 12:44:03 PM   
ryan007

 

Posts: 2
Joined: 26.Oct.2005
Status: offline
Hello,

I need some help figuring this error out. Everytime my exchange server sends or recieves email from another Exchange server (external to our network), I get this error:

Event Type:    Error
Event Source:    MSExchangeTransport
Event Category:    SMTP Protocol
Event ID:    7010
Date:        10/26/2005
Time:        11:04:52 AM
User:        N/A
Computer:    NTSERVERTWO
Description:
This is an SMTP protocol log for virtual server ID 1, connection #2267. The client at "209.202.22.6" sent a "xexch50" command, and the SMTP server responded with "504 Need to authenticate first  ". The full command sent was "xexch50 2228 2".  This will probably cause the connection to fail.

For more information, click http://www.microsoft.com/contentredirect.asp.

Which the connection does fail. Now I have gone through the Microsoft Knowledge base and found the following articles:
843106 - which talks about how to troubleshoot the error, and 818222 - which says to add the "SuppressExternal" registry key & to use HELO instead of EHLO. If have done both, restarted the services, and even rebooted the server. There seems to be no other info on this type of error except for these 2 articles.

Is there any other way to fix this? I am hesitent to install Exch2003 SP2 until this is resolved. This is my server's specs:
Win2003 SP1
Exchange 2003 SP1
Intelligent Message Filter
ORFilter Anti Spam for Exchange and SMTP Server (the issue was happening before this).

Does anyone have any other ideas, it would be very much appreciated?

Thanks,

Ryan
Post #: 1
RE: Error: "504 Need to authenticate first" - 28.Oct.2005 10:49:42 AM   
BeTaCam

 

Posts: 420
Joined: 24.Feb.2003
From: India
Status: offline
 
:)

Let's say that server A (which is running any version of Exchange earlier than Exchange 2003 SP1) connects to server B, which is running Exchange 2003 SP1.

Server A sends the XEXCH50 verb to indicate that it's an Exchange server.

This verb tells the receiving server that various Exchange-specific bits of functionality (including 8-bit MIME support and the X-LINK2STATE verb) are  available.
 
Exchange 2003 reject any XEXCH50 requests that occur before authentication.

Because server A hasn't yet authenticated to server B, server B will reject the XEXCH50 verb and log the event you're seeing.

Resolution

Enable the use of SMTP authentication for both servers by opening each SMTP virtual server's Properties dialog box, switching to the Access tab, clicking Authentication, and selecting the Integrated Windows Authentication box.

HTH

/BC


_____________________________

Ad Astra per Aspera..........

(in reply to ryan007)
Post #: 2
RE: Error: "504 Need to authenticate first" - 28.Oct.2005 11:04:17 AM   
ryan007

 

Posts: 2
Joined: 26.Oct.2005
Status: offline
BeTaCam,

Thanks for the suggestion. I do have the authentication turned on, for the Virtual SMTP Connector interface.

Now, to my way of thinking, Exchange servers should only use the exchange protocols for intersite replication and communication. If your exchange server needs to talk to an External Exchange server (one not under your control), it should default to using the basic SMTP commands. Now, I believe what is happening is exactly what you said, there are other exchange servers that are trying to send the exchange commands before they are authenticated.

Now what I am starting to wonder is this just a warning message before the servers 'downgrade' there connection to SMTP (instead of exchange). I don't seem to be losing any email, (but it seems to come in through my secondary server, which is not an Exchange).

Any other ways to for External email to be default SMTP only. I do have the registry key "SuppressExternal" set to 1, but it doesn't seem to make a difference.

Thanks,

Ryan

(in reply to BeTaCam)
Post #: 3
RE: Error: "504 Need to authenticate first" - 15.Nov.2005 10:31:13 PM   
gshiii

 

Posts: 1
Joined: 15.Nov.2005
Status: offline
I had the same issue with POP3 clients having problems authenticating.  I know you didn't mention POP3 clients but hopefully it will give you more insight as to what might be a root cause.  I found this article on the MS site.  http://support.microsoft.com/default.aspx?scid=kb;en-us;324025  Good Luck!!

(in reply to ryan007)
Post #: 4

Page:   [1] << Older Topic    Newer Topic >>
All Forums >> [Microsoft Exchange 2003] >> Message Routing >> Error: "504 Need to authenticate first" Page: [1]
Jump to:

New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Follow TechGenix on Twitter