• RSS
  • Twitter
  • FaceBook

Exchange Server Forums

Forums | Register | Login | My Profile | Inbox | RSS RSS icon | My Subscription | My Forums | Address Book | Member List | Search | FAQ | Ticket List | Log Out

Installing additional exchange server

Users viewing this topic: none

Logged in as: Guest
  Printable Version
All Forums >> [Microsoft Exchange 2003] >> Installation >> Installing additional exchange server Page: [1]
Login
Message << Older Topic   Newer Topic >>
Installing additional exchange server - 25.Jan.2006 5:18:17 PM   
grebnetso

 

Posts: 17
Joined: 29.Dec.2005
Status: offline
When I go to install the messaging and collab services I get this error.

The compenent "Microsoft Exchange Messaging Collaboration Services" cannot be assigned the action "install because:
-You either do not have permissions to complete this operation or Active Directory has not replicated all the necessary permissions for the deleted items container. Please check that you have the necessary permissions to modify exchange components and that replication is complete before running setup.

I've checked my permissions and I've force rep, it seems like a fairly straightforward message so I thought someone might be familiar with it.

Thanks.

_____________________________

Don't Question It.
Post #: 1
RE: Installing additional exchange server - 25.Jan.2006 5:40:20 PM   
pjhutch

 

Posts: 3578
Joined: 21.Jul.2001
From: W Yorks, England
Status: offline
A couple of things to check:

1. Make sure you use an account with at least Domain  or Enterprise Admin and Exchange Administrator rights to install Exchange (see AD Users and Computers and/or Exchange Manager). You will also need local Administrator rights on the server.

2. If you have just run Forest Prep or Domain Prep and have multiple DCs, then the schema changes may not have applied to all DCs yet. Wait for a couple of hours before installing Exchange.

3. Make sure IP, DNS settings are correct and server is joined to an AD Domain. Use NetDiag to test this.

4. Make sure IIS, NNTP and SMTP services are installed first.

(in reply to grebnetso)
Post #: 2
RE: Installing additional exchange server - 26.Jan.2006 5:28:36 PM   
grebnetso

 

Posts: 17
Joined: 29.Dec.2005
Status: offline
All of these donditions have been met.

(in reply to grebnetso)
Post #: 3
RE: Installing additional exchange server - 26.Jan.2006 5:42:21 PM   
pjhutch

 

Posts: 3578
Joined: 21.Jul.2001
From: W Yorks, England
Status: offline
1. Is the time sync'ed to AD? use NET TIME to sync time

2. Which version of Windows are you using?

3. Have you logged into the domain and not using a local account?

4. Run DCDIAG to check that your DC is ok.

5. Try the Reinstall action for Exchange Setup (KB327022)
   Check Permissions (KB279218)

(in reply to grebnetso)
Post #: 4
RE: Installing additional exchange server - 31.Jan.2006 4:12:16 PM   
rajeshbahl

 

Posts: 15
Joined: 31.Jan.2006
Status: offline
Check these things also:


1. run dcdiag and netdiag and make sure that there shld not be any network issues other that security etc..
2. Performf nltest for dc and gc

In case of problem..........post the Application Log and exact error message

Njoy!

(in reply to pjhutch)
Post #: 5
RE: Installing additional exchange server - 31.Jan.2006 5:19:36 PM   
sunligthpal

 

Posts: 139
Joined: 8.Jan.2006
Status: offline
Most of the time above error will come b'coz of permission issue.

Make sure that you've Exchange Full Administrator rights.

if you've these permission make sure that u've rights on Exchange box.

_____________________________

Regards,

Dipak Sharma

(in reply to rajeshbahl)
Post #: 6
RE: Installing additional exchange server - 1.Feb.2006 12:46:12 AM   
grebnetso

 

Posts: 17
Joined: 29.Dec.2005
Status: offline
It was a permissions issue. For some reason I was able to install the server previously but I had to delegate control to accomplish it this time. After the install I'm now unable to start the information store service. I did a netdiag and it's saying under LDAP that it's receiving a SPN error with the domain controllers. Could this be causing any problems?

(in reply to sunligthpal)
Post #: 7
RE: Installing additional exchange server - 1.Feb.2006 10:15:27 AM   
pjhutch

 

Posts: 3578
Joined: 21.Jul.2001
From: W Yorks, England
Status: offline
Its possible. Check everything from TCPIP , DNS, AD membership, group membership and so on.

(in reply to grebnetso)
Post #: 8
RE: Installing additional exchange server - 1.Feb.2006 7:01:02 PM   
de.blackman

 

Posts: 3542
Joined: 4.Apr.2005
From: Toronto, Canada
Status: offline
Whats the error you get in application log when you attempt to start the information store service?

_____________________________

Ibrahim Benna - Microsoft Exchange MVP
Forum Moderator
Navantis
@IbrahimBenna

(in reply to pjhutch)
Post #: 9
RE: Installing additional exchange server - 1.Feb.2006 8:50:07 PM   
grebnetso

 

Posts: 17
Joined: 29.Dec.2005
Status: offline
#1
Source:MSExchangeDSAcess
Description:
Process Mad.exe (pid=1836). All domain Controller Servers in use are not responding.
Lists the DCs

#2
Source:MSExchangeIS
Desciption:
Error 0x8004005 starting the Microsoft Exchange Information Store. Failed to load storage group data.

#3
Source:MSExchangeFBPublish
Description:Error initializing session for virtual machine "machine name". The error number is 0x8004011d. Make sure microsoft exchange information store is running.

I later gave it a reboot and noticed these errors in the log

Source:MSExchangeSA
Description:
DS ACCESS returned an error '0x8004005' on DS notification. Microsoft Exchange System Attendant will reset DS notification later.

Source:MSExchangeSA
Description:
Microsoft Exchange system attendant reported an error '0x8007000e' in it's DS monitoring thread.

All the errors made me think I might have some authentication issues with the DC's so I did a netdiag and everything passed but I did notice two items that I kind of questioned.

LDAPTEST....passed
[warning] Failed to query SPN registration on DC "domain controller name"
[warning] Failed to query SPN registration on DC "domain controller name"

When I go to manually start the IS I'm getting a service specific error 0.

(in reply to grebnetso)
Post #: 10
RE: Installing additional exchange server - 1.Feb.2006 9:22:33 PM   
de.blackman

 

Posts: 3542
Joined: 4.Apr.2005
From: Toronto, Canada
Status: offline
If you go into active directory sites and services (from RUN type DSSITE.MSC), how many sites do you see? Do you have any sites that have no servers in them? Do you have subnets created and are they associated to the correct sites?

_____________________________

Ibrahim Benna - Microsoft Exchange MVP
Forum Moderator
Navantis
@IbrahimBenna

(in reply to grebnetso)
Post #: 11
RE: Installing additional exchange server - 1.Feb.2006 10:44:53 PM   
grebnetso

 

Posts: 17
Joined: 29.Dec.2005
Status: offline
Just the one site with both DC's in it. No subnets are set up.

(in reply to de.blackman)
Post #: 12
RE: Installing additional exchange server - 1.Feb.2006 10:55:46 PM   
de.blackman

 

Posts: 3542
Joined: 4.Apr.2005
From: Toronto, Canada
Status: offline
Do you have your servers on different subnets?

_____________________________

Ibrahim Benna - Microsoft Exchange MVP
Forum Moderator
Navantis
@IbrahimBenna

(in reply to grebnetso)
Post #: 13
RE: Installing additional exchange server - 1.Feb.2006 10:59:52 PM   
de.blackman

 

Posts: 3542
Joined: 4.Apr.2005
From: Toronto, Canada
Status: offline
also the site you have, is it DEFAULT-FIRST-SITE-NAME? Do you have support tools installed on the exchange server? if so, go to a command prompt and type NLTEST /DSGETSITE, is it the correct site name?

_____________________________

Ibrahim Benna - Microsoft Exchange MVP
Forum Moderator
Navantis
@IbrahimBenna

(in reply to de.blackman)
Post #: 14
RE: Installing additional exchange server - 2.Feb.2006 5:16:18 PM   
abhi_ak

 

Posts: 24
Joined: 6.Jan.2006
Status: offline
could you tell the event id's that you are getting in you application logs

also have you installed the hotfix http://support.microsoft.com/kb/8908060
After you install this Hotfix remember you need to reboot your servers

you need to install this hotfix on all your exchange servers and Domain controllers that are running on Windows Server 2003 Sp1

also download ExBPA from the following link and run it on your exchange server it would tell you much more about the problems with your exchange server.
http://www.microsoft.com/downloads/details.aspx?FamilyID=dbab201f-4bee-4943-ac22-e2ddbd258df3&DisplayLang=en

Check the report genrated by this tool and check for Critical Errors and also look at the Full Detailed view.

Do let us know what does it tell you.

_____________________________

Regards,
Abhijeet Kulkarni,
MCSE, CCNA , CCNP,

(in reply to de.blackman)
Post #: 15
RE: Installing additional exchange server - 6.Feb.2006 5:45:42 PM   
grebnetso

 

Posts: 17
Joined: 29.Dec.2005
Status: offline
Right now I haven't installed SP1 for server 2003. I've had so many problems with this process that I don't put that much into it before I try to install exchange, because I don't feel like doing it all over again. I know that the other exchange server didnt have sp1 and it was working fine. We later installed it, but before that everything worked just fine. I've seen things online saying that forest prep or domain prep may need to be run again with service specific error 0. Is this something that would even be viable with another exchange server on the network, and if this server is running fine what would prevent my second one from working...

(in reply to grebnetso)
Post #: 16
RE: Installing additional exchange server - 8.Feb.2006 11:38:11 PM   
grebnetso

 

Posts: 17
Joined: 29.Dec.2005
Status: offline
I went ahead and installed 2003 SP1 and Exchange SP2 and I was able to start the information store. Does it check or rerun forest/domain prep during this installation? The reason I ask is the primary Exchange server doesnt have sp2 installed but it function with no problems. I also remember reading that the errors I was getting might be linked to domain prep needing to be run again.

(in reply to grebnetso)
Post #: 17

Page:   [1] << Older Topic    Newer Topic >>
All Forums >> [Microsoft Exchange 2003] >> Installation >> Installing additional exchange server Page: [1]
Jump to:

New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Follow TechGenix on Twitter