• RSS
  • Twitter
  • FaceBook

Exchange Server Forums

Forums | Register | Login | My Profile | Inbox | RSS RSS icon | My Subscription | My Forums | Address Book | Member List | Search | FAQ | Ticket List | Log Out

Information Store Fails To Start

Users viewing this topic: none

Logged in as: Guest
  Printable Version
All Forums >> [Microsoft Exchange 2003] >> Information Stores >> Information Store Fails To Start Page: [1]
Login
Message << Older Topic   Newer Topic >>
Information Store Fails To Start - 6.Mar.2006 4:44:52 AM   
nashtri

 

Posts: 3
Joined: 6.Mar.2006
Status: offline
Good afternoon / evening.

I have an Exchange 2003 server that has been running for a few months.
The network is simple, just this one box (Windows 2003 Server (SP1_
with Exchange 2003 (SP2)).

I am also running the Intelligent Message Filter and have been keeping
it updated.



Today there was a new IMF update along with a few other Windows
updates.  I told Windows Update to get the updates and install them.
After it was completed, the machine was rebooted.



Now I have a problem.  When the box is rebooted, all services start
correctly except the Exchange Information Store (all Exchange services
along with all Server services).



The error messages are such:
Under the System Event Property
Source: Service Control Manager
Type: Error
Event ID: 7024
Description:
The Microsoft Exchange Information Store service terminated with
service-specific error 0 (0x0).



In the application Event Property:
Source: MSExchangeIS
Event ID: 5000
Desctiption:
Unable to initialize the Microsoft Exchange Information Store service.
Failed to retrieve msExchUce value from DS (DSVAL in error) - Error
0x80004005.



Most of the messages that I have been able to find are talking about
upgrades from Exch SP1 to SP2, but that is not the issue here.  I have
also tried to revert back to plain SP2 (reinstall), but it will not let
me since the IMF has been updated multiple times.

Any help would be greatly appreciated.


I have continued down the path of looking and have run eseutil to recover (no errors),
and I have been trying to run the isinteg command but an receiving a message the indicates
Error: unable to get databases status from server.


I am at a complete loss for how to proceed since I cannot find anything like this anywhere.


Thank You
Nashtri
Post #: 1
RE: Information Store Fails To Start - 6.Mar.2006 9:49:38 AM   
damiant

 

Posts: 11
Joined: 22.Feb.2006
Status: offline
Have you checked this...
http://support.microsoft.com/?kbid=285116

Damian

(in reply to nashtri)
Post #: 2
RE: Information Store Fails To Start - 6.Mar.2006 1:24:46 PM   
nashtri

 

Posts: 3
Joined: 6.Mar.2006
Status: offline
Thanks for replying

Yes, I had ready that but went back this morning and checked the key again.  The system user (which is the accout that Exchange is starting under) is in the security tab with full control.

I have also changed the login user to domain\administrator (which also has full control in the permissions) and the store will still not start.

Nashtri

(in reply to nashtri)
Post #: 3
RE: Information Store Fails To Start - 6.Mar.2006 11:43:47 PM   
nashtri

 

Posts: 3
Joined: 6.Mar.2006
Status: offline
Just wanted to update everybody on the resolution to this problem.  The article that damiant pointed out: http://support.microsoft.com/?kbid=285116 was the key to the resolution. 

I tried going in to the key to make sure the permissions were set to run with the system user and that did not work.  What did work was completely removing the key with adsiedit.msc.  This key is spoken about when you install SP2 on a machine that has not had SP1 on it with IMF.  I added the key earlier and everything worked.  This key is outlined in:
http://www.petri.co.il/installing_imf_with_exchange_2003_sp2.htm.

What does not make sense to me now is that I had to remove the key to bring everything back up.  Now IMF is not available in the tabs, but the store is now mounting and running.

I will add the key back in once I have let mail settle down and see if the problem reproduces or if it was a fluke with the last IMF update.

Nashtri

(in reply to nashtri)
Post #: 4
RE: Information Store Fails To Start - 2.Oct.2006 12:01:38 AM   
sharrisonUK

 

Posts: 1
Joined: 1.Oct.2006
Status: offline
Huge thanks to nashtri for this lifesaver!  Can confirm that adding the following entry:

Cn=UCE Content Filter,cn=Message Delivery,cn=Global Settings,cn=<ORG NAME>cn=Microsoft
Exchange,cn=Services,cn=configuration,dc=<root domain>

stops MSExchangeIS in it's tracks.  I added this entry before upgrading from Exch2003sp1 to Exch2003sp2 on Win2003sp1 in a single server environment as outlined in http://www.petri.co.il/installing_imf_with_exchange_2003_sp2.htm"

(First tried adding the local service account to the above entry with full permissions to no avail; Deleting it allowed MSExchangeIS to restart without errors)

quote:

ORIGINAL: nashtri

Just wanted to update everybody on the resolution to this problem.  The article that damiant pointed out: http://support.microsoft.com/?kbid=285116 was the key to the resolution. 

I tried going in to the key to make sure the permissions were set to run with the system user and that did not work.  What did work was completely removing the key with adsiedit.msc.  This key is spoken about when you install SP2 on a machine that has not had SP1 on it with IMF.  I added the key earlier and everything worked.  This key is outlined in:
http://www.petri.co.il/installing_imf_with_exchange_2003_sp2.htm.

What does not make sense to me now is that I had to remove the key to bring everything back up.  Now IMF is not available in the tabs, but the store is now mounting and running.

I will add the key back in once I have let mail settle down and see if the problem reproduces or if it was a fluke with the last IMF update.

Nashtri


_____________________________

Phew! That was close!

(in reply to nashtri)
Post #: 5

Page:   [1] << Older Topic    Newer Topic >>
All Forums >> [Microsoft Exchange 2003] >> Information Stores >> Information Store Fails To Start Page: [1]
Jump to:

New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Follow TechGenix on Twitter