• RSS
  • Twitter
  • FaceBook

Exchange Server Forums

Forums | Register | Login | My Profile | Inbox | RSS RSS icon | My Subscription | My Forums | Address Book | Member List | Search | FAQ | Ticket List | Log Out

Messages stuck in Queue until Exchange & Domain controller restart

Users viewing this topic: none

Logged in as: Guest
  Printable Version
All Forums >> [Microsoft Exchange 2003] >> Message Routing >> Messages stuck in Queue until Exchange & Domain controller restart Page: [1]
Login
Message << Older Topic   Newer Topic >>
Messages stuck in Queue until Exchange & Domain control... - 13.Mar.2006 5:36:58 PM   
wklug

 

Posts: 8
Joined: 13.Mar.2006
Status: offline
The Problem

I have an Exchange 2003 server set up on a Windows 2003 platform. Randomly (every few weeks or so) messages to multiple domains will remain in the queue with the error "Unable to bind to destination server in DNS". Users who send emails receive messages stating that the message delivery has been delayed, and eventually that their message is undeliverable.

The temporary fix
If I restart my domain controller (also provides services: Active Directory, Symantec antivirus client management, Symantec Mail Security for SMTP, DNS, WINS, & DHCP) and then restart the Exchange server, everything works without problems until this problem eventually recurs.

The Question
Why? Has anyone experienced this or might know how to fix this problem or at least what service it's related to?
Post #: 1
RE: Messages stuck in Queue until Exchange & Domain con... - 13.Mar.2006 8:15:09 PM   
Xguru

 

Posts: 287
Joined: 14.Feb.2006
Status: offline
Check the version of TCPIP.SYS file on the exchange box and the DC (DNS).

If the version is lower than the one mentioned in KB898060 update the files to the hotfix version and reboot both the DC and exchange.

XGURU

(in reply to wklug)
Post #: 2
RE: Messages stuck in Queue until Exchange & Domain con... - 13.Mar.2006 8:48:27 PM   
wklug

 

Posts: 8
Joined: 13.Mar.2006
Status: offline
XGURU,

The version of TCPIP.SYS is lower than the one specified in the KB article you gave me, so I'll install that hotfix.

One question though: My DC is Windows 2000 and the KB article you gave me only has hotfixes for '03. Do I need to get a hotfix for the DC too, or only for the Exchange server since it's the client that loses connection?

Thanks,
Wayne

(in reply to Xguru)
Post #: 3
RE: Messages stuck in Queue until Exchange & Domain con... - 13.Mar.2006 9:43:27 PM   
Xguru

 

Posts: 287
Joined: 14.Feb.2006
Status: offline
If the DC is windows 2000 refer to article 893066 for the updated version of TCPIP.SYS.

XGURU

(in reply to wklug)
Post #: 4
RE: Messages stuck in Queue until Exchange & Domain con... - 13.Mar.2006 10:30:07 PM   
wklug

 

Posts: 8
Joined: 13.Mar.2006
Status: offline
Thanks. I've installed both hotfixes on the 2 servers and will restart them tonight. I hope that will solve these problems.

Wayne

(in reply to Xguru)
Post #: 5
RE: Messages stuck in Queue until Exchange & Domain con... - 13.Mar.2006 10:38:50 PM   
Xguru

 

Posts: 287
Joined: 14.Feb.2006
Status: offline
I bet this is gonna resolve the issue.....

If it does.... u owe me a Beer....

XGURU

(in reply to wklug)
Post #: 6
RE: Messages stuck in Queue until Exchange & Domain con... - 17.Mar.2006 5:08:22 PM   
wklug

 

Posts: 8
Joined: 13.Mar.2006
Status: offline
Unfortunately, this same problem occurred today. Do you have any other suggestions?

(in reply to Xguru)
Post #: 7
RE: Messages stuck in Queue until Exchange & Domain con... - 18.Mar.2006 12:53:38 AM   
AdminFix

 

Posts: 62
Joined: 13.Mar.2006
Status: offline
Since the mail does not leave your exchange server, the issue is with the Exchange Server and not with the IIS/AD. PLease check for the following on the Exchange Server.

1) Does Symantec Antivirus have any auto-protect options installed on the server. If so, please uninstall anything other than File System Auto-Protect (Especially Internet Email Auto-Protect).

2) Do you have the exclusions configured properly in the Symantec File Level. You need to have all the EXCHSRVR folders on all the drives, Windows/System32/InetSRV & System32/Temp excluded from scanning. If you do it now, don't forget to restart the Antivirus Service First and then SMTP and Routing Engine Service.

3) Is Symantec mail Security running anything below 4.6.3. If not, You need to update this to the latest version.

4) Is there any external DNS server or Smarthost configured on the Default Virtual SMTP Server under Delivery-> Advanced. Please remove them from there as it creates a lot of confusion in mail delivery.

5) If you have any DNS server specified by your ISP, add them to your DNS Server Forwarder list. Also Configure your Exchange Server to use only Local DNS Servers and have no External / ISP DNS servers specified in the IP Configuration.

Lets us know if the above steps help.

(in reply to wklug)
Post #: 8

Page:   [1] << Older Topic    Newer Topic >>
All Forums >> [Microsoft Exchange 2003] >> Message Routing >> Messages stuck in Queue until Exchange & Domain controller restart Page: [1]
Jump to:

New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Follow TechGenix on Twitter