RPC over HTTPS is not working (Full Version)

All Forums >> [Microsoft Exchange 2003] >> Installation



Message


bronco88 -> RPC over HTTPS is not working (16.Mar.2006 1:52:49 AM)

I followed these two articles and installed RPC over HTTPS
http://www.petri.co.il/configure_rpc_over_https_on_a_single_server.htm
http://support.microsoft.com/default.aspx?scid=kb;en-us;833401

the SSL Certificate is trusted and valid. I have checked over and over carefully all registry changes and everything is correctly done.

the problem is i CAN NOT connect to it or i keep getting the prompt to log in and unable to log in at all.

please help




de.blackman -> RE: RPC over HTTPS is not working (16.Mar.2006 2:02:25 AM)

How many Exchange servers do you have? What service packs are they on? What about the OS and service pack?
How many global catalog servers running win2k3 do you have?




bronco88 -> RE: RPC over HTTPS is not working (16.Mar.2006 2:09:10 AM)

Single Exchange Server 2003 with latest Service Pack 2

Windows 2003 Enterprise with SP1 




de.blackman -> RE: RPC over HTTPS is not working (16.Mar.2006 4:11:14 PM)

1. I assume this exchange server is also the global catalog or do you have other DCs running windows 2k3?

2. In IIS, check and make sure that the RPCPRoxy virtual directory has only BASIC authentication and is set to require SSL. Also in the virtual directory Tab of the RPCProxy, make sure the path set is c:\windows\system32\rpcproxy.

3. Still in IIS, under Web Service Extensions, open properties of RPC Proxy Server Extension and confirm the it is allowed and the path is set to c:\windows\system32\rpcproxy\rpcproxy.dll

4. Next, check the properties of default web site and ISAPI filters tab. Anything listed?

5. Also check the properties of WEB SITES folder and ISAPI filters tab. Anything listed?

6. In Exchange System Manager, check the properties of the server object, under RPC-HTTP tab, make sure it is set to "Not part of a managed..."

7. Can you telnet to the Exchange server from a command prompt on ports 6001, 6002, 6004? If this is not a GC, can you telnet to the GC on port 6004?

8. Check in the registry of the Exchange server at HKLM\Software\Microsoft\Rpc\Rpcproxy and verify the validports key has entries that are similar to (remember all these names MUST be the INTERNAL network name of the servers):

If your exchange is a global catalog: EXCH-NETBIOSNAME:6001-6004;EXCH-INTERNAL-FQDN:6001-6004
If your exchange is NOT a global catalog: EXCH-NETBIOSNAME:6001-6002;EXCH-INTERNAL-FQDN:6001-6002;GC-NetbiosName:6004;GC-INTERNAL-FQDN:6004

9. When you say your certificate is trusted, what do u mean? What is the issued to name on it? Was it obtained from a public vendor? From an External client, when you browse to https://YourExchCommonName/rpc, do you get the security warning for certificate? Do you see the 401.3 error page as expected?




bronco88 -> RE: RPC over HTTPS is not working (16.Mar.2006 8:05:36 PM)

1. it is global catalog there is no other DCs running it.

2. everything is correct here

3. RPC proxy server extension is allowed and pointed to the right path

4. there are two filters here: fpeyedll.dll and owalogon

5. nothing is listed

6. it was checked at "RPC-HTTP back-end server". i have changed it to "Not part of a ..." 

7. can telnet to all ports

8. registry is like this: EXCH-NETBIOSNAME:6001-6002;EXCH-INTERNAL-FQDN:6001-6002;GC-NetbiosName:6004;GC-INTERNAL-FQDN:6004

9. yes and yes




de.blackman -> RE: RPC over HTTPS is not working (16.Mar.2006 8:20:42 PM)

After changing the settings to  "Not part of a ..."  from system manager, did you restart system attendant? I think this needs to be done. Also restart IIS Admin Service. Check the ValidPorts registry key and {humor me} see what happens when you change it to:

EXCH-NETBIOSNAME:6001-6004;EXCH-INTERNAL-FQDN:6001-6004;GC-NetbiosName:6004;GC-INTERNAL-FQDN:6004






bronco88 -> RE: RPC over HTTPS is not working (16.Mar.2006 8:24:49 PM)

i did stop and restart all. i did change the port registry to your advise. it still did not work. i don't know if restarting the machine would help but i have not done so. why changed to "Not part of a ...", is this not against their suggestion?




de.blackman -> RE: RPC over HTTPS is not working (16.Mar.2006 11:27:41 PM)

well what i have noticed in a number of environments is that when you have only one exchange server and you select it to be a back-end in a managed topology, it keeps changing the ValidPorts key and it will always keep looking for a front-end server, which is not the case in your environment.

In the profile settings, make sure the INTERNAL name of the server is entered as the mailbox server name.




bronco88 -> RE: RPC over HTTPS is not working (16.Mar.2006 11:40:38 PM)

not working still.

what profile settings are you talking about and where do i check that?




de.blackman -> RE: RPC over HTTPS is not working (17.Mar.2006 12:19:40 AM)

Lets create a new profile:

1.From control panel go to Mail and add a new profile.
2.select Microsoft Exchange Server --> next
3.here type the INTERNAL FQDN of the exchange server where the mailbox exists on and then the user's alias. Do not check name and click More Settings.
4. Click on Connection tab and Exchange Proxy Settings.
5. Under connection Settings, type the EXTERNAL FQDN (COMMON name on your SSL certificate) of your server.
6. Select both checkboxes saying "on fast networks..." and "on slow networks...". Do not select "mutually authenticate..."
7. Change the proxy authentication to Basic, apply and OK out of the entire profile settings and try it.




bronco88 -> RE: RPC over HTTPS is not working (17.Mar.2006 12:32:23 AM)

oh, you mean this client outlook profile setting.
i have tried all sort of combinations including what you suggested here. it is not working. i just can't simply log in at all.





de.blackman -> RE: RPC over HTTPS is not working (17.Mar.2006 12:54:49 AM)

when you try to logon does it even ask for credentials?




bronco88 -> RE: RPC over HTTPS is not working (17.Mar.2006 1:01:33 AM)

not sure if this is what you mean credentials. when you open outlook > select profile > enter login name and password. this is where i can't log in.

i have read this article also and tried it also but got the same problem
http://support.microsoft.com/default.aspx?kbid=820281





telco966 -> RE: RPC over HTTPS is not working (5.Sep.2007 4:36:59 AM)

Hi All

I just want to let you know that I am having exactly the same issue here.

I have setup RPC\HTTP and although my Exchange topoligy is slightly different as I have a load balanced front end and a single back end but I configured it as such and it installed the reg key valid ports as though I have a single server seneario. If I change the reg key ports it reverts back on both front ends. So I made all the changes that have been suggested in this post and still it changes back to deleting the contents of that reg key so it is blank and it does this for both FE's.

I have followed all the guides and it has never worked for me I believe due to this issue. I have tried eveything that I could think off and most things that people have suggested. I have totally uninstalled it and re-installed it. I have fallen short "JUST" of uninstalling exchange and re-installing it but that would be going way to far, lol.

So If anyone has any ideas why this is happening would be great as I have now got it set to unmanaged and it is still changing the reg key.

Just to let you know I have set all the servers to unmanaged FE and BE.


Regards




trachoi81 -> RE: RPC over HTTPS is not working (5.Sep.2007 5:58:12 AM)

I have a same problem and this is my server's information:
4. there is only one filter here: owalogon
5. there are two filters here: ASP.NET_1.1.4322.2379 (low priority) and RpcProxy
6. it was checked at "RPC-HTTP back-end server
7. can not telnet to all ports




Page: [1]