SMTP send connectors (Full Version)

All Forums >> [Microsoft Exchange 2007] >> Message Routing



Message


DaveVVV -> SMTP send connectors (31.Jul.2006 7:27:45 AM)

Can someone help me troubleshoot a problem with sending mail?  I can receive mail but when I send it, it sits in the outbox.  I have created the smtp send connector on several occasions and I have tested smtp by telneting to it and it works fine.  Can someone point me in a different direction, I am thinking there is something wrong with my authentication to the send connector or maybe I created the send connector incorrectly. 
Iím Lost
Thanks
David




Henrik Walther -> RE: SMTP send connectors (31.Jul.2006 4:45:57 PM)

If you're using Exchange Server 2007 Beta 2, a Send Connector is created by default. Did you delete that one? And if yes how did you configure the new Send Connector? Is port 25 perhaps blocked in the firewall? Do you need to use a SMTP gateway/smarthost in order to send mail over port 25?

Almost forgot to ask what ype of Send Connector you created? You need to create a "Custom" connector, if you're sending directly to the Internet.




DaveVVV -> RE: SMTP send connectors (31.Jul.2006 9:36:33 PM)

Thanks Henrik for the reply, I am using Exchange Server 2007 Beta 2 and yes port 25 has an access-list setup through the firewall and I am able to connect directly to the server via that port from the internet.  I donít recall seeing a default smtp send connector "under the Organization" but I have been troubleshooting this for a while so I may have deleted the default one that was created during the install, regardless, I have created a new custom one.   I have created it in the Exchange Management Console and in the Management shell (under Organization Configuration-Hub transport-send connector) neither of which seemed to work for me.  I also have an smtp receive connector setup (under server configuration).  I still have no problems receiving e-mail from the internet, just can't send (sits in the out box).   I am wondering if there is some kind of authentication problem.  Where does smtp get itís authentication requirements in exchange 2007?  How does SMTP know who is allowed to send mail through the send connector?

Thanks a million [;)]

David




truder -> RE: SMTP send connectors (1.Aug.2006 12:32:05 AM)

i seem to have the same problem. Do you get the following error: '550 5.7.1 Client does not have permissions to send as this sender' ? Also, have you tried using Outlook web access? From there outbound mails are being sent in my case.




DaveVVV -> RE: SMTP send connectors (1.Aug.2006 12:41:34 AM)

Yup I do the "550 5.7.1 Client does not have permissions to send as this sender" error.  As far as OWA I can receive but not send.  I'm at a loss, I definitely think it is something with the authentication, can't find it though. 




scorpiuss -> RE: SMTP send connectors (1.Aug.2006 1:05:06 AM)

I didn't have any default Send Connectors for internet email when I first installed the Exchange beta. Maybe there is one in the Edge Transport server role, but I don't think the Hub Transport server has one.

How 'bout posting the details of your Send Connector up here for troubleshooting? Run 'Get-SendConnector | Format-List | Out-File <file path>' in the Management Shell, and copy the output into your post as code.




DaveVVV -> RE: SMTP send connectors (1.Aug.2006 7:47:06 AM)

Here is the send connector info let me know what you think:


Schema                           : Microsoft.Exchange.Data.Directory.SystemConfiguration.SmtpSendConnect
                                  orSchema
DNSRoutingEnabled                : True
SmartHosts                       : {}
Port                             : 25
LinkedReceiveConnector           :
ConnectionTimeOut                : 00:10:00
ForceHELO                        : False
IgnoreSTARTTLS                   : False
Fqdn                             : ex01.vigworld.com
RequireTLS                       : False
Enabled                          : True
ExternallySecuredAsPartnerDomain :
ProtocolLoggingLevel             : Basic
AuthMechanism                    : None
AuthenticationCredential         :
UseExternalDNSServersEnabled     : True
SourceIPAddress                  : 0.0.0.0
SmartHostsString                 :
AddressSpaces                    : {smtp:vigworld.com;1, smtp:vig.biz;1}
MaxMessageSize                   : 10MB
DeliveryMechanism                : 2
ConnectedDomains                 : {}
IsScopedConnector                : False
IsSmtpConnector                  : True
Comment                          :
SourceRoutingGroup               : Exchange Routing Group (DWBGZMFD01QNBJR)
SourceTransportServers           : {HQ-EX01}
HomeMTA                          : Microsoft MTA
HomeMtaServerId                  : HQ-EX01
MinAdminVersion                  : -2147453113
AdminDisplayName                 :
ObjectCategoryName               : msExchRoutingSMTPConnector
ExchangeVersion                  : 0.1 (8.0.535.0)
CurrentObjectVersion             : 0.1 (8.0.535.0)
Name                             : SMTPSend1
DistinguishedName                : CN=SMTPSend1,CN=Connections,CN=Exchange Routing Group (DWBGZMFD01QNBJ
                                  R),CN=Routing Groups,CN=Exchange Administrative Group (FYDIBOHF23SPDL
                                  T),CN=Administrative Groups,CN=VIG Exchange,CN=Microsoft Exchange,CN=
                                  Services,CN=Configuration,DC=vig,DC=biz
Identity                         : SMTPSend1
Guid                             : f8bdaf39-98fe-4b3b-b572-095440d1405e
ObjectCategory                   : vig.biz/Configuration/Schema/ms-Exch-Routing-SMTP-Connector
ObjectClass                      : {top, msExchConnector, mailGateway, msExchRoutingSMTPConnector}
OriginalId                       : SMTPSend1
WhenChanged                      : 7/30/2006 10:15:10 PM
WhenCreated                      : 7/30/2006 9:32:03 PM
ObjectState                      : Unchanged
OriginatingServer                : hq-ex01.vig.biz
IsReadOnly                       : False
Id                               : SMTPSend1
IsValid                          : True




Henrik Walther -> RE: SMTP send connectors (1.Aug.2006 8:37:22 AM)

In order to be secure by default the Hub Transport server isn't allowed to submit messages to other servers than an Edge Server in the perimeter network. If you want to change this behaviour you need to issue below CMDlet:

get-receiveConnector server1\default* | set-receieveConnector -permissionGroups "AnonymousUsers,ExchangeServers,ExchangeLegacyServers,AnonymousUsers"

It might be worth restarting the Exchange Transport service afterwards.




DaveVVV -> RE: SMTP send connectors (1.Aug.2006 10:21:41 AM)

I deleted the receive connector that I had and recreated the default so I could run the command as is and the command took but it did not change my problem with sending email.  Now in OWA the mail goes straight to the send folder but if you look in the queue under "unreachable domains" all the messages I have sent are sitting in there with the error of "A matching connector cannot be found to route the exterinal recipient."   Hummm maybe that will give someone an idea.

David




RWH_1 -> RE: SMTP send connectors (1.Aug.2006 10:55:44 AM)

Maybe this will work for you, it did for me.

Under Organization Configuration->Hub Transport->Sender Connectors->(Your connector)->Address Space

specify domain to be *

I did not have to set up an edge server or execute any powershell commands related to edge servers.

I hope this helps.




DaveVVV -> RE: SMTP send connectors (1.Aug.2006 11:23:52 AM)

WOW, who would have thought [:)], that fixed my problem with OWA sending mail (everything cleared the queue, thanks!!!).  I still however have a problem connecting to the server via outlook express and sending mail through smtp.  I can connect to pop and receive mail through outlook express but I can not send mail, I get the following error:

"Protocol: SMTP, Server Response: '550 5.7.1 Client does not have permissions to send as this sender', Port: 25, Secure(SSL): No, Server Error: 550, Error Number: 0x800CCC78"

Any ideas.

Thanks again
David




scorpiuss -> RE: SMTP send connectors (1.Aug.2006 1:14:16 PM)

Beat me to it, RWH_1! The clue is in the configuration info you printed out:

AddressSpaces                    : {smtp:vigworld.com;1, smtp:vig.biz;1}

If you run the 'Get-SendConnector' command again, you'll find it now says

AddressSpaces     : {smtp:*,1}

This setting mimics the "Address Space" tab on an SMTP Connector in Ex2k3. It determines what email is actually passed through the connector. Only email whose recipients are in the Address Space are actually routed through.

Your second problem is a problem with authenticated SMTP relay. I've seen other people with a similar problem on the MS forums, and will try to look into it today.

BTW, an excellent source of information is the protocol logs at C:\Program Files\Microsoft\Exchange Server\TransportRoles\Logs\ProtocolLog. Refresh yourself on SMTP syntax at Wikipedia if you need to, then scroll through these in Wordpad (or Notepad if it keeps the lines straight) for some nifty info. It helped me nail down an authentication problem with my smart host.




Henrik Walther -> RE: SMTP send connectors (1.Aug.2006 1:45:47 PM)

Clients like IMAP and POP3 uses the Client <servername> Receive Connector. In order to allow clients to submit messages via this connector, you need to issue below command:

get-receieveconnector Client <servername> | add-adpermission -user AU -extendedrights ms-Exch-SMTP-Accept-Authoritative-Domain-Sender
 




aivanoff -> RE: SMTP send connectors (1.Aug.2006 11:32:57 PM)

How do I configure smtp connector for open relay and no authentication?




DaveVVV -> RE: SMTP send connectors (4.Aug.2006 12:47:07 AM)

Thanks everyone for your help, however I still cannot send mail via smtp through outlook express:  Here is the error I am getting:
The message could not be sent because the server rejected the sender's e-mail address. The sender's e-mail address was 'dv@vigworld.com'. Subject 'test', Account: 'ex01.vigworld.com', Server: 'ex01.vigworld.com', Protocol: SMTP, Server Response: '550 5.7.1 Client does not have permissions to send as this sender', Port: 25, Secure(SSL): No, Server Error: 550, Error Number: 0x800CCC78

Question: where does Exchange 2007 get valid senders, as you know I already have the send connector setup with an * and I did run the following command on the receive connector :"get-receieveconnector Client <servername> | add-adpermission -user AU -extendedrights ms-Exch-SMTP-Accept-Authoritative-Domain-Sender" and it took.


BTW OWA will send and receive fine.

David







naughtyboy119 -> RE: SMTP send connectors (5.Jul.2007 12:10:20 PM)

quote:

Clients like IMAP and POP3 uses the Client <servername> Receive Connector. In order to allow clients to submit messages via this connector, you need to issue below command:

get-receieveconnector Client <servername> | add-adpermission -user AU -extendedrights ms-Exch-SMTP-Accept-Authoritative-Domain-Sender


Henrik, can you make it clearer. I have problem with the client using POP3 sending email. Our internal client cant' send email out bound when they set there outlook express with pop3. I point the incoming and outgoing server to my Exchange server IP address.
Thank you very much.




naughtyboy119 -> RE: SMTP send connectors (5.Jul.2007 12:28:12 PM)

Thank you Henrik, i got the cmdlet




dcstar -> RE: SMTP send connectors (6.Mar.2011 7:42:36 PM)

I had the '550 5.7.1 Client does not have permissions to send as this sender' error with POP3 accounts set up so people could "Send As" in Outlook using e-mail addresses from other places. This worked fine until the SBS 2003 to 2008 migration.

I had to do the following to allow sending from domains not in my SBS server:

get-receiveconnector Client | add-adpermission -user AU -extendedrights ms-Exch-SMTP-Accept-Any-Sender

Now Outlook works fine after they log into the Client Receive connector using their appropriate credentials.




Page: [1]