The remote server did not respond to a connection attempt error (Full Version)

All Forums >> [Microsoft Exchange 2003] >> Message Routing



Message


milano -> The remote server did not respond to a connection attempt error (1.Aug.2006 8:21:39 PM)

Alright Guys,

Just back from a recovering an Exchange fully from backup, and now I have a big problem with outbound email

The Exchange server responsible for sending outbound mail has queues of Internet mail that keeps retrying. My error message is 'The remote server did not respond to a connection attempt'

I have been running a counter log on this machine for SMTP counter Outbound Connections Refused and there are many over the last couple of hours. The queued mail is for a variety of domains

I can receive Internet mail, and my MX records are stored with a hosting provider.

I have reinstalled SMTP as I have just restored this box, but this does not solve the problem.

My SMTP is configured to use my ISPs external DNS servers, which I can ping. I run no Antivirus or Spam Blockers

Where do I begin to find out why I cannot reach out with email? About being on a block List? Some Telnet procedures? What am I to telnet? ISP DNS ?

Oh dear!! [:(]




milano -> RE: The remote server did not respond to a connection attempt error (2.Aug.2006 8:38:40 PM)

Guys,

this box is now a newly installed Exchange Server. Newly sent emails again are queued. Firewall allows port 25. Not on any Block Lists that I could see. DNS resolution is fine. Latest Service Pack and Hotfixes.

Apparently a possible CNAME record error in my MX records on hosted DNS, but haven't changed any entries here since configuring in the first place, and outbound mail used to work fine.

After checking in dnsstuff.com, a reverse lookup on my public IP does not resolve to my domainname, instead to ipaddress.static.dsl.dsfeew.com??
 
All other checks appear ok

Any clues ?




Lancy -> RE: The remote server did not respond to a connection attempt error (2.Aug.2006 11:06:34 PM)

does it retries for all domains or just one or two.
stop the smtp service and move the old messages from the queue folder and try to send a test message to internet. see if that delivers?

try to reply to internet message and see if that delivers.

check if your domain is blacklisted?

check the schedule for mail delivery. is it set to deliver always or any other time?





milano -> RE: The remote server did not respond to a connection attempt error (3.Aug.2006 7:09:55 PM)

Lancy, thanks for the advice

In dnsstuff.com, I am said to be listed on 2 of the many block lists when I do a spam lookup against my public IP.

I am listed as 'myisp'.com misc.spam

One of the RBLs seems pretty obscure, and has not to be used against its name. The other block list I have asked to be taken off but it takes time to propogate.

Is this the reason I get continual retries of outbound emails? Being on 2 block lists out of over a hundred? I am currently sending to 4 different and diverse domains. Any replies to Internet mail received see these get queued up as well.

SMTP services stopped/started - actually the box has been reinstalled as well, as well as SMTP separately

I have reset router and firewall settings, still mail gets queued.

Where next?

All the best

Dan (London)




Lancy -> RE: The remote server did not respond to a connection attempt error (3.Aug.2006 10:35:59 PM)

Can the exchange server query the dns server.
have u run nslookup for those domains and see if you can resolve from the exchange server.




Lancy -> RE: The remote server did not respond to a connection attempt error (3.Aug.2006 10:37:13 PM)

if you are blacklisted you should recieve a ndr. i cant remember this.




milano -> RE: The remote server did not respond to a connection attempt error (4.Aug.2006 9:46:54 AM)

Thanks Lancy, nslookup for the domains I am sending to works ok, and for other domains as well.

I do get postmaster notifications for the messages that are being queued, that they are being delayed and there is no need to resend them




Lancy -> RE: The remote server did not respond to a connection attempt error (4.Aug.2006 2:15:28 PM)

on your smtp connector  have you set forward messages using dns or you have specified to a ip address or host name. if so does that name accept your smtp connections. i mean ISP.

are you replaying the old messages again or again?
you need to stop smtp service and move old messages from the queue folder if they are corrupt.

queues on smtp connector can be due to  either dns issues or some corrupt email /large email stopping other messages and relay isssues.




milano -> RE: The remote server did not respond to a connection attempt error (5.Aug.2006 9:05:02 PM)

Thanks again Lancy

Shortly after performing nslookup, I have managed to send an email to one of the domains I was trying. Does nslookup refresh/reset settings, or is it just a test for connectivity and name resolution?

I have set the external dns servers in the properties of my default SMTP server, and I only have their IP addresses

I can't see how to move messages from the queue. I monitor this in Queues under my Exchange Server in ESM

So, I have managed to get mail out to a certain domain, but other mail sent to other domains has not arrived yet, but is not being queued so is on the way I guess




Lancy -> RE: The remote server did not respond to a connection attempt error (5.Aug.2006 11:48:41 PM)

nslookup does not refresh/reset settings, in DNS.
Nslookup is to check few records and to check if if you can  resolve dns correctly.
ipconfig /flushdns and ipconfig /registerdns does flush and registers the dns on the local server.

to move messages- stop the smtp service.

locate the folder drive letter\Program Files\Exchsrvr\Mailroot\vsi 1\Queue and remove the messages and copy it to another location.

start the smtp service and try sending test email to internet.check if that delivers (confirm delivery reciept in client)




milano -> RE: The remote server did not respond to a connection attempt error (6.Aug.2006 12:33:50 PM)

Lancy, lots of help from you so thanks

My mail issue seems to be resolved, it just eventually started to work after nslookup.

Maybe being asked to come off that block list did it?

Have learnt a lot

Cheers

Dan




liamthebest -> RE: The remote server did not respond to a connection attempt error (28.Aug.2006 3:37:50 PM)

i have the same problem
can reply the iiseu to resolve the problem ?

thanks !!!!




Bodestone -> RE: The remote server did not respond to a connection attempt error (23.Mar.2008 4:44:19 PM)

I had this problem while trialing and training on Exchange on a home virtual server setup. I had already checked most of the above before finding this post but all to no avail.

The issue turned out to be my ISP blocking port 25 so don't forget to try telnetting to a few known mail servers on port 25 to ensure this is not the cause could save a lot of time and really i should have thought of it sooner so hopefully this will help nudge others having a blonde moment or just getting started in the whole area.




Page: [1]