Error 0X8004010F (Full Version)

All Forums >> [Microsoft Exchange 2007] >> Migration



Message


aivanoff -> Error 0X8004010F (5.Aug.2006 6:19:45 PM)

I have a mixed environment: 2003 SP2 and 2007 Beta 2. During send/receive Outlook reports the following error:

11:14:26 Microsoft Exchange offline address book
11:14:26                                 Not downloading Offline address book files.  A server (URL) could not be located.
11:14:26                0X8004010F

What could be the problem?




Henrik Walther -> RE: Error 0X8004010F (5.Aug.2006 8:24:45 PM)

See:
http://forums.msexchange.org/Outlook_2003_reports_error_on_send%2freceive/m_1800412454/tm.htm




aivanoff -> RE: Error 0X8004010F (5.Aug.2006 11:54:16 PM)

This post discusses different problem: 'The operation failed. An object could not be found'. I had this problem before an fixed it by rebuilding offline address books and fixing replication settings. Now I have "A server (URL) could not be located."




Henrik Walther -> RE: Error 0X8004010F (6.Aug.2006 12:53:25 PM)

Ah I see, I just noticed it was the same error code...




cybermcm -> RE: Error 0X8004010F (23.Nov.2006 3:44:20 AM)

Hi aivanoff,

did you solve your problem because I've the same error here?

greetings,
Markus




cizzeler -> RE: Error 0X8004010F (2.Feb.2007 3:30:26 AM)

I have the same problem too..

16:15:45 Microsoft Exchange offline address book
16:15:45                                 Not downloading Offline address book files.  A server (URL) could not be located.
16:15:45                0X8004010F

Outlook 2003 client ok
but Outlook 2007 all have this error..




geeksneak -> RE: Error 0X8004010F (19.Feb.2007 6:32:05 PM)

Hi,

After going through the issue and doing some basic research. Let me summaize as  why you could be having this issue.
On my research, this issue may occur when the Public Folder Store in the
replication list of  /o=SIRIM Berhad/cn=addrlists/cn=oabs/cn=Default Offline
Address List is not mounted or there is no correct Public Folder store in the
replication list. --> This is a major posibility

Please try these to get it resolved.

1. Check the replication list of the OAB, found that the Public Folder Store is
missing in the replication list of OAB Version 3a
2. Add the Public Folder Replication list, rebuidl the Offline Address Book
3. Wait a while and start Outlook to send/receive, and then the error disappears

Regards,
[:D]




caw1970 -> RE: Error 0X8004010F (1.Mar.2007 8:28:09 PM)

Here's what worked for me:
Assuming all the following are true, the problem is likely a public DNS issue:
 
- You have configured the OAB for web distribution correctly.
- The client computers having this issue are located across a security device or outside your corporate network (The Internet, etc.) where your internal DNS records are not replicated.
- These clients are using the Outlook Anywhere feature in OL2007. 
 
Apparently, the OAB download activity is handled by the Autodiscover feature in OL2007.  When downloading the OAB, Outlook tries to connect to a web services Url found on the Client Access Server that resides in an IIS virtual directory called "autodiscover", and access a file called "autodiscover.xml".  If the OAB is not configured correctly for web distribution, this file will likely not exist, and your day will be ruined.  On the other hand, if the file exists, then you should be able to test client connectivity to the web service by doing the following:
 
1.  From the client machine, open a web browser.
2.  Navigate to http://<mail-server>.<your-email-domain-name>.<ext>/autodiscover/autodiscover.xml
3.  Enter your credentials when prompted.
 
You will get a 600 error.  This is ok.  It means you are connecting to the autodiscover service, and that you don't have an issue with access to the web service from the client.
 
By default, Outlook will look for and try to connect to the following preset Autodiscover web service Urls in this order when looking for the "autodiscover.xml" file:
 
https://<your-email-domain-name>.<ext>
https://autodiscover.<your-email-domain-name>.<ext>
http://<your-email-domain-name>.<ext>
http://autodiscover.<your-email-domain-name>.<ext>
 
In a nutshell, if you don't have a public DNS "A" record for "autodiscover.<your-email-domain-name>.<ext>", then your OAB downloads will fail miserably, and you will get "0x8004010F" synch errors in Outlook.  Since public DNS records take 24 to 48 hours to replicate and become effective, you will likely need a workaround during that time.  The easiest interim fix is to modify the client computer's hosts file to include an entry for the autodiscover host name, binding it to the ip address of the CAS or mail server.  For example:
 
65.223.187.51         autodiscover.your-email-domain.com
 
This is just an educated guess, but it is likely that the reason internal clients (domain member computers) that are configured to use Outlook Anywhere (like laptops) don't have this issue is because of the integrated nature of DNS and Active Directory.  Even though you probably don't have an "A" record for the "autodiscover" host internally, Outlook still seems to connect to the web service just fine.  I would be interested to know if my thoughts on this are accurate, but I have already spent enough time on this issue...
Good luck!




AKBTim -> RE: Error 0X8004010F (2.Mar.2007 5:25:32 PM)

We've been having this error and have tried all the various suggestions in the forum posts with no success. 

    Not downloading Offline address book files.  A server (URL) could not be located.

We did discover that unchecking the Use proxy server checkbox in IE (v7) allowed the OAB synch to work correctly without any synch issue.  Not the ideal solution, though....




t0ta11ed -> RE: Error 0X8004010F (6.Mar.2007 10:43:33 AM)

I'm having the same issue, luckily it doesn't stop any users from working but it is annoying. I've tried rebuilding the OAB as well. When I attempt to go to the autodiscover URL caw1970 mentioned, I'm unable to login which results in an access denied message. This is likely why it doesn't work in my enviroment. Not sure what could be causing the problem. 




atedja -> RE: Error 0X8004010F (8.May2008 2:08:47 AM)

Hi,

I tried your suggestion by adding A Record in my DNS "autodiscover" to point to my CAS Exchange Server IP Address, and also I've successfully ping it.

but then everytime my client hit Send and Receive Button the dialog box appears to Accept the current certificate issue ?

am I supposed to install my certificate properly before I do this steps ?

because at the moment, my Certificate is SLEF signed by my mail server for my mail server itself.




charliegadget -> RE: Error 0X8004010F (10.May2008 5:07:14 AM)

caw1970

This was exactly my problem and temporarily editing my hosts file proved that is was the issue. will be adding an A record for autodiscover when I get to the office on monday!

Many thanks

Charlie




charliegadget -> RE: Error 0X8004010F (10.May2008 5:09:26 AM)

atedja,

Yes, you will need a SAN cert installed with the correct SANs before that box will go away!

Charlie




ahmedza76 -> RE: Error 0X8004010F (4.Aug.2009 9:06:34 AM)

I agree , you will need a correct SAN certificate and also you need to configure your autodiscover service to use correct SCPs URLs .

Regards
Ahmed Saber
www.ms-phantom.com




Page: [1]