• RSS
  • Twitter
  • FaceBook

Exchange Server Forums

Forums | Register | Login | My Profile | Inbox | RSS RSS icon | My Subscription | My Forums | Address Book | Member List | Search | FAQ | Ticket List | Log Out

Exchange 2007 can't send to Exchange 2003

Users viewing this topic: none

Logged in as: Guest
  Printable Version
All Forums >> [Microsoft Exchange 2007] >> Message Routing >> Exchange 2007 can't send to Exchange 2003 Page: [1] 2   next >   >>
Login
Message << Older Topic   Newer Topic >>
Exchange 2007 can't send to Exchange 2003 - 3.Jan.2007 7:52:48 AM   
marcrp

 

Posts: 9
Joined: 3.Jan.2007
Status: offline
I've just deployed Exchange 2007 on a new 64bit server with CAS, Hub Transport and Mailbox roles.

I created a new mailbox on the 2007 server.

This new mailbox can send externally. Users on 2003 can send to 2007 mailbox. However the 2007 mailbox can't send to 2003 users. The mail gets stuck in the "Unreachable Domain" queue with LastError of "there is currently no route to the mailbox database".

Single forest with Single domain. All servers in same domain.

Any help would be appreciated.

Post #: 1
RE: Exchange 2007 can't send to Exchange 2003 - 3.Jan.2007 12:36:23 PM   
John Weber

 

Posts: 1236
Joined: 20.Apr.2005
From: Portland, Oregon
Status: offline
2007 requires a routing group connector to talk to 2003.
Verify that, or create it.  It should have been created when you installed and told it that there was a 2003 server existing.
Maybe you made a change to the routing group connector?  If so, nuke it.  Create a new one using the help file - you can copy and paste the help file command line example, change elements to match your environment, and execute it.  Works well.

(in reply to marcrp)
Post #: 2
RE: Exchange 2007 can't send to Exchange 2003 - 3.Jan.2007 3:39:42 PM   
marcrp

 

Posts: 9
Joined: 3.Jan.2007
Status: offline
Thanks John, I will give it a try and let you know.

Regards,

Marc

(in reply to marcrp)
Post #: 3
RE: Exchange 2007 can't send to Exchange 2003 - 3.Jan.2007 4:58:04 PM   
marcrp

 

Posts: 9
Joined: 3.Jan.2007
Status: offline
I deleted and recreated the routing group connector with the correct information and it still fails to reach the exchange 2003 server. The Unreachable queue still has "there is currently no route to the mailbox database".

Any ideas?

Thanks,

Marc

(in reply to marcrp)
Post #: 4
RE: Exchange 2007 can't send to Exchange 2003 - 4.Jan.2007 1:41:22 PM   
rishishah

 

Posts: 784
Joined: 14.Nov.2006
From: Surrey, UK
Status: offline
I have the same issue... I have deleted and recreated the routng group but this does still not work.

Any more ideas or troubleshooting tips?

(in reply to marcrp)
Post #: 5
RE: Exchange 2007 can't send to Exchange 2003 - 4.Jan.2007 1:50:24 PM   
marcrp

 

Posts: 9
Joined: 3.Jan.2007
Status: offline
Hi rishishah,
 
I'm glad I'm not the only one with this problem!
 
I have just finished reinstalling Exchange 2007 after wiping everything on the 2007 server and starting again.
 
I'm very confused.

(in reply to marcrp)
Post #: 6
RE: Exchange 2007 can't send to Exchange 2003 - 4.Jan.2007 2:34:00 PM   
Henrik Walther

 

Posts: 6928
Joined: 21.Nov.2002
From: Copenhagen, Denmark
Status: offline
Are you guys using the RTM version of E2K7?


_____________________________

HTH
Henrik Walther
Lead Moderator/author
MSExchange.org

Follow me on Twitter!

(in reply to marcrp)
Post #: 7
RE: Exchange 2007 can't send to Exchange 2003 - 4.Jan.2007 4:56:31 PM   
marcrp

 

Posts: 9
Joined: 3.Jan.2007
Status: offline
Hi,

Yes I'm using the final release downloaded on Microsoft Select - Exchange 2007 Enterprise.

Regards,

Marc

(in reply to Henrik Walther)
Post #: 8
RE: Exchange 2007 can't send to Exchange 2003 - 4.Jan.2007 5:04:40 PM   
marcrp

 

Posts: 9
Joined: 3.Jan.2007
Status: offline
Also while I remember here are the event logs that are generated:

Event Type: Warning
Event Source: MSExchangeTransport
Event Category: Routing
Event ID: 5009
Date:  04/01/2007
Time:  17:46:38
User:  N/A
Computer: LONDON
Description:
Microsoft Exchange cannot find the route to mailbox database CN=Public Folder Store (EXCHANGE2003),CN=First Storage Group,CN=InformationStore,CN=EXCHANGE2003,CN=Servers,CN=DBC,CN=Administrative Groups,CN=Dartford BC,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=dartford,DC=gov,DC=uk for public folder hierarchy CN=Public Folders,CN=Folder Hierarchies,CN=DBC,CN=Administrative Groups,CN=Dartford BC,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=dartford,DC=gov,DC=uk in routing tables with timestamp 04/01/2007 17:46:38.
For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

and

Event Type: Warning
Event Source: MSExchangeIS Public Store
Event Category: Replication General
Event ID: 3113
Date:  04/01/2007
Time:  16:55:26
User:  N/A
Computer: LONDON
Description:
There was a problem retrieving the list of public MDBs associated with the TLH with GUID "FAB1B815-829A-4259-8624-AABF034F44AC". The entry "/DC=uk/DC=gov/DC=dartford/CN=Configuration/CN=Services/CN=Microsoft Exchange/CN=Dartford BC/CN=Administrative Groups/CN=DBC/CN=Servers/CN=EXCHANGE2003/CN=InformationStore/CN=First Storage Group/CN=Public Folder Store (EXCHANGE2003)" was not found in the directory. The item may have been deleted.
This problem may resolve itself after directory replication and regular directory maintenence completes.
For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

This might be because "Disallow public folder referalls" is enabled?

I'm currently trying to find what object is GUID: FAB1B815-829A-4259-8624-AABF034F44AC

Any tips on translating GUIDs to objects?

Regards,

Marc

< Message edited by marcrp -- 4.Jan.2007 5:06:11 PM >

(in reply to marcrp)
Post #: 9
RE: Exchange 2007 can't send to Exchange 2003 - 12.Feb.2007 11:55:40 AM   
swiesman

 

Posts: 26
Joined: 20.Jun.2003
From: USA
Status: offline
I'm having a very similar problem.  My EX2007 can't send messages to my Ex2003 box.  I can send externally from my 07 box.  I want to recreate the routing group, but wanted to double check the best way of doing so.  I can delete the routing group with the 2003 management, then do I just run setup /prepareAD to recreate the routing group?  I don't see any warning or errors in the event logs related to this. 
I also checked the send connector.  I have tried using the 03 box as the smarthost, as well as using the DNS records (changed setting, waited a few hours, tried to send, change to other setting).

Any help is appreciated.

Thanks
Scott Wiesman

< Message edited by swiesman -- 12.Feb.2007 1:15:35 PM >

(in reply to marcrp)
Post #: 10
RE: Exchange 2007 can't send to Exchange 2003 - 13.Feb.2007 3:18:21 AM   
Henrik Walther

 

Posts: 6928
Joined: 21.Nov.2002
From: Copenhagen, Denmark
Status: offline
It's important you use the New-RoutingGroupConnector cmdlet to establish mail flow between the legacy and E2K7 routing groups.

Also see:
http://technet.microsoft.com/en-us/library/6297510c-7022-4702-83e6-a213a93d46e1.aspx


_____________________________

HTH
Henrik Walther
Lead Moderator/author
MSExchange.org

Follow me on Twitter!

(in reply to swiesman)
Post #: 11
RE: Exchange 2007 can't send to Exchange 2003 - 14.Feb.2007 11:14:15 AM   
swiesman

 

Posts: 26
Joined: 20.Jun.2003
From: USA
Status: offline
Thanks.  I'm looking forward to your new book.  When is it coming out, February or March?

Scott Wiesman

(in reply to Henrik Walther)
Post #: 12
RE: Exchange 2007 can't send to Exchange 2003 - 15.Feb.2007 2:41:36 PM   
Henrik Walther

 

Posts: 6928
Joined: 21.Nov.2002
From: Copenhagen, Denmark
Status: offline
You're welcome...

Although Amazon says March 15, it will hopefully be ultimo Feb.


_____________________________

HTH
Henrik Walther
Lead Moderator/author
MSExchange.org

Follow me on Twitter!

(in reply to swiesman)
Post #: 13
RE: Exchange 2007 can't send to Exchange 2003 - 26.Feb.2007 6:41:46 PM   
swiesman

 

Posts: 26
Joined: 20.Jun.2003
From: USA
Status: offline
Henrik

Is there anything else to check?  Are there any updates after SP2 for 2003?  I have tried deleting/recreating the routing group connectors (one each way) a few times, and I keep getting the same result.  Exchange 2003 has no problem sending to 2007, but doesn't work the other way around.  I did learn a bit about cmdlets and powershell while trying to fix this, though.  I also found out that the install of 2007 reset my 2003 send/receive limits.  Do you think anything else might have changed?  Also, am I the only one still having this problem after recreating the routing group connector?

I preordered your book from Bookpool, they're more optimistic about the Feb release:)

Thanks again
Scott Wiesman

(in reply to Henrik Walther)
Post #: 14
RE: Exchange 2007 can't send to Exchange 2003 - 2.Mar.2007 3:30:06 PM   
WVR

 

Posts: 43
Joined: 4.May2006
Status: offline
Hello,

I have exactly the same problem: I cannot send from E2003 to E2007 but I can send from E2007 to E2003.

Get-routinggroupconnector gives me the following information:

Name                      SourceRoutingGroup         TargetRoutingGroup
----                      ------------------         ------------------
WJVNTFS05-WJVNTFS04       Exchange Routing Group ... First Routing Group
WJVNTFS05-WJVNTFS04       First Routing Group        Exchange Routing Group ..

WJVNTFS04 is the E2003 server
WJVNTFS05 is the E2007 server

In the Exchange System Manager if I look at First Administrative Group -> Servers -> WJVNTFS04 -> Queues -> WJVNTFS05-WJVNTFS04 (Routing group connector) I see the following error message:

quote:

The remote SMTP service rejected AUTH negotiation.


Edit on 3-Mar-2007: In the Exchange System Manager; under Administrative Groups -> Exchange Administrative Group -> Servers -> WJVNTFS05 -> Queues I see under both Default SMTP server and MTA Exchange the following error message:

quote:


Exchange System Manager failed to retrieve queues for the SMTP Virtual Server (error code = 0x800706D9).  Check the event log and verify that the required services are running.


And yes, theyre running. Also I have added SMTP to the IIS.

Any ideas how to get this solved?

With kind regards,
WVR

< Message edited by WVR -- 3.Mar.2007 10:17:04 AM >

(in reply to swiesman)
Post #: 15
RE: Exchange 2007 can't send to Exchange 2003 - 7.Mar.2007 4:17:04 AM   
Henrik Walther

 

Posts: 6928
Joined: 21.Nov.2002
From: Copenhagen, Denmark
Status: offline
Do you perhaps have a smart host configured on the property page of your SMTP virtual server?

Also you mention that you have added SMTP to IIS? Hopefully not on the E2K7 server right?


_____________________________

HTH
Henrik Walther
Lead Moderator/author
MSExchange.org

Follow me on Twitter!

(in reply to WVR)
Post #: 16
RE: Exchange 2007 can't send to Exchange 2003 - 7.Mar.2007 5:00:55 AM   
WVR

 

Posts: 43
Joined: 4.May2006
Status: offline
Henrik,

Many thanks for your reply.

In E2003 I have one SMTP connector: one that sends all the mail to my ISP. And that might me the problem, I guess.

Question: do I have to make a new connector on the E2007 server which forwards all the mail to the E2007 server? And the outbound mail to the ISP?

SMTP on IIS. What I did: I installed the SMTP via Add / Romove programs / Windows Components / etc. etc on the E2007 server. Please let me know if this should be removed.

With very kind regards,
WVR

< Message edited by WVR -- 7.Mar.2007 5:02:56 AM >

(in reply to Henrik Walther)
Post #: 17
RE: Exchange 2007 can't send to Exchange 2003 - 7.Mar.2007 7:18:42 AM   
Henrik Walther

 

Posts: 6928
Joined: 21.Nov.2002
From: Copenhagen, Denmark
Status: offline
Never ever install the Windows SMTP component on an Exchange 2007 Server. Actually you'll be warned if you try to install Exchange 2007 on a server with this component installed. You see Exchange 2007 has it's own SMTP Transport protocol, unlike previous versions of Exchange.

The SMTP connector should not be an issue since legacy Exchange servers and Exchange 2007 uses the Routing Group Connector for mail flow.

How did you create the Routing Group Connector?


_____________________________

HTH
Henrik Walther
Lead Moderator/author
MSExchange.org

Follow me on Twitter!

(in reply to WVR)
Post #: 18
RE: Exchange 2007 can't send to Exchange 2003 - 7.Mar.2007 7:55:32 AM   
WVR

 

Posts: 43
Joined: 4.May2006
Status: offline
Henrik,

Again, many thanks for your reply.

I will remove the SMTP stuff from my E2007 later today.

The connector has been created with the following code:
New-RoutingGroupConnector -Name "WJVNTFS05-WJVNTFS04" -SourceTransportServers "wjvntfs05.domain.local" -TargetTransportServers "wjvntfs04.domain.local" -Cost 100 -Bidirectional $true


WJVNTFS05 -> E2007 server
WJVNTFS04 -> E2003 server

With kind regards,
WVR

(in reply to Henrik Walther)
Post #: 19
RE: Exchange 2007 can't send to Exchange 2003 - 7.Mar.2007 2:44:28 PM   
WVR

 

Posts: 43
Joined: 4.May2006
Status: offline
Hoi Henrik,

An update.

I have removed the SMTP Service from my E2007 server. And I found that I can send from E2007 to E2003 but not the other way around.

In the Exchange Server Manager I found status reports regarding the routing group connector. I removed them all. And recreated them. And still no luck.

If I look at the status now I see the following:

Name                       Admin Group                    Status
WJVNTFS05-WJVNTFS04        First Administrative Group     Available
WJVNTFS05-WJVNTFS04        Exchange Administrative Group  Available
Internet SMTP connector    First Administrative Group     Available
WJVNTFS05                  Exchange Administrative Group  Unreachable
WJVNTFS08                  Exchange Administrative Group  Unreachable
WJVNTFS04                  First Administrative Group     Available
WJVNTFS01                  First Administrative Group     Available


WJVNTFS01 -> E2003 Front end (not in service anymore)
WJVNTFS08 -> E2007 CAS without mailboxes

Hope this helps to help me troubleshooting the problem. Your help is highly appreciated.

With kind regards,
wvr

< Message edited by WVR -- 7.Mar.2007 3:24:50 PM >

(in reply to Henrik Walther)
Post #: 20

Page:   [1] 2   next >   >> << Older Topic    Newer Topic >>
All Forums >> [Microsoft Exchange 2007] >> Message Routing >> Exchange 2007 can't send to Exchange 2003 Page: [1] 2   next >   >>
Jump to:

New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Follow TechGenix on Twitter