• RSS
  • Twitter
  • FaceBook

Exchange Server Forums

Forums | Register | Login | My Profile | Inbox | RSS RSS icon | My Subscription | My Forums | Address Book | Member List | Search | FAQ | Ticket List | Log Out

ActiveSync 0x85010004 Error

Users viewing this topic: none

Logged in as: Guest
  Printable Version
All Forums >> [Microsoft Exchange 2007] >> Mobility >> ActiveSync 0x85010004 Error Page: [1]
Login
Message << Older Topic   Newer Topic >>
ActiveSync 0x85010004 Error - 23.Mar.2007 1:21:10 PM   
rooppert

 

Posts: 8
Joined: 23.Mar.2007
Status: offline
We have just about completed our transition from Exch03 to 2007.  Mailboxes have been moved, public folders replicated, etc.  Now I've moved on to completing cutover of our WM5 devices.  A little backgroud first... in 2003 we were running FE/BE setup, with OWA and exch activesync pointing to the front-end, and all mailboxes located on the back-end.  Also, both 2003 servers are running SP2, and have had no problems with direct push email using SSL (self-signed).

Now I have moved all of our mailboxes to the 2007 box, which in all other aspects is working great.  But now if I point my device (only testing mine at this point) to the new server (after installing the new cert on my phone) I get:

"Your account in Microsoft Exchange Server does not have permission to synchronize with your current settings.  Contact your Exchange Server administrator.

Support code: 0x85010004"

Fortunately, my 2003 FE server is still allowing all of my users to sync their devices as the FQDN and cert on their phones are still valid.  I've checked the settings in EMC and the mailboxes are enabled for Exchange Activesync.  I've even run the script to enable it again (successfully) in EMS.

I know 2003 had some funny configs for virtual directory security, etc. to get EA working in some enviornments; is that the case again in 2007?

Any help on this would be greatly appreciated!
Post #: 1
RE: ActiveSync 0x85010004 Error - 24.Mar.2007 8:43:34 AM   
Henrik Walther

 

Posts: 6928
Joined: 21.Nov.2002
From: Copenhagen, Denmark
Status: offline
There's no funny configs for EAS vdir in E2K7. But I've seen similar issues with migrated users, where the solution was to delete the partnership using the EMC.

Does a partnership show up for your device?


_____________________________

HTH
Henrik Walther
Lead Moderator/author
MSExchange.org

Follow me on Twitter!

(in reply to rooppert)
Post #: 2
RE: ActiveSync 0x85010004 Error - 24.Mar.2007 10:33:21 AM   
rooppert

 

Posts: 8
Joined: 23.Mar.2007
Status: offline
No, I'm not showing partnerships listed for any of the mailboxes for my mobile users.

(in reply to Henrik Walther)
Post #: 3
RE: ActiveSync 0x85010004 Error - 24.Mar.2007 11:32:51 AM   
rooppert

 

Posts: 8
Joined: 23.Mar.2007
Status: offline
Figured it out...

Even though the user accounts were enabled for activesync in EMC I ran the following command in EMS:

Set-CASMailbox -Identity <SMTP Address of user> -ActiveSyncEnabled $true

The funny thing is that it said the command executed successfully, but "no settings of 'domain/OU/user' have been modified".  After that I was able to sync the device and manage it within EMC under the user's mailbox in recipient configuration.

(in reply to rooppert)
Post #: 4
RE: ActiveSync 0x85010004 Error - 15.May2007 5:20:55 PM   
felipeg007

 

Posts: 70
Joined: 9.Aug.2006
Status: offline
same thing happened to me

Set-CASMailbox -Identity FirstintialLastname -ActiveSyncEnabled $true

i had to run this to get things to work.

I even tried assigning different policies via the managment tool and nothing. I also ran get-casmailbox to look at setting and everything looked the same.
Maybe they will fix this on rollout 3 ;-) 


(in reply to rooppert)
Post #: 5
RE: ActiveSync 0x85010004 Error - 16.May2007 10:52:22 AM   
felipeg007

 

Posts: 70
Joined: 9.Aug.2006
Status: offline
i am having a problem with enabling passwords on mobile devices.
When I enable "Require password" Sync fails and i recieve the error
"your exchange account does not have access"

I am using the same password settings recommended by Henrik Walther book page 249

I am using Windows Mobile 5 as a client.

has anyone else seen this.

Thank you

(in reply to felipeg007)
Post #: 6
RE: ActiveSync 0x85010004 Error - 16.May2007 11:18:55 AM   
felipeg007

 

Posts: 70
Joined: 9.Aug.2006
Status: offline
i have narrowed down the error to "require encryption on device"

i am using a cert from godaddy do i need to install this on the mobile device as well.

(in reply to felipeg007)
Post #: 7
RE: ActiveSync 0x85010004 Error - 16.May2007 12:47:18 PM   
felipeg007

 

Posts: 70
Joined: 9.Aug.2006
Status: offline
I found out that godaddy new cert are not installed on mobile 5 devices. but they are in Mobile 6.  I am not trying to find a DER formatted cert from godaddy so i can install it on my device.
I tried installing the Cert that is DER format
Valicert_class2_root.ver and it did not fix problem
 
I tried installing gd-class-root.cer and  I get an error system “can not access cert”
I am going to continue trying with godaddy. 

(in reply to felipeg007)
Post #: 8
RE: ActiveSync 0x85010004 Error - 3.Jun.2007 12:39:25 AM   
tekmunki

 

Posts: 2
Joined: 3.Jun.2007
Status: offline
For testing purposes, does anyone know a way to disable the requirement for SSL for ActiveSync in Exchange 2007? 

In doing so, will I run into the port 80 conflicts that occured in exch2003?


(in reply to felipeg007)
Post #: 9
RE: ActiveSync 0x85010004 Error - 30.Jul.2007 4:49:14 PM   
RobGraves

 

Posts: 2
Joined: 30.Jul.2007
Status: offline
We have a new install going on and we are getting this error message on multiple accounts and multiple devices.  We have reviewed every tip and trick that we can find out there including the ones in this post. 

The CAS servers are set up a NLB configuration and the Certificate includes the default OWA site, both node names and the virtual node name.

We go live with the install on Saturday, and I have 85 Executives who are going to want their new Treo 700wx working with Active Sync bright and early Monday morning.

Thanks in advance for any assistance!

Rob Graves

(in reply to rooppert)
Post #: 10
RE: ActiveSync 0x85010004 Error - 7.Sep.2007 2:17:10 PM   
nathansrebs

 

Posts: 2
Joined: 7.Sep.2007
Status: offline
You have to do it in two places.  Under IIS and under the exchange mmc.

IIS first
Under the website for exchange view properties of the "Microsoft-Server ActiveSync.  Under the document security click edit under secure communications.  Uncheck the require SSL.

Now Exchange MMC
Under the Organization Configuration click client access.  View properties of the activesync policy.  If no policy, create a new one.  On the password tab, uncheck the require device encryption and any other that you desire.

Helpful links
http://support.microsoft.com/kb/841060
and
http://www.pocketpcfaq.com/faqs/activesync/exchange_errors.php

Give the Glory to God!


(in reply to tekmunki)
Post #: 11
RE: ActiveSync 0x85010004 Error - 18.Oct.2007 3:54:02 AM   
hiramdante

 

Posts: 1
Joined: 18.Oct.2007
Status: offline
Hi, im new on this forums and i dont speak english at 100% bout i hope that you understand me
I was reading a lot of articles, process and contact the Microsoft Support Premier, but nobody solved.... Finaly I found the solution for this problem through the following:



- Deployment process followed:

http://www.microsoft.com/technet/solutionaccelerators/mobile/deploy/msfpdepguide.mspx

http://www.petri.co.il/how_to_sync_ppc_with_exchange_2003.htm
- Understanding Troubleshooting ActiveSync:  http://support.microsoft.com/?scid=kb%3Ben-us%3B330461&x=7&y=11
- The "KnowledgeBase" for PocketPC with an issues list (incluided error 85010014) checking all the 12 posible causes:

http://www.pocketpcfaq.com/faqs/activesync/exchange_errors.php
- IIS support for both the Kerberos protocol and the NTLM protocol for network authentication   http://www.pocketpcfaq.com/faqs/activesync/exchange_errors.php

I hope that this help you, cause its very helful to troubleshooting.



Please let me know if this work.. 


Hiram Dante

(in reply to rooppert)
Post #: 12
RE: ActiveSync 0x85010004 Error - 2.Nov.2009 12:29:54 AM   
vquinones

 

Posts: 1
Joined: 2.Nov.2009
Status: offline
Steps to fixing Microsoft Exchange 2007 to Windows Mobile 6.1 ERROR 0x85010004

I just went through a 72 hour nightmare trying to diagnose/fix this issue. I finally broke down and got Microsoft on the phone. After 2 more hours, they finally figured this out.

I am hoping to save many of my brothers out there the agony of having to fix Microsoft's mistakes.


On the Microsoft Exchange 2007 Server...

1. Create a new certificate:

This is the powershell command for creating one from the server:
New-ExchangeCertificate -SubjectName "c={COUNTRY}, o={COMPANY}, cn={EXTERNAL FQDN}" -DomainName {EXTERNAL FQDN},{NETBIOS NAME}, {INTERNAL FQDN}, autodiscover.{INTERNAL DOMAIN NAME}, autodiscover.{EXTERNAL DOMAIN NAME} -PrivateKeyExportable $true -KeySize 1024 | Enable-ExchangeCertificate -services iis

2. Remove Activesync virtual directory
In Powershell:

Remove-ActiveSyncVirtualDirectory -Identity "ppg-exchange\Microsoft-Server-ActiveSync (Default Web site)"


3. Recreate Activesync virtual directory
In Powershell:

New-ActiveSyncVirtualDirectory

4. Reset IIS

iisreset

On the Windows Mobile Device...

5. Install the new certificate on the Windows mobile device.

6. Setup Activesync pointing to {EXTERNAL FQDN}

7. Make sure "This server requires an encrypted (SSL) connection is checked.

8. Reset you Windows Mobile Device

9. Sync



I hope this helps.

Respectfully,

Victor Quinones,
CTO
Virtual-Q, Inc.
www.Virtual-Q.com

(in reply to rooppert)
Post #: 13
RE: ActiveSync 0x85010004 Error - 12.Nov.2009 2:58:00 AM   
bathshop321

 

Posts: 2
Joined: 12.Nov.2009
From: washington dc
Status: offline
Support code: 0x85010004"

Fortunately, my 2003 FE server is still allowing all of my users to sync their devices as the FQDN and cert on their phones are still valid.  I've checked the settings in EMC and the mailboxes are enabled for Exchange Activesync.  I've even run the script to enable it again (successfully) in EMS.

(in reply to vquinones)
Post #: 14

Page:   [1] << Older Topic    Newer Topic >>
All Forums >> [Microsoft Exchange 2007] >> Mobility >> ActiveSync 0x85010004 Error Page: [1]
Jump to:

New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Follow TechGenix on Twitter