Public Folders and PFDAVAdmin (Full Version)

All Forums >> [Microsoft Exchange 2003] >> Public Folders



Message


dholder97 -> Public Folders and PFDAVAdmin (29.Mar.2007 10:22:52 AM)

Can someone please help me with this error?  I accidentally removed some permissions and now my public folders have all disappeared.  I searched the site and found someone else with a quite similar problem, that's how I found out about PVDAV.  I feel like I'm almost there to recovering it, I just can't get past this error.  I have attached 2 screen shots.

[image]http://24.106.181.164/images/screenshot.jpg[/image]
[image]http://24.106.181.164/images/pfdav.jpg[/image]
Port 80 works b/c that's how you're seeing these images on my web server.  SSL works because OWA is working.  I can't figure out how to mount if there's nothing appearing to mount.  And I tried a restore-- access denied of course.  Thanks in advance




dholder97 -> RE: Public Folders and PFDAVAdmin (29.Mar.2007 10:26:35 AM)

Oh btw, the bottom error happens when i try to connect to public folders in PFDAV




uemurad -> RE: Public Folders and PFDAVAdmin (29.Mar.2007 10:50:36 AM)

Can you see the Public folder objects in the ADUC?  Make sure you are viewing Advanced Features and look for the Microsoft Exchange Sysetm Objects folder.  There is probably an easier way, but if you can see the folders you might try changing the security permissions on one of the higher-level folders to see if it then appears in the ESM.

Do you know what permissions you changed to cause the issue?




dholder97 -> RE: Public Folders and PFDAVAdmin (30.Mar.2007 11:42:27 AM)

good idea uemurad!  i never thought about ADUC.  unfortunately though, all the permissions look good in there.  all public folders are visible, and they all have full control permissions.  the parent folder, MS Exchange System Objects, has good permissions too.  The object above that in the tree is the domain.  Also looks good.
So I go back to ESM and try to mount the store and get this:
[image]http://24.106.181.164/images/123.jpg[/image]
Answer to your last question - i must have removed all permissions from a group.  i was flying thru the windows so fast i just clicked and it was over.  it may have been the everyone group, but it makes no sense b/c i have the administrator group with full control and even went back and added the everyone with full control for giggles.  still no worky :(




uemurad -> RE: Public Folders and PFDAVAdmin (30.Mar.2007 11:58:19 AM)

In that case, read through this:
HOW TO: Add Minimum Permissions Required for Mailbox Stores and Public Folder Stores
http://support.microsoft.com/kb/328229/en-us




dholder97 -> RE: Public Folders and PFDAVAdmin (30.Mar.2007 12:25:08 PM)

did that yesterday :(  am i not doing it in the right place.  i've tried from ESM, ADUC, and from the MDBDATA directory

it's GOT to be permissions somewhere.  i even tried a restore and it says access denied.  this is getting frustrating




uemurad -> RE: Public Folders and PFDAVAdmin (30.Mar.2007 1:53:47 PM)

At this point your best bet is to put in a call to Microsoft PSS.




dholder97 -> RE: Public Folders and PFDAVAdmin (30.Mar.2007 3:00:27 PM)

HALLE-FREAKIN-LUJAH i fixed it!  Wow what a trip that was.  The problem was I denied the everyone group all privaleges (OOPS!). 
Thanks so much uemurad, i went to the PSS knowledge base and found this holy grail article about an oh-so-fantastic tool called dsacls
http://support.microsoft.com/kb/823017/en-us
It reset the permissions for me and my public folder is mounted again.  Time to resume backups!




Page: [1]