Windows Mobiles not syncing (Full Version)

All Forums >> [Microsoft Exchange 2007] >> Mobility



Message


hhth -> Windows Mobiles not syncing (21.Apr.2007 9:15:47 AM)

I have setup a cas with a public (verisign) ssl certificate. This certificate was imported from our old front-end. If I access the new CAS from Internet explorer from a pc I have no problems and everything is fine. If however I try and access the site from some mobile devices using IE I get 'The certificate was issued by a company you have chosen not to trust'. Activesync is also failing with 'the security certificate on the server is invalid'. This is baffling since the certificate is valid and the error (the IE one) doesn't appear on PC's. Becasue of this I've put back the old front-end (with exaclty the same ssl certificate) that causes the PDA's to work perfectly.




Henrik Walther -> RE: Windows Mobiles not syncing (22.Apr.2007 4:26:18 AM)

And you did remember to export/import the certificate with the private key too right?




hhth -> RE: Windows Mobiles not syncing (22.Apr.2007 6:47:47 AM)

Hi Henrik,

Got your book by the way 'How to cheat at ...'. Nice pointers but can you recommend a more indepth one. I also have the 'Unleashed' one. 

Certificate below shows it has got the keys:

AccessRules        : {System.Security.AccessControl.CryptoKeyAccessRule, System.Security.AccessControl.CryptoK
                     eyAccessRule}
CertificateDomains : {webmail.ourdomian.com}
HasPrivateKey      : True
IsSelfSigned       : False
Issuer             : CN=VeriSign Class 3 Secure Server CA, OU=Terms of use at https://www.verisign.com/rpa (c)
                     05, OU=VeriSign Trust Network, O="VeriSign, Inc.", C=US
NotAfter           : 18/12/2009 00:59:59
NotBefore          : 13/11/2006 01:00:00
PublicKeySize      : 1024
SerialNumber       : 53292574AE54B817A0A8535392ABAD10
Status             : Valid
Subject            : CN=webmail.ourdomain.com, OU=Terms of use at www.verisign.com/rpa (c)05, OU=MIS, O=Ourcompany, L=Gibraltar, S=Gibraltar, C=GI
Thumbprint         : 7FDEB7DDD500FA5A3E543A25C98302704A6B0E6A




Henrik Walther -> RE: Windows Mobiles not syncing (22.Apr.2007 9:21:59 AM)

Ok and this certificate doesn't require an intermediate cert (besides the root CA which is trusted by default) to be installed on the server and the mobile device?

There are not many E2K7 books out yet, and I don't believe those that are on the way goes very deep. For deep info the E2K7 online documentation is the best resource.




hhth -> RE: Windows Mobiles not syncing (22.Apr.2007 1:21:43 PM)

Nope. Go to https://195.244.195.19 which is the 2K7 box and https://webmail.gibtele.com which is the 2K3 box. If you edit your hosts file to point webmail.gibtele.com to 195.244.195.19 you'll see you don't have any cert. warnings when going in via IE on your PC. If you do the same on a pda (I'm testing on a HP6515) you'll get the warning. I'm testing by using 'Zimmermann Pocket Hosts - Version 1.5' that allows me to edit the hosts file on the pda.

Also any ideas on this:

http://forums.msexchange.org/Cannot_Add_Hub_Transport_Role/m_1800438198/tm.htm

Thanks.




hhth -> RE: Windows Mobiles not syncing (10.Jun.2007 2:00:28 AM)

Solved. Purchased\installed Entrust Unified Communications Certificate and alls OK now. Other issues have also been resolved using this cert.




Page: [1]