• RSS
  • Twitter
  • FaceBook

Exchange Server Forums

Forums | Register | Login | My Profile | Inbox | RSS RSS icon | My Subscription | My Forums | Address Book | Member List | Search | FAQ | Ticket List | Log Out

SMTP delivery stops at SMTP: Message Submitted to Categorizer

Users viewing this topic: none

Logged in as: Guest
  Printable Version
All Forums >> [Microsoft Exchange 2003] >> General >> SMTP delivery stops at SMTP: Message Submitted to Categorizer Page: [1]
Login
Message << Older Topic   Newer Topic >>
SMTP delivery stops at SMTP: Message Submitted to Categ... - 8.May2007 10:44:37 AM   
tisgrandupnorth

 

Posts: 40
Joined: 3.Apr.2007
Status: offline
Routing stops at "SMTP: Message Submitted to Categorizer"
I have a batch of messages that have been received by the POP3 Connector and are stuck somewhere in the production line of exchange server.

I can find the messages from the Message Tracking Centre but they're not appearing in the user's mailbox.

How do I narrow down where they are, and how I can get them to the user's mailbox?

< Message edited by tisgrandupnorth -- 8.May2007 12:33:54 PM >
Post #: 1
RE: SMTP delivery? - 8.May2007 11:46:55 AM   
uemurad

 

Posts: 8232
Joined: 7.Jan.2004
From: California, USA
Status: offline
Does Message Tracking claim to have delivered locally to store?

_____________________________

Regards,

Dean T. Uemura
Microsoft MVP - Exchange (2007-2011)
exchangeguy.blogspot.com
uemurad@yahoo.com

(in reply to tisgrandupnorth)
Post #: 2
RE: SMTP delivery? - 8.May2007 11:58:24 AM   
tisgrandupnorth

 

Posts: 40
Joined: 3.Apr.2007
Status: offline
I'm not positive how to check, but I presume it's under the Track Message dialogue, in which case it looks like this:

SMTP: Message Submitted to Advance Queuing
SMTP: Started Message Submission to Advance Queuing
SMTP: Message Submitted to Categorizer

Hope I'm looking in the right place?

(in reply to uemurad)
Post #: 3
RE: SMTP delivery? - 8.May2007 12:03:48 PM   
uemurad

 

Posts: 8232
Joined: 7.Jan.2004
From: California, USA
Status: offline
You are looking in the right place, but is there any more to the tracking?  After being submitted to the categorizer, a successfully delivered message will then:

SMTP: Message Categorized and Queued for Routing
SMTP: Message Queued for Local Delivery
SMTP: Message Delivered Locally to <username>@<domainname>


_____________________________

Regards,

Dean T. Uemura
Microsoft MVP - Exchange (2007-2011)
exchangeguy.blogspot.com
uemurad@yahoo.com

(in reply to tisgrandupnorth)
Post #: 4
RE: SMTP delivery? - 8.May2007 12:09:06 PM   
tisgrandupnorth

 

Posts: 40
Joined: 3.Apr.2007
Status: offline
Glad i'm looking in the right place but that's the extent of the tracking.

(in reply to uemurad)
Post #: 5
RE: SMTP delivery stops at SMTP: Message Submitted to C... - 8.May2007 3:19:19 PM   
jchong

 

Posts: 2516
Joined: 1.Dec.2005
From: Centreville, Virginia
Status: offline
Enable diagnostic logging for msexchangetransport, categorizer, then send the message and view your eventviewer app log and post.

Exchange 2000 Diagnostics Logging
http://www.msexchange.org/tutorials/Diagnostics-Logging.html


James Chong (MVP)
MCSE | M+, S+, MCTS, Security+
msexchangetips.blogspot.com

(in reply to tisgrandupnorth)
Post #: 6
RE: SMTP delivery stops at SMTP: Message Submitted to C... - 9.May2007 7:03:49 AM   
tisgrandupnorth

 

Posts: 40
Joined: 3.Apr.2007
Status: offline
We're getting there - I managed to solve that one as the email domain for the POP collected mail was not included in the default recipients policy!

Now new e-mails are coming through the POP connector and landing in the inbox, but I still have hundreds of emails that made it to:

SMTP: Message Submitted to Categorizer

and went no further. The recipient of all these is mspop3connector.username.domain.co.uk.  How can I get these from the categorizer to the mailbox?

(in reply to jchong)
Post #: 7
RE: SMTP delivery stops at SMTP: Message Submitted to C... - 9.May2007 10:16:31 AM   
tisgrandupnorth

 

Posts: 40
Joined: 3.Apr.2007
Status: offline
Right, I've read up on the 'Message Sent To Categorizer' error.  The most useful stuff on the net is actually from jchong on this very forum!

With the initial problem - mail from the POP3 connector dissapearing into the categorizer and still having the mspop3connector. prefix attached - seemed to be because the domain in the To: of the e-mail was not entered into the defauly recipient policy with 'responsible for all mail' checked.  It seems that this is going to cause more problems when it tried to send mail and discovers it isn't actually solely responsible, but one thing at a time.

Next, how to get the mails from the Categorizer?  One solution seems to be to reinstall IIS and Exchange, but that seems a bit extreme to me, and will I not lose the e-mails if I do that?

Many people refer to finding the e-mails in the BadMail / Queue in %program files%\Exchsrvr\Mailroot\vsi 1 folder as .eml files, but there's nothing there,

Others talk of setting an undeliverable mail mailbox, which would work for getting new e-mails through the system, but not old e-mails out of the system.

So, how do I get the existing mails stuck in the categorizer through into the routing queue?

(in reply to tisgrandupnorth)
Post #: 8
RE: SMTP delivery stops at SMTP: Message Submitted to C... - 28.May2009 10:44:41 AM   
bogdan

 

Posts: 4
Joined: 28.May2009
Status: offline
I have quite the same problem. My Exchange server works, but the weird thing is that a recipient received a third email from an address and it was delivered fine and the first two emails from the same address to the same recipient got stuck in the "Message Submitted to Categorizer". Does anyone know any way I can found out what caused that? Thank you.

Bogdan

(in reply to tisgrandupnorth)
Post #: 9
RE: SMTP delivery stops at SMTP: Message Submitted to C... - 29.May2009 11:45:42 AM   
Subashes

 

Posts: 72
Joined: 24.Sep.2008
From: India
Status: offline
I observe this issue when users send mail to distribution list. This is because the distribution list membership is not automatically cleared when a member is deleted from AD. In my case I have removed the orphaned object membership from distribution group and the issue disappeared.

_____________________________

-Sub-

(in reply to tisgrandupnorth)
Post #: 10
RE: SMTP delivery stops at SMTP: Message Submitted to C... - 3.Jun.2009 8:33:06 AM   
bogdan

 

Posts: 4
Joined: 28.May2009
Status: offline
Thanks. I will have to find out if the message was sent to a distribution list. It hasn't happened again since then. I hope it was an isolated issue.

(in reply to Subashes)
Post #: 11
RE: SMTP delivery stops at SMTP: Message Submitted to C... - 23.Jul.2009 9:24:25 AM   
bogdan

 

Posts: 4
Joined: 28.May2009
Status: offline
It happened again. This time the email was sent to a single address, not a distribution list. I also got an event ID 6019 from MSExchangeTransport - Categorizer which corresponds to the lost message. Unfortunately I don't have the event message. 

(in reply to Subashes)
Post #: 12

Page:   [1] << Older Topic    Newer Topic >>
All Forums >> [Microsoft Exchange 2003] >> General >> SMTP delivery stops at SMTP: Message Submitted to Categorizer Page: [1]
Jump to:

New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Follow TechGenix on Twitter