ID no: c1030af1 (Full Version)

All Forums >> [Microsoft Exchange 2003] >> Public Folders



Message


EssCee -> ID no: c1030af1 (11.May2007 4:54:00 AM)

When i expand First Administrative Group > Folders > Public Folders
I receive:

The requested operation is forbidden.
ID no: c1030af1
Exchange system manager


and cant do anything further. My guess would be this has possibly occurred after installing SP2 but not 100%. an anyone guide in how to resolve this error as searching the web didnt provide any resolutions?
Thanks




a.grogan -> RE: ID no: c1030af1 (11.May2007 8:52:21 AM)

Hiya Ess - have you seen this - it might help - http://www.petri.co.il/error_c1030af1_on_pf_properties.htm

Cheers,

A




EssCee -> RE: ID no: c1030af1 (11.May2007 10:32:23 AM)

Thanks a.grogan. I checked that link but unfortunately i didnt have SSL enabled so i ticked the relevant options restarted Exchange and then deselected the same options and restarted Exchange, still didnt resolve. After reading a few articles closely related i even went into adsiedit.msc looked at the mssecureBindings key which didnt have a value set.

Strangely the error message is now:

The token supplied to the function is invalid.
ID no: 80090308
Exchange System Manager


and clicking ok to that comes up with:

The operation completed successfully
Facility:Win32
ID no: c0070000
Exchange system Manager


Any more ideas? Thanks




a.grogan -> RE: ID no: c1030af1 (11.May2007 10:52:15 AM)

Hiya chap, ok, have a look here http://support.microsoft.com/?id=324345

A




EssCee -> RE: ID no: c1030af1 (11.May2007 10:59:14 AM)

Hello. Yes already have tried that without success.




a.grogan -> RE: ID no: c1030af1 (11.May2007 11:07:37 AM)

Ok mate, sorry for the previous two answers - just firing off into the ether -
Couple of Questions;

Is this a Frontend server?
Was it OK prior to SP2?
Was SP 2 a recent thing?

What are the current settings at the moment.

Hope you don't mind the Q's

A




EssCee -> RE: ID no: c1030af1 (11.May2007 11:13:55 AM)

No problem about the questions.

Is this a Frontend server?
Yes (It runs on SBS)
Was it OK prior to SP2?
Yes
Was SP 2 a recent thing?
Installed it about a month ago but never really went into the public folders
What are the current settings at the moment.
Not sure what you mean by that
 
But in the meantime reading around I think this article may help as i did install IE7 shortly after SP2 http://support.microsoft.com/kb/932513. Ill try this later today as i cant take down the server just yet and if i dont report back it means it all went well and resolved the issue however thanks for your advise and help.





Update:
I tried the above but it resolved the problem about opening help (which i didnt mention as it was not a huge issue) but did nothing with the problem described here (I was hoping this problem would have fixed both) So back to square one




ismail.mohammed -> RE: ID no: c1030af1 (14.May2007 5:28:42 AM)

Hi,
It seems that u have done most of the troubleshooting steps like Uncheck require 128-bit encryption & Uncheck require SSL Encryption and one more thing while following this step have you Checked Accept Client Certificates and restarted the WWW service.
And another thing msExchSecureBindings = not set which u did.

I would like to confirm Is this server is first server in the site.
Is it your certificate is expired : Possiblities "Certificate principal mismatch"

I would suggest to run exbpa and work accordingly and re-confirm your ceritificate is under validation.




EssCee -> RE: ID no: c1030af1 (18.May2007 6:51:36 AM)

When i ran exba it brought up a couple of errors:

Permissions inheritance block on Exchange database object Server: SERVER
Access control list (ACL) inheritance is blocked for the Exchange database object (DN: CN=Public Folder Store (SERVER),CN=First Storage Group,CN=InformationStore,CN=SERVER,CN=Servers,CN=first administrative group,CN=Administrative Groups,CN=DOMAIN,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=Domain Controller,DC=local). This may cause mail flow problems, store mounting issues and other service outages. Follow Microsoft Knowledge Base article KB264733 and use the Active Directory Sites and Services program to re-enable inheritance on this object.
  

Permissions inheritance block on Exchange database object Server: SERVER
Access control list (ACL) inheritance is blocked for the Exchange database object (DN: CN=Mailbox Store (SERVER),CN=First Storage Group,CN=InformationStore,CN=SERVER,CN=Servers,CN=first administrative group,CN=Administrative Groups,CN=DOMAIN,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=Domain Controller,DC=local). This may cause mail flow problems, store mounting issues and other service outages. Follow Microsoft Knowledge Base article KB264733 and use the Active Directory Sites and Services program to re-enable inheritance on this object.


Ive got the Security tab showing but not sure which group im suppose to give permission to or where in AD i need to go to give permission. Can anyone advise?

Many thanks




ismail.mohammed -> RE: ID no: c1030af1 (22.May2007 2:38:26 AM)

Please follow the EXBPA suggestion... inheritance permission is blocked which is not a good sign.




EssCee -> RE: ID no: c1030af1 (22.May2007 4:22:56 AM)

quote:

ORIGINAL: ismail.mohammed

Please follow the EXBPA suggestion... inheritance permission is blocked which is not a good sign.


Yes i know that but not too sure what i need to do as i went into ADSS but wasnt sure where to go to enable inheritance.

Thanks




ismail.mohammed -> RE: ID no: c1030af1 (22.May2007 5:22:46 AM)

hi,

Install windows support tool.

Then click on run => Adsiedit.msc

Then go to the following path :
CN=Public Folder Store (SERVER),CN=First Storage Group,CN=InformationStore,CN=SERVER,CN=Servers,CN=first administrative group,CN=Administrative Groups,CN=DOMAIN,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=Domain Controller,DC=local
 
Then right click it and go to properties => then click on security => Advanced => here u will see small box for "Allow inheritance" which you need to provide check mark.
 
Please keep me update because i just now tested it and it worked for me.
 
When you change it should or if might come across with this situation
 
When you try to mount a public folder store by using Exchange 2000 Server version of Exchange System Manager, you may receive the following error message:
The store could not be mounted because the Active Directory information was not replicated yet. After you receive the preceding error message, you receive the following error message:
The Microsoft Exchange Information Store service could not find the specified object. ID no:c1041722 ORAn invalid directory pathname was passed (when you try to go to the properties of public folder store through adsiedit.msc) That time go to cmd prompt type the following dsacls "CN=Public Folder Store (SERVER),CN=First Storage Group,CN=InformationStore,CN=SERVER,CN=Servers,CN=first administrative group,CN=Administrative Groups,CN=DOMAIN,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=Domain Controller,DC=local" /I:T /R  EVERYONE (You can get this by going to mailbox store properties through adsiedit.msc just change mailbox store to public folder store) http://support.microsoft.com/kb/300444/en-us




EssCee -> RE: ID no: c1030af1 (1.Jun.2007 12:24:50 PM)

Hello and sorry for the delay in getting back (on vacation). I ran adsiedit.msc and i cant find the path specified
 
CN=Public Folder Store (SERVER),CN=First Storage Group,CN=InformationStore,CN=SERVER,CN=Servers,CN=first administrative group,CN=Administrative Groups,CN=DOMAIN,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=Domain Controller,DC=local
 
I couldnt find a folder listed as Public folder Store even when i expanded the configuration option - any advice on this?

Thanks




ismail.mohammed -> RE: ID no: c1030af1 (5.Jun.2007 10:03:14 AM)

Are you sure about this, because this is not a good sign at all. I would like to see the print screen of ESM of mailbox store public store including their propertie (general tab) and Adisiedit where you are not able to see that.
mohammed.ismail@gmail.com my email address




andykewcomp -> RE: ID no: c1030af1 (22.Jan.2008 3:45:38 AM)

I have the same problem here.

In ESM I expand Folders, and then Public Folders does not expand and brings up the error:

The requested operation is forbidden
 
ID no: c1030af1
Exchange System Manager

So I apply this fix:
http://www.petri.co.il/error_c1030af1_on_pf_properties.htm

The 2 tick boxes were unticked anyway, so if I tick them it brings up another error!

The token supplied to the function is invalid
 
ID no: 80090308
Exchange System Manager

So if I look up the solution for that problem it just gets me to untick the two boxes and I'm back to square one again!






andykewcomp -> RE: ID no: c1030af1 (22.Jan.2008 4:25:17 AM)

Ok, sorted it [:)]

Went into IIS Admin - Exadmin folder and allowed access to everyone in the TCP/IP section. Access was blocked except for 2 IP addresses.




andykewcomp -> RE: ID no: c1030af1 (24.Jan.2008 5:37:05 AM)

Problem returned later the same day!

Does anyone have a solution??????????

I can't re-do what I did in my last post as that's already been done.




andykewcomp -> RE: ID no: c1030af1 (24.Jan.2008 7:49:55 AM)

Got it working again.

I went in to IIS Manager and set anonymous access on the default web site.

Then dismounted the Public Folders store and re-mounted.

Still working after an hour. Fingers crossed.........




paresh_md -> RE: ID no: c1030af1 (28.Jan.2008 9:46:24 AM)

Hi,

Just in case if anyone is facing the issue and have not find the answer yet.

This usually happens as someone mistakenly unchecks the "Allow inherit" box and select remove when prompted with options. Usually one should always do "Copy" and not "Remove".

Removing the inherited permissions takes everyone's permissions from that object including Admnistrators.

To get the permissions fixed on any object use the command below.

dsacls CN=Someone,OU=Software,OU=Engineering,DC=Microsoft,DC=Com /g "Everyone":GA /i:t

See article http://support.microsoft.com/kb/281146 on how to use DSACLS.exe

I've done this on many scenarios and it has worked. Please send me a PM if you cant fix it using this.

Regards,
PD




Meelmuis -> RE: ID no: c1030af1 (15.Mar.2010 12:33:52 PM)

Hi Paresh,

I am facing the same problem. Tried al options, but could not get the problem solved. The only option left is your tip in this Article
I can only not figure out how to use the command. Can you help me with this?

Thank you in advance,

Mark

PS. see next post for extra info.




Page: [1] 2   next >   >>