• RSS
  • Twitter
  • FaceBook

Exchange Server Forums

Forums | Register | Login | My Profile | Inbox | RSS RSS icon | My Subscription | My Forums | Address Book | Member List | Search | FAQ | Ticket List | Log Out

Hosted GAL Issues

Users viewing this topic: none

Logged in as: Guest
  Printable Version
All Forums >> [Microsoft Exchange 2007] >> General >> Hosted GAL Issues Page: [1]
Login
Message << Older Topic   Newer Topic >>
Hosted GAL Issues - 25.Sep.2007 3:18:28 PM   
jason331

 

Posts: 20
Joined: 23.Sep.2007
Status: offline
(sorry for the double post, I couldn't figure out how to delete the other one)

I recently migrated from Exchange 2003 with a working hosted Exchange environment to Exchange 2007. I followed GoldenDog's guide at http://www.kortekservices.com/lyle but can't get the GAL segmentation to work correctly. In Exchange 2003 I had several companies on my servers that could not see each other in their GALs. Now, the only way I can get new Outlook 2003 profiles setup or view the GAL while logged in as a segmented user without the dreaded "bookmark is not valid" message is to grant read and open address list on my Default Global Address list.

Per GoldenDog's guide I have removed inheritance on the All Address Lists, All Global Address Lists, and Offline Address Lists containers (as well as appropriate sub-items) and added Authenticated Users with List Object permissions to the appropriate places (after enabling dsHeuristics). Any thoughts on what I might be doing wrong? I'm thinking about rolling back to Exchange 2003 because of this.

I guess this question is mostly directed toward GoldenDog, but anyone is free to respond. Was there anything else special you did to get this working in your Exchange 2007 environment?

Also, on an unrelated note, when I try to run the exchange management shell commands listed on your website, I get the following:

New-GlobalAddressList –Name “My GAL” –RecipientFilter {(alias –ne $null –and customattribute15 –eq ‘customer.com’)}

New-GlobalAddressList : Cannot bind parameter 'RecipientFilter' to the target. Exception setting "RecipientFilter": """ is not a valid operator. For a list of
supported operators see the command help. "(alias -ne $null -and customattribute15 -eq `customer.com')" at position 8." At line:1 char:54
+ New-GlobalAddressList -Name "My GAL" -RecipientFilter  <<<< {(alias -ne $null -and customattribute15 -eq `customer.com')}
Post #: 1
RE: Hosted GAL Issues - 30.Sep.2007 3:50:34 AM   
jason331

 

Posts: 20
Joined: 23.Sep.2007
Status: offline
OK, I think I may have made some progress in troubleshooting this.

While logged in with my domain admin/enterprise admin account I can't create new Outlook profiles for my own mailbox. I get:

"The name could not be resolved. The bookmark is not valid."

Upon further research I noticed in OWA if I click the Address Book icon at the top I don't see anyone in the Default Global Address List (the first list that shows up). I can click the dropdown next to "Show other address lists" and I can see all my other address lists and corresponding global address lists (per GoldenDog's article). I can see members in the "regular" address lists but each Global Address List shows up empty. When I created the GALs per GoldenDog's article I ran the following command as quoted from his page below:

"NOTE: We can also do this entire setup in one command, but I broke it into two for clarification. To do it in one command, type New-GlobalAddressList –Name “Dogfood GAL” –RecipientFilter {(alias –ne $null –and customattribute1 –eq ‘Dogfood’)}"

New-GlobalAddressList –Name “My Test GAL” –RecipientFilter {(alias –ne $null –and customattribute15 –eq ‘company.com’)}"

I got the error described in my previous post:

": Cannot bind parameter 'RecipientFilter' to the target. Exception setting "RecipientFilter": """ is not a valid operator"

I had to modify that command a bit to get it to actually work:

New-GlobalAddressList -Name "New GAL" -RecipientFilter {(customattribute15 -eq 'company.com')}

I believe this is the source of my problem since I cannot see members of any of the GALs I created, even when logged in with my "God" account. I did some digging around in ADSIEdit and found the following property:

msExchQueryFilter

...which I manually modified to:

(Alias -ne $null -and (CustomAttribute15 -eq 'company.com'))

I have a feeling my opath syntax may not be correct. Can someone with a working hosted Exchange 2007 environment please check this property on a GAL and verify if I have it set correctly?

(in reply to jason331)
Post #: 2
RE: Hosted GAL Issues - 12.Oct.2007 12:22:10 PM   
jason331

 

Posts: 20
Joined: 23.Sep.2007
Status: offline
I fixed it!!

Apparently, when you migrate from Exchange 2003 to Exchange 2007, you have to upgrade your Global Address List(s) from LDAP to OPATH. (see http://msexchangeteam.com/archive/2007/01/11/432158.aspx)

In the process of upgrading my GALs per the article above, I found out it actually deletes the old GAL and creates a new one based on the new OPATH filter. My users were all still pointing to the old GALs (showInAddressBook ADSI property). As we're all aware, even though an object in AD may have the same name as something else that was deleted, its not considered the same since it would have a different SID. Once I deleted the references to the old GALs and changed that property to the DNs of the new GALs they all showed up in the correct GALs and could resolve usernames when creating new Outlook profiles.

Just thought I'd post my fix here in case anyone else has this same problem.

(in reply to jason331)
Post #: 3

Page:   [1] << Older Topic    Newer Topic >>
All Forums >> [Microsoft Exchange 2007] >> General >> Hosted GAL Issues Page: [1]
Jump to:

New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Follow TechGenix on Twitter