Reinstall Exchange... (Full Version)

All Forums >> [Microsoft Exchange 2003] >> Installation


msXchanger -> Reinstall Exchange... (14.Nov.2007 1:29:38 PM)

Since I can't find any help or resolution to my issues, I suppose I have to reinstall Exchange, we've been without e-mail too long... so my next question is this:

If I reinstall Exchange, what exactly is overwritten?  Will I pretty much start from scratch?  Will I keep my current Exchange configs (users, smtp domains, etc.)?


de.blackman -> RE: Reinstall Exchange... (14.Nov.2007 2:39:10 PM)


Since I can't find any help or resolution to my issues

What issues are you having exactly?

As long as you did not uninstall exchange, reinstalling exchange will simply replace all the exchange binary files on the server. Even though it will not overwrite your databases, it is always a good idea to take a backup of them before re-installing or installing any type of updates!!

All your exchange configuration information is stored in active directory so none of that will be lost with the re-install.

msXchanger -> RE: Reinstall Exchange... (14.Nov.2007 2:52:04 PM)

My issues I thought were DNS related, but I've gone over them time and again.  But here is my issue:

1. In ESM, under my Default SMTP Server, I cannot assign the correct IP address of the server.  I instead get two other IP address options (these of which I've never seen or inputted before). 

I've run Analyzer Tools and Troubleshooting Assistants with no luck.  The troubleshooting assistant says there needs to be a proper Host record, and there is, and the Analyzer Tool goes off about MSExchangeIS and I've corrected as described. 

de.blackman -> RE: Reinstall Exchange... (14.Nov.2007 2:56:17 PM)

Sounds like you have multiple network cards that have been configured in a teaming on the server. How many network cards are physically on the server (yes unfortunately I will need you to look at the back of the server itself to confirm this [;)]).

msXchanger -> RE: Reinstall Exchange... (14.Nov.2007 3:19:01 PM)

2 NIC's but one is disabled and always has been.  I use this server to host OWA. 

Issues began after I changed the server's IP address... users were able to receive but not send e-mails.  I checked DNS and changed the IPs... still no luck.

I ran the Configure E-Mail and Internet Connection Wizard and this messed everything up.  I finally got my websites back up and running, but I get a timeout 440 error when clients attempt to log on to OWA.  I can only assume that's because the Default SMTP Virtual Server doesn't have the correct IP.

Thanks a ton for the help.

de.blackman -> RE: Reinstall Exchange... (15.Nov.2007 3:15:51 PM)

The IP address of the SMTP virtual server actually has nothing to do with OWA. When users connect to OWA, they are using IIS on the server which in turn connects to HTTP protocol on the exchange server (in the Exchange system Manager, under protocols, you'll see HTTP).

Another thing to make sure of is when you go into Network Connections, on the Advanced Menu at the top of the window, select Advanced settings. There you will see the binding order of your NICs. Confirm that the enabled card is at the top of the binding order. If you have multiple protocols, make sure TCP/IP is at the top of the binding order as well.

So my understanding is u have issues sending emails as well as OWA, correct?

msXchanger -> RE: Reinstall Exchange... (15.Nov.2007 3:46:17 PM)

I only run OWA on this server and since we get 440 timeout errors, there's no e-mail of any kind.  My clients cannot log in to view received messages nor to send any, obviously. 

I did check the binding order of the 2 NICs, and this is what I have:
The "Internet Connection" NIC is the enabled card.  As you see, none of the protocols are checked... is that an issue?  I can't say I've known if they were different. 

de.blackman -> RE: Reinstall Exchange... (18.Nov.2007 10:25:34 PM)

Most definitely! exchange works with TCP/IP protocol and if the enabled card is not using this protocol, there will be no communication to or from this server. Select the checkbox for TCP/IP for both file/print as well as client for MS networks, then reboot the server.

Any idea why this would have been unselected? Are you the only administrator managing this server?

msXchanger -> RE: Reinstall Exchange... (19.Nov.2007 10:26:31 AM)

Okay, with the bindings changed I still cannot access OWA.  On the ESM, I still cannot get the correct IP address to list. 

So, no change.

msXchanger -> RE: Reinstall Exchange... (19.Nov.2007 12:52:10 PM)

Okay, considering your posts, I think my issue is DNS.  But, I'm not very certain. I can ping the website and get the correct IP back (ping correct IP), but when I attach the "/exchange" I get one of those IP addresses in the ESM SMTP Virtual Server IPs (ping wrong IP). 

Why the difference and where can I fix that? I don't want to keep making changes in my DNS and getting lost further.

Thanks again.

de.blackman -> RE: Reinstall Exchange... (19.Nov.2007 2:20:21 PM)

I am actually more surprised that you can ping! "/Exchange" is only a virtual directory or folder on the web site. Since you are able to ping the website with the correct IP address, then that should mean the problem is not DNS. What happens when you type in in a browser. Do you get the "Under Construction" page?

msXchanger -> RE: Reinstall Exchange... (19.Nov.2007 2:50:11 PM)

Yeah, weird about the IP address. 

I can access the websites fine, however when I attempt to access the virtual dir (/Exchange) that's where the timeout begins.  I even get notifications to accept or view the Certificate.

The reason I thought it's DNS is because when I ran the Exchange Baseline Analyzer I received errors stating that the virtual server name and the fqdn are not the same.  I attempted to change the names (virtual server and fqdn at separate instances) and they just flip flop when I rerun the test... so I get no where.

But why is it I get a different IP for "" than I do for ""?  And I know I shouldn't even be receiving a response for the exchange virtual directory. 

de.blackman -> RE: Reinstall Exchange... (20.Nov.2007 9:22:07 AM)

You mentioned that you have 2 NICs but one is disabled. Can you confirm that the active NIC has only 1 IP address ( from the properties of the NIC --> TCP/IP properties --> Advanced).

What we may have to do is have the virtual directories for exchange in IIS recreated. To do this, follow METHOD 2 in the following article (Note that you will need to restart the Microsoft Exchange System Attendant service which will cause clients to lose connection to the server).

How to reset the default virtual directories that are required to provide Outlook Web Access, Exchange ActiveSync, and Outlook Mobile Access services in Exchange Server 2003

msXchanger -> RE: Reinstall Exchange... (20.Nov.2007 12:48:40 PM)

Yes, I verified the active NIC has only one IP under it's Properties and Advanced Menu. I also noticed that the inactive "Server Local Area Connection" had all TCP/IP protocols checked and I unchecked them under the Adapters and Bindings/Advanced Settings Menu.  That did nothing either. 

I ran throught the article, without any success.  Restarted the Server as well. 


a.grogan -> RE: Reinstall Exchange... (20.Nov.2007 2:19:15 PM)

Hiya MS, would you be willing to download and install the IIS 6 resource kit tools on to you Exchange Server (located here:

If so, install them - and then open up the IIS Metabase explorer and navigate to:
<Local> - > LM -> SMTPSVC -> 1

The right hand place will change to display a number of attributes - what is the entry for "Server Bindings"?

Also can you have a look at the settings for

<Local> - > LM -> W3SVC -> 1 - > Server Bindings



msXchanger -> RE: Reinstall Exchange... (20.Nov.2007 5:43:59 PM)

Thanks A,
I did happen to have the Resource Kit already installed.  Would be nice to know how to use it, huh?

Okay, here's the data:


a.grogan -> RE: Reinstall Exchange... (21.Nov.2007 5:54:03 AM)

Hiya mate, I could not see the second image, but the first gave me some food for thought.
Can you take a backup of your IIS metabase (done via the IIS Manager) and then use the Metabase Explorer to navigate to the SMTP "serverbindings" value.

Double click on the item which will open up a dialog box you will see an entry at the top which says :25: double click on it and change this to <your IP address which is missing>:25: and click OK.
Restart the SMTP service - repeat for the W3SVC.

Let us know


msXchanger -> RE: Reinstall Exchange... (21.Nov.2007 10:07:01 AM)

Thanks!!  But no change.  I still cannot access OWA, and the correct IP address still is NOT showing up in my Default SMTP Virtual Server. 

If I close the Metabase Explorer, and open it back up, the binding remains the same (:25:) without the IP addressed I entered.  The change is not taking hold.

Thanks so much for you help, by the way. 

a.grogan -> RE: Reinstall Exchange... (21.Nov.2007 1:37:28 PM)

Hiya MX, you have said that you have 2 NICs on the server 1 is enabled and the other is not and that is the way it always has been.
Can I ask a couple more questions;

At the back of your server are both NICs plugged into the network.
Have you at any point re-enabled the other NIC
On the active NIC when you have the properties open, and then select the properties of TCP/IP there is an ADVANCED button - when you click on that the first page is entitled IP settings - what do you see there?



msXchanger -> RE: Reinstall Exchange... (21.Nov.2007 2:17:27 PM)

2 NICs on the server, only one has a cable plugged in. 
I have NOT enabled the 2nd NIC... although, I did run the E-Mail and Internet Connection Wizard at one point which caused some problems (websites would not start/display). 

As for the settings you asked for, under IP Adress:  there is the correct IP and Subnet Mask. 

Under Default Gateway: Its the default gateway given to me by my ISP.  Metric set to Automatic.


Page: [1] 2 3   next >   >>