Similar Exchange 2000/ 2007 message routing problem. (Full Version)

All Forums >> [Microsoft Exchange 2007] >> Migration



Message


hinek -> Similar Exchange 2000/ 2007 message routing problem. (25.Nov.2007 9:53:58 AM)

Dear all,

Iím having a problem after have installed my first Exchange 2007 server MB,HT,CA,MT.

Now I have two windows 2000 server domain controllers and two windows server 2003 domain controllers.

All FSMO roles and GC are on Windows 2003 server.

I have one Exchange 2000 sever also.

The domain level is in Windows 2000 native.

Exchange 2007 is part of the Exchange 2000 organization on his administrative group and a bidirectional routing connector, created during Exchange 2007 setup,  is percent on both, Exchange 2000 and Exchange 2007 routing groups.

Moving mail box between both Exchange servers works properly.

The problem is that after have moved a mail box in to the Exchange 2007, no message sent from Exchange 2000 server senders are delivered to recipients on Exchange 2007.

If I take a look at the Exchange 2000 message tracking Tool this is what I get:

11/25/2007 2:30 PM SMTP Store Driver: Message Submitted from Store
11/25/2007 2:30 PM SMTP Message Submitted to Advanced Queuilg
11/25/2007 2:30 PM SMTP Started Message Submission to Advanced Queue
11/25/2007 2:30 PM SMTP Message Submitted to Categorizer

When I take a look at the logs when an Exchange 2000 sender send an e-mail to an Exchange 2000 recipient I get this:

11/25/2007 2:38 PM SMTP Store Driver: Message Submitted from Store
11/25/2007 2:38 PM SMTP Message Submitted to Advanced Queuilg
11/25/2007 2:38 PM SMTP Started Message Submission to Advanced Queue
11/25/2007 2:38 PM SMTP Message Submitted to Categorizer
11/25/2007 2:38 PM SMTP Message Delivered Locally to user@mydomain.com
11/25/2007 2:38 PM SMTP Store Driver: Message Delivered Locally to Store to  user@mydomain.com

What do you think about all this ?

Many, Many thanks in advance!!




hinek -> RE: Similar Exchange 2000/ 2007 message routing problem. (26.Nov.2007 3:04:17 AM)

Hi all,

I wanted to supply you with more information about my problem.
After some time I get this messages on the Exchange 2000 message tracking tool:
11/25/2007 2 :30 PM SMTP :Message Submitted to Categorizer
11/25/2007 3 :43 PM SMTP :Started Outbound Tranfert of Message
11/25/2007 3 :53 PM SMTP :Message transferred to exchange2007.mycompany.com

So Exchange 2000 is aware about user mail box in on the Exchange 2007 and is forwarding the e-mails to it but Exchnge 2007 but nothing arrive on the user mail box.

Also Exchnage 2000 sender is getting the following Delivery Status Notification:

This is an automatically generated Delivery Status Notification.
THIS IS A WARNING MESSAGE ONLY.
YOU DO NOT NEED TO RESEND YOUR MESSAGE.
Delivery to the following recipients has been delayed.
      exchange2007recipient@mycompany.comNOSPAM

Many thanks in advance !




petefella -> RE: Similar Exchange 2000/ 2007 message routing problem. (27.Nov.2007 3:43:23 AM)

Hi Hinek,
I'm in a  very similar position. Have a new Exchange 2007 box in an existing exchange 2000 environment. I too can send mail from 2000 mailboxes to 2007. They get as far as the new server, but they don't get delivered.
If I look in the messages queues on the new exchange 2007 server, I can see the messages sat in the queue with the following error:

430 4.2.0. STOREDRV; mailbox logon failure

Also, when I try to send from a 2007 mailbox the messages just sit in the outbox.
Look like the Store Driver (which is responsible for delivering and picking up new messages) doesn't have permissions on the mailboxes.
Unfortunately, I don't know why yet.
Let me know if this is the same error you're seeing - if I find a fix, I'll let you know!




petefella -> RE: Similar Exchange 2000/ 2007 message routing problem. (27.Nov.2007 9:35:34 AM)

I finally gave up on trying to fix mine. I removed all the roles (and management tools) from the server, and reinstalled them again.
Lo and behold it's now working fine!

The only thing I can think of is that when I did the original install I installed straight from the DVD, which threw an error forcing me to try the install again. Apparently, it's advisable to copy the contents of the DVD to the server and run the install from there instead.

Good luck! :)




hinek -> RE: Similar Exchange 2000/ 2007 message routing problem. (27.Nov.2007 11:12:04 AM)

Hi there !

You are really loocky !!  :)

Here is what I get if I take a look at the receiving logs on the Exchange 2007.

2007-11-27T08:41:59.460Z,EXCH2007\Default EXCH2007,08C9FE67ABEC7C14,22,172.20.4.133:25,172.20.4.101:38346,<,MAIL FROM:<Administrator@mydomain.com>,
2007-11-27T08:41:59.460Z,EXCH2007\Default EXCH2007,08C9FE67ABEC7C14,23,172.20.4.133:25,172.20.4.101:38346,*,08C9FE67ABEC7C14;2007-11-27T08:41:59.256Z;1,receiving message
2007-11-27T08:41:59.460Z,EXCH2007\Default EXCH2007,08C9FE67ABEC7C14,24,172.20.4.133:25,172.20.4.101:38346,>,250 2.1.0 Sender OK,
2007-11-27T08:41:59.460Z,EXCH2007\Default EXCH2007,08C9FE67ABEC7C14,25,172.20.4.133:25,172.20.4.101:38346,<,RCPT TO:<user2007@mydomain.com>,
2007-11-27T08:41:59.460Z,EXCH2007\Default EXCH2007,08C9FE67ABEC7C14,26,172.20.4.133:25,172.20.4.101:38346,>,250 2.1.5 Recipient OK,
2007-11-27T08:41:59.460Z,EXCH2007\Default EXCH2007,08C9FE67ABEC7C14,27,172.20.4.133:25,172.20.4.101:38346,<,XEXCH50 1876 2,
2007-11-27T08:41:59.460Z,EXCH2007\Default EXCH2007,08C9FE67ABEC7C14,28,172.20.4.133:25,172.20.4.101:38346,>,354 Send binary data,
2007-11-27T08:46:59.387Z,EXCH2007\Default EXCH2007,08C9FE67ABEC7C12,29,172.20.4.133:25,172.20.4.101:38341,>,451 4.7.0 Timeout waiting for client input,
2007-11-27T08:46:59.387Z,EXCH2007\Default EXCH2007,08C9FE67ABEC7C12,30,172.20.4.133:25,172.20.4.101:38341,-,,Local
2007-11-27T08:47:00.387Z,EXCH2007\Default EXCH2007,08C9FE67ABEC7C14,29,172.20.4.133:25,172.20.4.101:38346,>,451 4.7.0 Timeout waiting for client input,
2007-11-27T08:47:00.387Z,EXCH2007\Default EXCH2007,08C9FE67ABEC7C13,29,172.20.4.133:25,172.20.4.101:38345,>,451 4.7.0 Timeout waiting for client input,

Many Many thanks in advance !




hinek -> RE: Similar Exchange 2000/ 2007 message routing problem. (27.Nov.2007 12:00:15 PM)

Dear all,

If I take a look at the Exchange 2000 Defaul SMTP Virtual Server, on Queues I find a Queue corresponding to my Exchnge 2000/Exchange 2007 Roting group connector. And the status is:

Total number of messages: 21
Total message size (KB):7
Time of submission of oldest message:
11/26/2007 11:22 AM
Time of next connection retry:
11/27/2007 6:08PM
Status: Retry
Remote delivery
The connection was dropped by the remote host.

Now for me is clear, Exchange 2007 is not acepting messages from Exchnag 2000 throuhg the RGC.

But why ??

Any subjestion???

Many thanks in advance !




hinek -> RE: Similar Exchange 2000/ 2007 message routing problem. (27.Nov.2007 5:10:46 PM)

Dear all,

I finally find the aswer to my problem.

My problem was exactly:

"Messages remain in an outbound queue until a non-delivery report is generated when you send e-mail to a remote domain"

Please take a look to this MS article. I dont have any firawall between my Exch2000 and my Exch2007 but after been created this Reg key value all e-mails from Exch2000 get in to Exch2007 MailBox !!!!

http://support.microsoft.com/kb/818222

Many thanks for your collaboration !!




petefella -> RE: Similar Exchange 2000/ 2007 message routing problem. (28.Nov.2007 2:57:17 AM)

[:)] Great! Glad you got it working...
I'll make a note of that article...could come in handy...




Page: [1]