• RSS
  • Twitter
  • FaceBook

Exchange Server Forums

Forums | Register | Login | My Profile | Inbox | RSS RSS icon | My Subscription | My Forums | Address Book | Member List | Search | FAQ | Ticket List | Log Out

Exchange 2007 EDGE Server NAT issue

Users viewing this topic: none

Logged in as: Guest
  Printable Version
All Forums >> [Microsoft Exchange 2007] >> Message Routing >> Exchange 2007 EDGE Server NAT issue Page: [1]
Login
Message << Older Topic   Newer Topic >>
Exchange 2007 EDGE Server NAT issue - 14.Dec.2007 6:19:51 AM   
TobiR

 

Posts: 1
Joined: 14.Dec.2007
Status: offline
Hi,

I have our 2 Exchange 2007 EDGE Servers published to the internet via ISA Server Array.

The problem is that we have 2 dedicated IP addresses on the external adapter that are assigned to the SMTP Servers. These are VIP's across the NLB array for the ISA's

i.e. 73.60.135.189 &  73.60.135.190

these are set to point to reverse dns records to return mail1.mydomain.com and mail2.mydomain.com

but the primary NLB addresses are  73.60.135.130 &  73.60.135.131 and VIP ( 73.60.135.132)

the problem is when the mail servers relay messages outside the network the address is not nat'd and will come from either edge server but with a source ip of either  73.60.135130 /  73.60.135.131 this in turn does not have a reverse DNS record and the detination SMTP Server will knock back the message with an error

When mail is relayed to us it hit the correct ip address on the server because it is published and we have no problem.

How do i make the outbound initiated connection appear it comes from the correct ip address and not just the phyiscal ip of the adapter that is on the ISA Server.

Regards

Tobi

p.s. posted to isaserver.org as well.
Post #: 1
RE: Exchange 2007 EDGE Server NAT issue - 17.Dec.2007 11:47:42 AM   
John Weber

 

Posts: 1236
Joined: 20.Apr.2005
From: Portland, Oregon
Status: offline
Get ahold of your ISP that provides your IP space and have them rev ptr both outside IP's to your mx record.

-jmw

(in reply to TobiR)
Post #: 2

Page:   [1] << Older Topic    Newer Topic >>
All Forums >> [Microsoft Exchange 2007] >> Message Routing >> Exchange 2007 EDGE Server NAT issue Page: [1]
Jump to:

New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Follow TechGenix on Twitter