• RSS
  • Twitter
  • FaceBook

Exchange Server Forums

Forums | Register | Login | My Profile | Inbox | RSS RSS icon | My Subscription | My Forums | Address Book | Member List | Search | FAQ | Ticket List | Log Out

"Sent items" sync issue

Users viewing this topic: none

Logged in as: Guest
  Printable Version
All Forums >> [Microsoft Exchange 2007] >> Mobility >> "Sent items" sync issue Page: [1]
Login
Message << Older Topic   Newer Topic >>
"Sent items" sync issue - 14.Dec.2007 6:11:17 PM   
rxb216

 

Posts: 3
Joined: 14.Dec.2007
Status: offline
Hi,

I searched around for this problem but really didn't find this documented anywhere, so here goes.

I am on the client side of things, using both a laptop and handheld device that are sync'ed to a remote Exchange Server 2007 with Service Pack 1. My email is being hosted through this 3rd party exchange server (webville.net)

My handheld device runs the latest version of Windows Mobile 6 and my laptop has outlook 2007 SP1.

I've been just fine for the past 2 months, when all of a sudden my "sent items" folder does not sync right. (I did not change any settings either)

My problem is that when I send an email FROM my handheld device device:

1. I never get a copy of it in my handheld's "sent items" folder

AND ALSO

2. My laptop (also connected to the exchange server) never gets the copy of the email in its "sent items" folder, which was sent from the handheld


Just for a sanity check, whenever i send an email to myself (from handheld), I DO get it in my inbox (both laptop and handheld).

And if I send an email from my laptop, it DOES appear on the handheld's "sent items", so that part is working.

Even deleting email from the handheld does delete it from the exchange server.

Furthermore, when i delete an email from the handheld's sent items folder, it DOES delete from the exchange server. So all of that is working just fine.

The ONLY problem is when I SEND email from the handheld ONLY, that the message never appears in the "sent items" of both the handheld and the laptop. (The message does get sent, but the exchange server never somehow retains a copy of it!). This part seems broken.

Of course I have the setting "keep copies of sent items in sent folder" ENABLED on my handheld and also i have made sure the "sent items" folder is enabled for wireless SYNC on both the handheld and the laptop (its a common setting anyways)

My hosting provider uses exchange server 2007 and recently (last week) applied the SP1 update

Any ideas? Did my hosting company mess something up when they applied the service pack 1 on the exchange server 2007?

I went ahead and deleted the activesync relationship between my handheld and the exchange server, and created a new one (this wiped the email off the device and then it re-downloaded it). This did NOT solve the problem. I still can't get the email in the sent items folders whenever I send an email from the device...
Post #: 1
RE: "Sent items" sync issue - 21.Dec.2007 4:58:26 AM   
rishishah

 

Posts: 784
Joined: 14.Nov.2006
From: Surrey, UK
Status: offline
Well you have done everthing correctly so far... what about a total wipe of the WM device and starting fresh.

_____________________________

Rishi Shah, MCP

Remember to backup before applying the advice. www.saiconsult.co.uk. Happy to provide Professional Exchange Server Consultancy to anywhere in the world.

(in reply to rxb216)
Post #: 2
RE: "Sent items" sync issue - 21.Dec.2007 12:35:53 PM   
rxb216

 

Posts: 3
Joined: 14.Dec.2007
Status: offline
I wiped my device on Dec 18 as a last resort. I surprised to see that the number of nerds on this site had no input to my issue and I was tired of waiting for a response after so long. Looks like this "mobility" forum is not utilized much as I dont see many posts or replies (just views).

Of course the wipe worked but it also resulted in hours of restoring software back on the device. I was hoping someone could take a guess as to what was going on... Oh well... I know this was a device issue, but it was for sure MS Activesync (via OTA) related...

(in reply to rishishah)
Post #: 3
RE: "Sent items" sync issue - 10.Jan.2008 7:03:01 AM   
rishishah

 

Posts: 784
Joined: 14.Nov.2006
From: Surrey, UK
Status: offline
Your comments are quite unhelpfull.

This is a free forrum where people try to help and what you have said is very unprofessional.

Now when you say you used hours restoring software on your device...this clearly means you have a lot of 3rd party software on your WM device... you may wish to look at this as this might be the cause of your issues.

You may find that some 3rd party software is badly written and can cause issues.

_____________________________

Rishi Shah, MCP

Remember to backup before applying the advice. www.saiconsult.co.uk. Happy to provide Professional Exchange Server Consultancy to anywhere in the world.

(in reply to rxb216)
Post #: 4
RE: "Sent items" sync issue - 10.Jan.2008 10:42:51 AM   
rxb216

 

Posts: 3
Joined: 14.Dec.2007
Status: offline
Rishi,

Thanks for your response, it really made my day. It took almost a month for your suggestion that 3rd party software might be the culprit? It would have been nice if I could have heard that or anything perhaps in mid-December. I might have tried a different path if I knew that suggestion of yours.

Honestly my comment was just to poke a little bit of fun in an otherwise boring IT existence, so don't take it so seriously.

I think I described my problem in great detail so I was hoping for some sort of comment. I posted this issue here because I didn't think the problem was device specific or even hardware related. A clean wipe most certainly will cure all ailments, but we're engineers here (present company included), and we should try to troubleshoot rather than reset. My device was working just dandy for months, and all of a sudden this issue happens? Sounds like more than just 3rd party software can be the cause. I've fully reloaded my apps and have been fine since December, so I'm not thinking it was my apps. My gut was that it was synchronization issues with the server.

Also what good is a Windows Mobile device without 3rd party software? You might as well buy a house and not furnish it. We might as well start enforcing strict Blackberry-like IT policies on our devices like RIM can do, but that wouldn't be any fun for us end users.

I could have posted this to ppcgeeks, pdaphonehome, or even xda-developers, but I thought I would give this a shot here. Most people in those other forums will reply with something within at least a week, even if it's a vague idea. Are you the only one responding to people's threads? I don't see many other users posting replies…Maybe you're the only one that knows anything around here…

< Message edited by rxb216 -- 10.Jan.2008 10:46:25 AM >

(in reply to rishishah)
Post #: 5
RE: "Sent items" sync issue - 11.Jan.2008 4:05:24 AM   
rishishah

 

Posts: 784
Joined: 14.Nov.2006
From: Surrey, UK
Status: offline
Unless the 3rd party software you use has been fully tested and validated...they could have loads of issues which could corrupt the Windows Mobile OS.

So try annd avoid using software that is not fully tested, unless of course you dont mid re-building.

_____________________________

Rishi Shah, MCP

Remember to backup before applying the advice. www.saiconsult.co.uk. Happy to provide Professional Exchange Server Consultancy to anywhere in the world.

(in reply to rxb216)
Post #: 6

Page:   [1] << Older Topic    Newer Topic >>
All Forums >> [Microsoft Exchange 2007] >> Mobility >> "Sent items" sync issue Page: [1]
Jump to:

New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Follow TechGenix on Twitter